Bug 148755 - freezes at boot unless acpi=off
freezes at boot unless acpi=off
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
3
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Dave Jones
Brian Brock
:
Depends On:
Blocks: FCMETA_ACPI
  Show dependency treegraph
 
Reported: 2005-02-15 06:04 EST by Dimitri Papadopoulos
Modified: 2015-01-04 17:16 EST (History)
3 users (show)

See Also:
Fixed In Version: FC3
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-12-07 02:53:42 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
dmesg output (kernel 2.6.10-1.14_FC2smp with acpi=off) (14.02 KB, text/plain)
2005-02-15 06:04 EST, Dimitri Papadopoulos
no flags Details
startup logs (10.69 KB, text/plain)
2005-05-19 09:48 EDT, Dimitri Papadopoulos
no flags Details

  None (edit)
Description Dimitri Papadopoulos 2005-02-15 06:04:28 EST
Description of problem:
Freezes when booting, just after rhgb displays "Setting up system clock".
This is on a dual-processor Dell Precision 670, using the SMP kernel.
BIOS was updated from A02 to A03 but this didn't help.
Reproduced with 2.6.10-1.9_FC2, 2.6.10-1.12_FC2, and 2.6.10-1.14_FC2.
Works just fine with 2.6.9-1.11_FC2.
Adding "acpi=off" works around the problem, the system boots and works fine.

Version-Release number of selected component (if applicable):
2.6.10-1.9_FC2
2.6.10-1.12_FC2
2.6.10-1.14_FC2

How reproducible:
Always.

Additional info:
See also http://www.fedoraforum.org/forum/showthread.php?t=32534
Comment 1 Dimitri Papadopoulos 2005-02-15 06:04:28 EST
Created attachment 111079 [details]
dmesg output (kernel 2.6.10-1.14_FC2smp with acpi=off)
Comment 2 Dave Jones 2005-04-16 01:46:12 EDT
Fedora Core 2 has now reached end of life, and no further updates will be
provided by Red Hat.  The Fedora legacy project will be producing further kernel
updates for security problems only.

If this bug has not been fixed in the latest Fedora Core 2 update kernel, please
try to reproduce it under Fedora Core 3, and reopen if necessary, changing the
product version accordingly.

Thank you.
Comment 3 Dimitri Papadopoulos 2005-04-17 05:57:53 EDT
Come on. This bug has been there for long enough to be at least reproduced if
not fixed. It's not fair to leave it there and ask the reporter to reopen it
periodically.

Actually I haven't tried with FC3 and I can't update that particular workstation
right now, but I can reproduce that with the following FC2 kernel:
2.6.10-1.771_FC2. Since this version of the kernel is also available with FC3
I'm 100% certain the bug is still present in FC3.
Comment 4 Venkatesh Pallipadi 2005-04-17 09:04:51 EDT
Can you provide the dmesg output (using serial probably) when the system
actually hangs.. 
Comment 5 Dimitri Papadopoulos 2005-05-13 09:36:09 EDT
Is there any HOWTO for capturing boot messages through serial port?

I've searched the Red Hat manuals and Google withotu finding anything useful.


For what it's worth, I've tried booting with these options:
console=tty0 console=ttyS0,9600

Unfortunately:
1) I'm not sure how to capture the serial flow on the other end. I've tried:
cat /dev/ttyS0 > /LOG
but the result is not nice (looks like ANSI control chars garble the messages)
2) The boot process looks like it stops inside initrc when using the serial
console, sooner than without the serial.
Comment 6 Dimitri Papadopoulos 2005-05-18 01:24:37 EDT
Just answering myself for the benefit of users who read this bug report.

The main reference seems to be:
http://howtos.linux.com/howtos/Remote-Serial-Console-HOWTO/
but see also:
http://www.sabalsoftware.com/article_debuggingKernelModules.php
http://www.cpqlinux.com/boot_err_capture.html

I'll try captruring boot messages again.
Comment 7 Dimitri Papadopoulos 2005-05-19 09:47:15 EDT
Pheeew... I took 3 skilled programmers a few days to find a solution how to
retrieve boot messages from serial. It turned out minicom wasn't set up
properly. It would really be nice to describe basic kernel "debugging" in the
manuals, it's far from being straightforward.

Anyway, please find the logs attached. Please note that the system hangs while
init launches services, after the kernel has booted.
Comment 8 Dimitri Papadopoulos 2005-05-19 09:48:01 EDT
Created attachment 114567 [details]
startup logs
Comment 9 Dave Jones 2005-07-15 16:09:52 EDT
An update has been released for Fedora Core 3 (kernel-2.6.12-1.1372_FC3) which
may contain a fix for your problem.   Please update to this new kernel, and
report whether or not it fixes your problem.

If you have updated to Fedora Core 4 since this bug was opened, and the problem
still occurs with the latest updates for that release, please change the version
field of this bug to 'fc4'.

Thank you.
Comment 10 Dave Jones 2005-12-07 02:53:42 EST
This bug has been mass-closed along with all other bugs that
have been in NEEDINFO state for several months.

Due to the large volume of inactive bugs in bugzilla, this
is the only method we have of cleaning out stale bug reports
where the reporter has disappeared.

If you can reproduce this bug with current FC3 updates, please
reopen this bug.

If you are not the reporter, you can add a comment requesting
it be reopened, and someone will get to it asap.

If you are not the reporter, but can reproduce this problem against
FC4, please open a new bug.

Thank you.
Comment 11 Dimitri Papadopoulos 2005-12-07 04:16:01 EST
Just FYI, we have upgraded our Dell Precision 670 workstations form FC2 to FC4
and "acpi=off" is not needed anymore. As far as I'm concerned the bug is indeed
fixed.
Comment 12 Dave Jones 2005-12-07 14:41:47 EST
good to hear, thanks for the update.

Note You need to log in before you can comment on or make changes to this bug.