Bug 1487560 - [iSCSI] ovirt-hosted-engine-setup fails if none of the discovered target is associated to the accessed portal
[iSCSI] ovirt-hosted-engine-setup fails if none of the discovered target is a...
Status: CLOSED ERRATA
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-hosted-engine-setup (Show other bugs)
4.1.5
Unspecified Unspecified
medium Severity medium
: ovirt-4.2.0
: ---
Assigned To: Simone Tiraboschi
Nikolai Sednev
: EasyFix, Triaged, ZStream
Depends On:
Blocks: 1458709 1490202
  Show dependency treegraph
 
Reported: 2017-09-01 05:29 EDT by Simone Tiraboschi
Modified: 2018-05-15 13:33 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Fixed a SAN multipath configuration that was occasionally preventing ovirt-hosted-engine-setup from working correctly.
Story Points: ---
Clone Of:
: 1490202 (view as bug list)
Environment:
Last Closed: 2018-05-15 13:32:28 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: Integration
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
oVirt gerrit 81298 master POST storage: better validate iSCSI portal info 2017-09-01 05:36 EDT
Red Hat Product Errata RHBA-2018:1471 None None None 2018-05-15 13:33 EDT

  None (edit)
Description Simone Tiraboschi 2017-09-01 05:29:13 EDT
Description of problem:
ovirt-hosted-engine-setup is currently failing if, due to a bad multipath configuration on SAN side, the user tries to access an iSCSI portal where iSCSI discovery finds targets but not one of them is associated with the accessed portal.

Example:
2017-08-31 12:59:04 DEBUG otopi.plugins.otopi.dialog.machine dialog.__logString:204 DIALOG:SEND       ### Please specify the iSCSI portal IP address: 
2017-08-31 12:59:12 DEBUG otopi.plugins.otopi.dialog.machine dialog.__logString:204 DIALOG:RECEIVE    192.168.96.205

2017-08-31 12:59:23 DEBUG otopi.plugins.gr_he_setup.storage.blockd blockd._iscsi_discovery:320 {'status': {'message': 'Done', 'code': 0}, 'items': [u'192.168.96.206:3260,2460 iqn.2007-11.***.************:************-01-v04c505ca8ddf8aed.000000a2.891a8f27', u'192.168.96.207:3260,2460 iqn.2007-11.***.************:************-01-v04c505ca8ddf8aed.000000a2.891a8f27', u'192.168.96.206:3260,2460 iqn.2007-11.***.************:************-02-v04c505ca8ddf8aed.000000a3.891a8f27', u'192.168.96.207:3260,2460 iqn.2007-11.***.************:************-02-v04c505ca8ddf8aed.000000a3.891a8f27']}
2017-08-31 12:59:23 DEBUG otopi.plugins.gr_he_setup.storage.blockd blockd._iscsi_discovery:337 found: []

And then the code fails on:
2017-08-31 12:45:23 DEBUG otopi.plugins.gr_he_setup.storage.blockd
blockd._iscsi_discovery:337 found: []
2017-08-31 12:45:23 DEBUG otopi.context context._executeMethod:142
method exception
Traceback (most recent call last):
  File "/usr/lib/python2.7/site-packages/otopi/context.py", line 132,
in _executeMethod
    method['method']()
  File "/usr/share/ovirt-hosted-engine-setup/scripts/../plugins/gr-he-setup/storage/blockd.py",
line 611, in _customization
    default=valid_targets[0]
IndexError: list index out of range

Version-Release number of selected component (if applicable):
4.1.5

How reproducible:
100%

Steps to Reproduce:
1. run hosted-engine-setup ad try to connect to an iSCSI portal that reports just targets associated to other portals
2.
3.

Actual results:
line 611, in _customization
    default=valid_targets[0]
IndexError: list index out of range

Expected results:
It loops till the user enters a valid configuration

Additional info:
Comment 4 Nikolai Sednev 2017-09-26 11:51:02 EDT
Forth to https://bugzilla.redhat.com/show_bug.cgi?id=1490202#c4 and to that on latest ovirt-hosted-engine-setup-2.2.0-0.0.master.20170919052946.git896e399.el7.centos.noarch I was not able to reproduce the issue, moving to verified.
Please reopen if you still experience this issue.
Comment 7 errata-xmlrpc 2018-05-15 13:32:28 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2018:1471

Note You need to log in before you can comment on or make changes to this bug.