Bug 1487585 - Incorrectly logging as error message on HBA channel search
Summary: Incorrectly logging as error message on HBA channel search
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat OpenStack
Classification: Red Hat
Component: python-os-brick
Version: 10.0 (Newton)
Hardware: Unspecified
OS: Unspecified
low
medium
Target Milestone: z6
: 10.0 (Newton)
Assignee: Gorka Eguileor
QA Contact: Tzach Shefi
URL:
Whiteboard:
Depends On: 1487582
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-09-01 10:48 UTC by Gorka Eguileor
Modified: 2018-08-03 08:34 UTC (History)
9 users (show)

Fixed In Version: python-os-brick-1.6.1-7.el7ost
Doc Type: Bug Fix
Doc Text:
During FC scan we were logging failure to find target and channel to limit the scanning as an error, now we correctly log it as debug information.
Clone Of: 1487582
Environment:
Last Closed: 2017-11-15 13:45:13 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
OpenStack gerrit 424747 0 None MERGED Change log level on _get_hba_channel_scsi_target 2020-09-28 18:35:53 UTC
Red Hat Product Errata RHBA-2017:3231 0 normal SHIPPED_LIVE Red Hat OpenStack Platform 10 director Bug Fix Advisory 2017-11-15 18:36:45 UTC

Description Gorka Eguileor 2017-09-01 10:48:54 UTC
+++ This bug was initially created as a clone of Bug #1487582 +++

On the FC initiator, when we are doing a scan we try to narrow the scope of the scan as much as possible, for this purpose we try to get the HBA channel and SCSI targets for an HBA.

Unfortunately the mechanism we have implemented to detect these two parameters is not universal and will only work on FC targets that implement a single WWN.

This is OK, as the code is capable of operating normally without those 2 parameters, it's just that the filtering on the scan is not as precise as it could be.

So the issue is that we are logging as an error when we cannot get that information, which is clearly misleading to anybody reading the logs.

Comment 6 errata-xmlrpc 2017-11-15 13:45:13 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2017:3231


Note You need to log in before you can comment on or make changes to this bug.