Bug 14876 - inetd accumulates fd's
Summary: inetd accumulates fd's
Status: CLOSED DUPLICATE of bug 11548
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: inetd   
(Show other bugs)
Version: 6.2
Hardware: i386
OS: Linux
high
medium
Target Milestone: ---
Assignee: Jeff Johnson
QA Contact:
URL:
Whiteboard:
Keywords:
: 12779 14687 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2000-07-31 12:45 UTC by ae
Modified: 2008-05-01 15:37 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-08-03 10:27:39 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description ae 2000-07-31 12:45:34 UTC
if /etc/inetd.conf turns on the time/tcp service,
then connections are left in a CLOSE_WAIT state.

For me, a handful of Solaris and Linux clients will
cause the server's inetd to reach its fd limit
in a few days.  

RHL 6.2, kernel-2.2.14-12 (686, smp),  inetd-0.16-4

Comment 1 Jeff Johnson 2000-08-01 21:34:41 UTC
*** Bug 14687 has been marked as a duplicate of this bug. ***

Comment 2 Jeff Johnson 2000-08-01 21:45:30 UTC
*** Bug 12779 has been marked as a duplicate of this bug. ***

Comment 3 h0e 2000-08-03 10:27:39 UTC
heh.
--- netkit-base-0.16/inetd/inetd.c~	Wed Nov 24 06:31:53 1999
+++ netkit-base-0.16/inetd/inetd.c	Thu Aug  3 20:25:17 2000
@@ -485,12 +485,12 @@
 			FD_CLR(sep->se_fd, &allsock);
 			nsock--;
 		}
-		if (!sep->se_wait && sep->se_socktype == SOCK_STREAM)
-			close(ctrl);
 	}
 	else {
 		sep->se_bi->bi_fn(ctrl, sep);
 	}
+	if (ctrl != sep->se_fd)
+		close(ctrl);
 }
 
 static


Comment 4 Pekka Savola 2000-08-07 08:10:51 UTC

*** This bug has been marked as a duplicate of 11548 ***


Note You need to log in before you can comment on or make changes to this bug.