Bug 1487600 - subscription-manager-cockpit does not save proxy settings into /etc/rhsm/rhsm.conf file
Summary: subscription-manager-cockpit does not save proxy settings into /etc/rhsm/rhsm...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: subscription-manager
Version: 7.5
Hardware: Unspecified
OS: Unspecified
medium
medium
Target Milestone: rc
: ---
Assignee: Jiri Hnidek
QA Contact: Jan Stavel
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-09-01 11:08 UTC by Jan Stavel
Modified: 2018-04-10 09:51 UTC (History)
5 users (show)

Fixed In Version: subscription-manager-1.20.10-1
Doc Type: No Doc Update
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-04-10 09:51:13 UTC


Attachments (Terms of Use)
Proxy details used while registering (229.39 KB, image/png)
2017-12-15 14:55 UTC, Shwetha Kallesh
no flags Details


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2018:0681 None None None 2018-04-10 09:51:43 UTC
Github candlepin subscription-manager pull 1734 None None None 2017-11-24 21:31:40 UTC
Github candlepin subscription-manager pull 1752 None None None 2018-01-05 15:39:20 UTC

Description Jan Stavel 2017-09-01 11:08:58 UTC
Description of problem:

If I use proxy server for registering a system no proxy settings are stored in a configuration file /etc/rhsm/rhsm.conf.

Version-Release number of selected component (if applicable):


How reproducible:

Each time.

Steps to Reproduce:
1. open page 'Subscriptions' in cockpit app
2. unregister system if it is registered
3. click 'Register' button
4. check 'Use proxy server'
5. fill fields for proxy connection
6. fill fields for subscription
7. click 'Register' button
8. check values in /etc/rhsm/rhsm.conf (proxy_hostname, proxy_username)

Actual results:

No settings stored in the file.

Expected results:

The settings should be stored and offered each time I do register.

Additional info:

Comment 2 Kevin Howell 2017-09-07 15:42:33 UTC
Note: this *may* be fixed simply by using our new D-Bus services. (Dev should verify).

Comment 3 Jiri Hnidek 2017-11-24 13:07:40 UTC
It seems that it is necessary to explicitly save proxy settings using D-Bus method Set() from path /com/redhat/RHSM1/Config.

Comment 5 Shwetha Kallesh 2017-12-15 14:55:40 UTC
Created attachment 1368518 [details]
Proxy details used while registering

Comment 6 Shwetha Kallesh 2017-12-15 15:02:09 UTC
Marking bug as failed_qa as I do not see the proxy details used while registering via cockpit being saved into rhsm.conf

[root@bkr-hv01-guest15 ~]# rpm -qa | grep cockpit
cockpit-ws-154-2.el7.x86_64
cockpit-doc-154-2.el7.x86_64
cockpit-bridge-154-2.el7.x86_64
cockpit-154-2.el7.x86_64
cockpit-pcp-154-2.el7.x86_64
cockpit-system-154-2.el7.noarch
subscription-manager-cockpit-1.20.8-1.el7.noarch


[root@bkr-hv01-guest15 ~]# cat /etc/rhsm/rhsm.conf | grep proxy
# an http proxy server to use
proxy_hostname =  
# port for http proxy server
proxy_port =  
# user name for authenticating to an http proxy, if needed
proxy_user = 
# password for basic http proxy auth, if needed
proxy_password = 
# host/domain suffix blacklist for proxy, if needed
no_proxy =

Comment 7 Shwetha Kallesh 2018-01-31 07:36:12 UTC
Moving bug to verified as I see the proxy details used while registering via cockpit being saved into rhsm.conf

Verifying version:

[root@bkr-hv03-guest18 ~]# rpm -qa | grep cockpit
cockpit-160-2.el7.x86_64
cockpit-bridge-160-2.el7.x86_64
subscription-manager-cockpit-1.20.10-1.el7.noarch
cockpit-system-160-2.el7.noarch
cockpit-ws-160-2.el7.x86_64


Before registering:

[root@bkr-hv03-guest18 ~]# cat /etc/rhsm/rhsm.conf | grep proxy
# an http proxy server to use
proxy_hostname =
# port for http proxy server
proxy_port =
# user name for authenticating to an http proxy, if needed
proxy_user =
# password for basic http proxy auth, if needed
proxy_password =
# host/domain suffix blacklist for proxy, if needed
no_proxy =


After Registering:

[root@bkr-hv03-guest18 ~]# cat /etc/rhsm/rhsm.conf | grep proxy
# an http proxy server to use
proxy_hostname =auto-services.usersys.redhat.com
# port for http proxy server
proxy_port =3129
# user name for authenticating to an http proxy, if needed
proxy_user =
# password for basic http proxy auth, if needed
proxy_password =
# host/domain suffix blacklist for proxy, if needed
no_proxy =

Comment 10 errata-xmlrpc 2018-04-10 09:51:13 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2018:0681


Note You need to log in before you can comment on or make changes to this bug.