Bug 1487688 - subscription-manager-cockpit does not prefill "Registration" dialog by proxy settings from /etc/rhsm/rhsm.conf file
Summary: subscription-manager-cockpit does not prefill "Registration" dialog by proxy ...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: subscription-manager
Version: 7.5
Hardware: Unspecified
OS: Unspecified
medium
medium
Target Milestone: rc
: ---
Assignee: candlepin-bugs
QA Contact: John Sefler
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-09-01 15:30 UTC by Jan Stavel
Modified: 2018-04-10 09:51 UTC (History)
4 users (show)

Fixed In Version: subscription-manager-1.20.6-1
Doc Type: No Doc Update
Doc Text:
undefined
Clone Of:
Environment:
Last Closed: 2018-04-10 09:51:13 UTC


Attachments (Terms of Use)
DOesnot prefill proxy details (94.36 KB, image/png)
2017-12-08 14:00 UTC, Shwetha Kallesh
no flags Details
Doesnot prefill proxy details in Subscription-manager tab (101.02 KB, image/png)
2017-12-09 04:24 UTC, Shwetha Kallesh
no flags Details
proxy details are pre-filled with values from rhsm.conf file (98.19 KB, image/png)
2017-12-15 09:05 UTC, Shwetha Kallesh
no flags Details


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2018:0681 None None None 2018-04-10 09:51:43 UTC
Github candlepin subscription-manager pull 1725 None None None 2017-11-09 20:18:50 UTC

Description Jan Stavel 2017-09-01 15:30:05 UTC
Description of problem:

If there are proxy related values in /etc/rhsm/rhsm.conf file
Subscription plugin should display that values in "Registration" dialog.

Version-Release number of selected component (if applicable):


How reproducible:

Each time.

Steps to Reproduce:
1. unregister system
2. update the file /etc/rhsm/rhsm.conf by values:
   proxy_hostname = auto-services.usersys.redhat.com
   proxy_port = 3129
   proxy_user = 
   proxy_password =
   ... this is no auth proxy

3. launch Cockpit app in browser and log-in as 'root' user
4. Click on 'Subscriptions'
5. Click on 'Register' button


Actual results:

Check box 'Use proxy server' is not checked.
No value appears in field 'Server'

Expected results:

There should be values in the dialog fields the same as in /etc/rhsm/rhsm.conf file.

Additional info:

Comment 3 Shwetha Kallesh 2017-12-08 14:00:54 UTC
Created attachment 1364877 [details]
DOesnot prefill proxy details

Moving bug back to new, dont see fix yet in the following build:

[root@dhcp35-150 ~]# rpm -qa | grep cockpit
cockpit-packagekit-157-1.el7.x86_64
cockpit-ws-157-1.el7.x86_64
subscription-manager-cockpit-1.20.7-1.el7.noarch
cockpit-157-1.el7.x86_64
cockpit-bridge-157-1.el7.x86_64
cockpit-tests-157-1.el7.x86_64
cockpit-system-157-1.el7.noarch
cockpit-doc-157-1.el7.x86_64

[root@dhcp35-150 ~]# cat /etc/rhsm/rhsm.conf | grep proxy
# an http proxy server to use
proxy_hostname = auto-services.usersys.redhat.com
# port for http proxy server
proxy_port = 3129
# user name for authenticating to an http proxy, if needed
proxy_user =
# password for basic http proxy auth, if needed
proxy_password =
# host/domain suffix blacklist for proxy, if needed
no_proxy =

Comment 5 Shwetha Kallesh 2017-12-09 04:24:18 UTC
Created attachment 1365157 [details]
Doesnot prefill proxy details in Subscription-manager tab

Sorry about the wrong screenshot, I dont see the proxy details being prefilled in subscription-manager tab too with followng version of subscription-manager-cockpit

[root@dhcp35-150 ~]# rpm -qa | grep subscription-manager-cockpit
subscription-manager-cockpit-1.20.7-1.el7.noarch

Proxy details in the rhsm.conf file:
[root@dhcp35-150 ~]# cat /etc/rhsm/rhsm.conf | grep proxy
# an http proxy server to use
proxy_hostname = auto-services.usersys.redhat.com
# port for http proxy server
proxy_port = 3129
# user name for authenticating to an http proxy, if needed
proxy_user =
# password for basic http proxy auth, if needed
proxy_password =
# host/domain suffix blacklist for proxy, if needed
no_proxy =

Comment 6 Shwetha Kallesh 2017-12-15 09:05:48 UTC
Created attachment 1368400 [details]
proxy details are pre-filled with values from rhsm.conf file

Proxy details are pre-filled with values from rhsm.conf file so marking bug as verified 

[root@bkr-hv01-guest15 ~]# rpm -qa | grep cockpit
cockpit-ws-154-2.el7.x86_64
cockpit-doc-154-2.el7.x86_64
cockpit-bridge-154-2.el7.x86_64
cockpit-154-2.el7.x86_64
cockpit-pcp-154-2.el7.x86_64
cockpit-system-154-2.el7.noarch
subscription-manager-cockpit-1.20.8-1.el7.noarch


[root@bkr-hv01-guest15 ~]# cat /etc/rhsm/rhsm.conf | grep proxy
# an http proxy server to use
proxy_hostname = auto-services.usersys.redhat.com 
# port for http proxy server
proxy_port = 3128 
# user name for authenticating to an http proxy, if needed
proxy_user = 
# password for basic http proxy auth, if needed
proxy_password = 
# host/domain suffix blacklist for proxy, if needed
no_proxy =

Comment 9 errata-xmlrpc 2018-04-10 09:51:13 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2018:0681


Note You need to log in before you can comment on or make changes to this bug.