Bug 1487782 - Request Failed during periodic task operation full_sync
Summary: Request Failed during periodic task operation full_sync
Keywords:
Status: CLOSED DUPLICATE of bug 1477516
Alias: None
Product: Red Hat OpenStack
Classification: Red Hat
Component: python-networking-odl
Version: 12.0 (Pike)
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
: ---
Assignee: Mike Kolesnik
QA Contact: Toni Freger
URL:
Whiteboard:
: 1487784 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-09-01 21:59 UTC by Sai Sindhur Malleni
Modified: 2018-10-24 12:41 UTC (History)
0 users

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
N/A
Last Closed: 2017-09-04 07:07:37 UTC
Target Upstream Version:


Attachments (Terms of Use)

Description Sai Sindhur Malleni 2017-09-01 21:59:40 UTC
Description of problem: When running a Browbeat+Rally use case which does:
Create a network
Create a sbunet
Create a router
Attach router to subnet and oublic network
Boot VM with floating IP
Ping VM

with concurrency 8 and times set to 50 we see that some VMs remain unpingable even after 300 seconds and we see the following in neutron server logs:


2017-09-01 16:14:09.587 28160 ERROR networking_odl.journal.periodic_task [req-3d92e94d-77db-4022-8999-2c32f04402ab - - - - -] Failed during periodic task operation full_sync.: AttributeError: 'NoneType' object has no attribute 'get_policies'
2017-09-01 16:14:09.587 28160 ERROR networking_odl.journal.periodic_task Traceback (most recent call last):
2017-09-01 16:14:09.587 28160 ERROR networking_odl.journal.periodic_task   File "/usr/lib/python2.7/site-packages/networking_odl/journal/periodic_task.py", line 61, in _execute_op
2017-09-01 16:14:09.587 28160 ERROR networking_odl.journal.periodic_task     operation(context=context)
2017-09-01 16:14:09.587 28160 ERROR networking_odl.journal.periodic_task   File "/usr/lib/python2.7/site-packages/networking_odl/journal/full_sync.py", line 84, in full_sync
2017-09-01 16:14:09.587 28160 ERROR networking_odl.journal.periodic_task     collection_name)
2017-09-01 16:14:09.587 28160 ERROR networking_odl.journal.periodic_task   File "/usr/lib/python2.7/site-packages/networking_odl/journal/full_sync.py", line 119, in _sync_resources
2017-09-01 16:14:09.587 28160 ERROR networking_odl.journal.periodic_task     obj_getter = getattr(plugin, 'get_%s' % collection_name)
2017-09-01 16:14:09.587 28160 ERROR networking_odl.journal.periodic_task AttributeError: 'NoneType' object has no attribute 'get_policies'
2017-09-01 16:14:09.587 28160 ERROR networking_odl.journal.periodic_task



 

Version-Release number of selected component (if applicable):
OSP12
python-networking-odl-11.0.0-0.20170806093629.2e78dca.el7ost.noarch


How reproducible:
100%

Steps to Reproduce:
1. Deploy overcloud with ODL
2. Run custom Browbeat+Rally plugin which boots vm nad ping sfloatingip
3. 

Actual results:
Tracebacks in neutron server logs

Expected results:
No tracebacks in neutron server logs

Additional info:

Comment 1 Sai Sindhur Malleni 2017-09-01 22:56:04 UTC
*** Bug 1487784 has been marked as a duplicate of this bug. ***

Comment 2 Mike Kolesnik 2017-09-04 07:07:37 UTC

*** This bug has been marked as a duplicate of bug 1477516 ***


Note You need to log in before you can comment on or make changes to this bug.