Bug 1487791 - Thread terminated due to uncaught NullPointerException
Summary: Thread terminated due to uncaught NullPointerException
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat OpenStack
Classification: Red Hat
Component: opendaylight
Version: 12.0 (Pike)
Hardware: Unspecified
OS: Unspecified
high
high
Target Milestone: beta
: 13.0 (Queens)
Assignee: Sam Hague
QA Contact: Sai Sindhur Malleni
URL:
Whiteboard: scale_lab
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-09-01 22:41 UTC by Sai Sindhur Malleni
Modified: 2018-10-18 07:23 UTC (History)
4 users (show)

Fixed In Version: opendaylight-8.0.0-3.el7ost
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
N/A
Last Closed: 2018-06-27 13:36:15 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
OpenDaylight Bug 9190 None None None 2017-09-20 14:38:15 UTC
OpenDaylight gerrit 63343 None None None 2017-09-20 15:30:24 UTC
Red Hat Product Errata RHEA-2018:2086 None None None 2018-06-27 13:37:07 UTC

Description Sai Sindhur Malleni 2017-09-01 22:41:01 UTC
Description of problem:

When running a Browbeat+Rally use case which does:
Create a network
Create a sbunet
Create a router
Attach router to subnet and oublic network
Boot VM with floating IP
Ping VM

with concurrency 8 and times set to 50 we see that some VMs remain unpingable even after 300 seconds and we see a lot of the following exceptions in karaf logs

2017-09-01 12:19:16,060 | ERROR | eChangeHandler-5 | AsyncDataTreeChangeListenerBase  | 319 - org.opendaylight.genius.mdsalutil-api - 0.2.2.Carbon | Thread terminated due to uncaught exception: AsyncDataTreeChangeListenerBase-DataTreeChangeHandler-5
java.lang.NullPointerException
        at org.opendaylight.netvirt.vpnmanager.VpnUtil.getIsExternal(VpnUtil.java:1695)[360:org.opendaylight.netvirt.vpnmanager-impl:0.4.2.Carbon]
        at org.opendaylight.netvirt.vpnmanager.SubnetmapChangeListener.update(SubnetmapChangeListener.java:107)[360:org.opendaylight.netvirt.vpnmanager-impl:0.4.2.Carbon]
        at org.opendaylight.netvirt.vpnmanager.SubnetmapChangeListener.update(SubnetmapChangeListener.java:29)[360:org.opendaylight.netvirt.vpnmanager-impl:0.4.2.Carbon]
        at org.opendaylight.genius.datastoreutils.AsyncDataTreeChangeListenerBase$DataTreeChangeHandler.run(AsyncDataTreeChangeListenerBase.java:160)[319:org.opendaylight.genius.mdsalutil-api:0.2.2.Carbon]
        at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1149)[:1.8.0_141]
        at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:624)[:1.8.0_141]
        at java.lang.Thread.run(Thread.java:748)[:1.8.0_141]



Version-Release number of selected component (if applicable):
ODL Caarbon+OSP12
opendaylight/6.2.0-0.1.20170829rel1948.el7.noarch
python-networking-odl-11.0.0-0.20170806093629.2e78dca.el7ost.noarch

How reproducible:
100%


Steps to Reproduce:
1. Deploy overcloud with ODL
2. Run custom Browbeat+Rally plugin which boots vm and pings floatingip
3. 

Actual results:
Tracebacks in karaf logs

Expected results:
No tracebacks in karaf

Additional info:

Comment 3 Mike Kolesnik 2018-03-21 08:23:50 UTC
Sam,

This appears to have been fixed upstream.
Can you please check and update the bug accordingly?

Comment 8 Sai Sindhur Malleni 2018-04-14 14:03:22 UTC
I can confirm that this specific NullPointer Exception has not bee seen with OSP13 + Oxygen.

Comment 10 errata-xmlrpc 2018-06-27 13:36:15 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHEA-2018:2086


Note You need to log in before you can comment on or make changes to this bug.