Bugzilla (bugzilla.redhat.com) will be under maintenance for infrastructure upgrades and will not be unavailable on July 31st between 12:30 AM - 05:30 AM UTC. We appreciate your understanding and patience. You can follow status.redhat.com for details.
Bug 1487860 - PLP0000 when updating Puppet containing CVs or syncing puppet containing repos
Summary: PLP0000 when updating Puppet containing CVs or syncing puppet containing repos
Keywords:
Status: CLOSED DUPLICATE of bug 1317978
Alias: None
Product: Red Hat Satellite
Classification: Red Hat
Component: Content Views
Version: 6.2.11
Hardware: x86_64
OS: Linux
unspecified
medium
Target Milestone: Unspecified
Assignee: satellite6-bugs
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-09-02 17:41 UTC by Patrick C. F. Ernzer
Modified: 2017-09-05 12:13 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-09-05 12:13:41 UTC
Target Upstream Version:


Attachments (Terms of Use)
foreman-debug output on the affected Satellite6 (7.58 MB, application/x-xz)
2017-09-02 21:24 UTC, Patrick C. F. Ernzer
no flags Details

Description Patrick C. F. Ernzer 2017-09-02 17:41:26 UTC
Description of problem:
I get
19:38:55 [root@satellite katello-cvmanager]# grep "\[E\]" "/var/log/foreman/production.log"
2017-09-02 05:50:43 518f11f9 [app] [E] RedhatAccess::Telemetry::PortalClient: Caught HTTP error when proxying call to tapi: 404 Resource Not Found: {}
2017-09-02 14:34:09 70a27523 [foreman-tasks/action] [E] undefined method `repositories' for nil:NilClass (NoMethodError)
2017-09-02 14:34:09 70a27523 [foreman-tasks/action] [E] undefined method `repositories' for nil:NilClass (NoMethodError)
2017-09-02 14:34:13 70a27523 [app] [E] NoMethodError: undefined method `repositories' for nil:NilClass
2017-09-02 14:35:55 0afc028b [foreman-tasks/action] [E] undefined method `repositories' for nil:NilClass (NoMethodError)
2017-09-02 14:35:55 0afc028b [foreman-tasks/action] [E] undefined method `repositories' for nil:NilClass (NoMethodError)
2017-09-02 14:35:59 0afc028b [app] [E] NoMethodError: undefined method `repositories' for nil:NilClass
2017-09-02 14:37:13 a33d25fc [foreman-tasks/action] [E] undefined method `repositories' for nil:NilClass (NoMethodError)
2017-09-02 14:37:13 a33d25fc [foreman-tasks/action] [E] undefined method `repositories' for nil:NilClass (NoMethodError)
2017-09-02 14:37:16 a33d25fc [app] [E] NoMethodError: undefined method `repositories' for nil:NilClass
2017-09-02 15:08:36  [foreman-tasks/dynflow] [E] ... core terminated.
2017-09-02 15:11:45  [foreman-tasks/dynflow] [E] ... core terminated.
2017-09-02 15:13:02  [foreman-tasks/dynflow] [E] invalid worlds found {"47c72271-bef0-49a8-9c90-e1da456c5a26"=>:invalidated}
2017-09-02 15:13:44  [foreman-tasks/dynflow] [E] ... core terminated.
2017-09-02 15:14:50  [foreman-tasks/dynflow] [E] ... core terminated.
2017-09-02 16:45:01 70d794c8 [foreman-tasks/action] [E] undefined method `repositories' for nil:NilClass (NoMethodError)
2017-09-02 16:45:01 70d794c8 [foreman-tasks/action] [E] undefined method `repositories' for nil:NilClass (NoMethodError)
2017-09-02 16:45:06 70d794c8 [app] [E] NoMethodError: undefined method `repositories' for nil:NilClass
2017-09-02 16:51:03  [foreman-tasks/dynflow] [E] invalid worlds found {"661195b0-9261-47d6-9a17-4a1a41efb4f5"=>:invalidated, "98534166-5a91-4dfe-bcff-67f2bfedc1f4"=>:invalidated}
2017-09-02 16:53:28 7931b2fe [foreman-tasks/action] [E] undefined method `repositories' for nil:NilClass (NoMethodError)
2017-09-02 16:53:28 7931b2fe [foreman-tasks/action] [E] undefined method `repositories' for nil:NilClass (NoMethodError)
2017-09-02 16:53:32 7931b2fe [app] [E] NoMethodError: undefined method `repositories' for nil:NilClass
2017-09-02 17:06:45 67569d5b [foreman-tasks/action] [E] undefined method `repositories' for nil:NilClass (NoMethodError)
2017-09-02 17:06:45 67569d5b [foreman-tasks/action] [E] undefined method `repositories' for nil:NilClass (NoMethodError)
2017-09-02 17:06:49 67569d5b [app] [E] NoMethodError: undefined method `repositories' for nil:NilClass
2017-09-02 17:08:41  [foreman-tasks/action] [E] PLP0000: Importer indicated a failed response (Katello::Errors::PulpError)
2017-09-02 17:08:46  [foreman-tasks/action] [E] PLP0000: Importer indicated a failed response (Katello::Errors::PulpError)
2017-09-02 17:14:28  [foreman-tasks/action] [E] PLP0000: Importer indicated a failed response (Katello::Errors::PulpError)
2017-09-02 17:14:30  [foreman-tasks/action] [E] PLP0000: Importer indicated a failed response (Katello::Errors::PulpError)
2017-09-02 17:29:52  [foreman-tasks/action] [E] PLP0000: Importer indicated a failed response (Katello::Errors::PulpError)
2017-09-02 17:31:05  [foreman-tasks/action] [E] PLP0000: Importer indicated a failed response (Katello::Errors::PulpError)
2017-09-02 17:32:21  [foreman-tasks/action] [E] PLP0000: Importer indicated a failed response (Katello::Errors::PulpError)
2017-09-02 18:00:36  [foreman-tasks/dynflow] [E] ... core terminated.
2017-09-02 18:05:24  [foreman-tasks/dynflow] [E] FATAL:  the database system is shutting down
2017-09-02 18:30:26  [foreman-tasks/dynflow] [E] invalid worlds found {"8f112b3a-d469-4461-8d42-ab86395cac0e"=>:invalidated, "6ad69e3d-b467-4c87-90f0-49f7fb0b9162"=>:invalidated, "d2bfe146-48bb-4231-8119-142f679c1ffd"=>:invalidated}
2017-09-02 19:38:51 d6f9c9b6 [foreman-tasks/action] [E] undefined method `repositories' for nil:NilClass (NoMethodError)
2017-09-02 19:38:51 d6f9c9b6 [foreman-tasks/action] [E] undefined method `repositories' for nil:NilClass (NoMethodError)
2017-09-02 19:38:55 d6f9c9b6 [app] [E] NoMethodError: undefined method `repositories' for nil:NilClass

when I
Actions::Katello::Repository::Sync or Actions::Katello::ContentView::Publish

Version-Release number of selected component (if applicable):
satellite-6.2.11-2.0.el7sat.noarch

How reproducible:
always

Steps to Reproduce:
1. try to update CV 14 or try to sync 
2.
3.

Actual results:


Expected results:


Additional info:
17:25:17 [root@satellite ~]# hammer content-view list --search "cv-rhel7-server-additions" --organization-id 1
----------------|---------------------------|---------------------------|-----------|-------------------
CONTENT VIEW ID | NAME                      | LABEL                     | COMPOSITE | REPOSITORY IDS
----------------|---------------------------|---------------------------|-----------|-------------------
14              | cv-rhel7-server-additions | cv-rhel7-server-additions |           | 14, 15, 16, 17, 70
----------------|---------------------------|---------------------------|-----------|-------------------
17:26:11 [root@satellite ~]# hammer repository info --id 14
ID:                 14
Name:               Red Hat Enterprise Linux 7 Server - Extras RPMs x86_64
Label:              Red_Hat_Enterprise_Linux_7_Server_-_Extras_RPMs_x86_64
Organisation:       Sat Test
Red Hat Repository: yes
Content Type:       yum
Checksum Type:      sha1
URL:                https://cdn.redhat.com/content/dist/rhel/server/7/7Server/x86_64/extras/os
Publish Via HTTP:   no
Published At:       https://satellite.sattest.pcfe.net/pulp/repos/Sat_Test/Library/content/dist/rhel/server/7/7Server/x86_64/extras/os/
Relative Path:      Sat_Test/Library/content/dist/rhel/server/7/7Server/x86_64/extras/os
Download Policy:    immediate
Product:
    ID:   139
    Name: Red Hat Enterprise Linux Server
GPG Key:

Sync:
    Status:         Success
    Last Sync Date: about 13 hours
Created:            2016/07/30 05:48:43
Updated:            2016/07/30 05:50:43
Content Counts:
    Packages:       603
    Package Groups: 0
    Errata:         494

17:26:32 [root@satellite ~]# hammer repository info --id 15 ; hammer repository info --id 16 ; hammer repository info --id 17 ; hammer repository info --id 70
ID:                 15
Name:               Red Hat Enterprise Linux 7 Server - Fastrack RPMs x86_64
Label:              Red_Hat_Enterprise_Linux_7_Server_-_Fastrack_RPMs_x86_64
Organisation:       Sat Test
Red Hat Repository: yes
Content Type:       yum
Checksum Type:      sha1
URL:                https://cdn.redhat.com/content/fastrack/rhel/server/7/x86_64/os
Publish Via HTTP:   no
Published At:       https://satellite.sattest.pcfe.net/pulp/repos/Sat_Test/Library/content/fastrack/rhel/server/7/x86_64/os/
Relative Path:      Sat_Test/Library/content/fastrack/rhel/server/7/x86_64/os
Download Policy:    immediate
Product:
    ID:   139
    Name: Red Hat Enterprise Linux Server
GPG Key:

Sync:
    Status:         Success
    Last Sync Date: about 13 hours
Created:            2016/07/30 05:48:50
Updated:            2016/07/30 05:49:29
Content Counts:
    Packages:       0
    Package Groups: 0
    Errata:         0

ID:                 16
Name:               Red Hat Enterprise Linux 7 Server - Optional RPMs x86_64 7Server
Label:              Red_Hat_Enterprise_Linux_7_Server_-_Optional_RPMs_x86_64_7Server
Organisation:       Sat Test
Red Hat Repository: yes
Content Type:       yum
Checksum Type:      sha1
URL:                https://cdn.redhat.com/content/dist/rhel/server/7/7Server/x86_64/optional/os
Publish Via HTTP:   no
Published At:       https://satellite.sattest.pcfe.net/pulp/repos/Sat_Test/Library/content/dist/rhel/server/7/7Server/x86_64/optional/os/
Relative Path:      Sat_Test/Library/content/dist/rhel/server/7/7Server/x86_64/optional/os
Download Policy:    immediate
Product:
    ID:   139
    Name: Red Hat Enterprise Linux Server
GPG Key:

Sync:
    Status:         Success
    Last Sync Date: about 13 hours
Created:            2016/07/30 05:48:57
Updated:            2016/07/30 06:29:18
Content Counts:
    Packages:       12695
    Package Groups: 2
    Errata:         1588

ID:                 17
Name:               Red Hat Enterprise Linux 7 Server - Optional Fastrack RPMs x86_64
Label:              Red_Hat_Enterprise_Linux_7_Server_-_Optional_Fastrack_RPMs_x86_64
Organisation:       Sat Test
Red Hat Repository: yes
Content Type:       yum
Checksum Type:      sha1
URL:                https://cdn.redhat.com/content/fastrack/rhel/server/7/x86_64/optional/os
Publish Via HTTP:   no
Published At:       https://satellite.sattest.pcfe.net/pulp/repos/Sat_Test/Library/content/fastrack/rhel/server/7/x86_64/optional/os/
Relative Path:      Sat_Test/Library/content/fastrack/rhel/server/7/x86_64/optional/os
Download Policy:    immediate
Product:
    ID:   139
    Name: Red Hat Enterprise Linux Server
GPG Key:

Sync:
    Status:         Success
    Last Sync Date: about 13 hours
Created:            2016/07/30 05:49:05
Updated:            2016/07/30 05:50:51
Content Counts:
    Packages:       0
    Package Groups: 0
    Errata:         0

ID:                 70
Name:               RPMS RHEL7
Label:              RPMS_RHEL7
Organisation:       Sat Test
Red Hat Repository: no
Content Type:       yum
Checksum Type:      sha256
URL:                http://192.168.200.100/pub/soe-repo/rhel7
Publish Via HTTP:   yes
Published At:       http://satellite.sattest.pcfe.net/pulp/repos/Sat_Test/Library/custom/ACME_SOE/RPMS_RHEL7/
Relative Path:      Sat_Test/Library/custom/ACME_SOE/RPMS_RHEL7
Download Policy:    immediate
Product:
    ID:   151
    Name: ACME SOE
GPG Key:

Sync:
    Status:         Success
    Last Sync Date: 18 minutes
Created:            2016/07/30 15:47:53
Updated:            2016/07/30 17:58:04
Content Counts:
    Packages:       6
    Package Groups: 0
    Errata:         0

17:27:08 [root@satellite ~]# 

===

17:51:10 [root@satellite ~]# hammer repository list --search puppet --organization-id 1
-----|----------------------|----------------------|--------------|-----------------------------------------------------
ID   | NAME                 | PRODUCT              | CONTENT TYPE | URL
-----|----------------------|----------------------|--------------|-----------------------------------------------------
2369 | Puppet only          | ACME SOE             | puppet       | http://jenkins.sattest.pcfe.net/pub/soe-puppet-only/
2071 | puppet forge modules | puppet forge modules | puppet       |
71   | Puppet               | ACME SOE             | puppet       | http://jenkins.sattest.pcfe.net/pub/soe-puppet/
-----|----------------------|----------------------|--------------|-----------------------------------------------------
17:51:39 [root@satellite ~]# hammer repository info --id 2369 ; hammer repository info --id 71
ID:                 2369
Name:               Puppet only
Label:              Puppet_only
Organisation:       Sat Test
Red Hat Repository: no
Content Type:       puppet
URL:                http://jenkins.sattest.pcfe.net/pub/soe-puppet-only/
Publish Via HTTP:   yes
Published At:       http://satellite.sattest.pcfe.net/pulp/puppet/Sat_Test-ACME_SOE-Puppet_only/
Relative Path:      Sat_Test/Library/custom/ACME_SOE/Puppet_only
Download Policy:    
Product:            
    ID:   151
    Name: ACME SOE
GPG Key:            

Sync:               
    Status:         
    Last Sync Date: 21 minutes
Created:            2017/05/14 19:54:04
Updated:            2017/09/02 15:30:54
Content Counts:     
    Puppet Modules: 14

ID:                 71
Name:               Puppet
Label:              Puppet
Organisation:       Sat Test
Red Hat Repository: no
Content Type:       puppet
URL:                http://jenkins.sattest.pcfe.net/pub/soe-puppet/
Publish Via HTTP:   yes
Published At:       http://satellite.sattest.pcfe.net/pulp/puppet/Sat_Test-ACME_SOE-Puppet/
Relative Path:      Sat_Test/Library/custom/ACME_SOE/Puppet
Download Policy:    
Product:            
    ID:   151
    Name: ACME SOE
GPG Key:            

Sync:               
    Status:         
    Last Sync Date: 20 minutes
Created:            2016/07/30 15:48:23
Updated:            2017/09/02 15:32:11
Content Counts:     
    Puppet Modules: 14

17:52:11 [root@satellite ~]#

Comment 1 Patrick C. F. Ernzer 2017-09-02 21:24:16 UTC
Created attachment 1321376 [details]
foreman-debug output on the affected Satellite6

Comment 3 Evgeni Golov 2017-09-05 12:13:41 UTC

*** This bug has been marked as a duplicate of bug 1317978 ***


Note You need to log in before you can comment on or make changes to this bug.