Bugzilla (bugzilla.redhat.com) will be under maintenance for infrastructure upgrades and will not be unavailable on July 31st between 12:30 AM - 05:30 AM UTC. We appreciate your understanding and patience. You can follow status.redhat.com for details.
Bug 1487888 - Could not parse *.spec with error can't parse specfile
Summary: Could not parse *.spec with error can't parse specfile
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Copr
Classification: Community
Component: backend
Version: unspecified
Hardware: Unspecified
OS: Linux
unspecified
urgent
Target Milestone: ---
Assignee: clime
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-09-03 01:24 UTC by Robbi Nespu
Modified: 2017-09-07 20:49 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-09-07 20:49:17 UTC


Attachments (Terms of Use)

Description Robbi Nespu 2017-09-03 01:24:09 UTC
Description of problem:
I am new with packager, please teach me if I doing wrong. I fork some project to learn about packaging.

I forked a copr project (riot) and try to build new version of riot but failed, source are stored on github https://github.com/RobbiNespu/riot-rpm

Latest build and  log https://copr.fedorainfracloud.org/coprs/robbinespu/Riot/build/597588/

I keep getting the same error for each build, can anyone tell my why and what should I do.

Version-Release number of selected component (if applicable):
n/a

How reproducible:
When building the package

Steps to Reproduce:
1. Login to Copr
2. Go to build or package
3. Build or rebuild package

Actual results:
Build failed

Expected results:
Build success

Additional info:
I already posted on copr-devel mailing list and Michal Novotny inform this is due to bug on Copr side:

>> This is a bug on our side.
>> 
>> More concretely, the error is caused by:
>> 
>> BuildRoot: %(mktemp -ud %{_tmppath}/%{namevr}-XXXXXX)
>> 
>. directive in the spec file. We "disallow" calling external commands currently from the .spec preamble.
>>
>> This will be fixed in the next release. As a temporary solution I would suggest putting the mktemp call into %build section or avoid it completely.

chroot fedora-26-i386 and fedora-26-x86_64 log :
http://copr-dist-git.fedorainfracloud.org/per-task-logs/597588.log

Comment 1 clime 2017-09-07 20:49:17 UTC
Should be fixed now. Please try and reopen if there are further problems.


Note You need to log in before you can comment on or make changes to this bug.