Bug 148808 - cyrus-imapd doesn't start if started for the first time with the 2.2.10-3.fc3
cyrus-imapd doesn't start if started for the first time with the 2.2.10-3.fc3
Status: CLOSED DUPLICATE of bug 154342
Product: Fedora
Classification: Fedora
Component: cyrus-imapd (Show other bugs)
3
All Linux
medium Severity high
: ---
: ---
Assigned To: John Dennis
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-02-15 14:25 EST by Nathan G. Grennan
Modified: 2007-11-30 17:11 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-04-23 16:03:39 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Bugzilla 154342 None None None Never

  None (edit)
Description Nathan G. Grennan 2005-02-15 14:25:37 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8b)
Gecko/20050115 Galeon/1.3.19

Description of problem:
I did a fresh install of FC3 on a computer. cyrus-imapd was disabled
by default. Then I installed all updates via yum. I think found
cyrus-imapd wouldn't start. It will start if the database conversion
command is commented out in /etc/rc.d/init.d/cyrus-imapd, but
otherwise errors. The reason seems to be two things. One the databases
are empty, which explains why people who update after having started
it once with the original version work. The second is that the default
empty database files are skiplist, and the
/usr/lib/cyrus-imapd/cvt_cyrusdb_all command expects them to be berkeley.

I was successful in uninstalling cyrus-imapd and subpackages, removing
the directories, installing the original version, starting
cyrus-imapd, updating cyrus-imapd, and restarting cyrus-imapd.

The original version is cyrus-imapd-2.2.6-2.FC3.6.


var/lib/imap/rpm/cvt_cyrusdb_all.log:

you are using /var/lib/imap/sieve as your sieve directory.
fatal error: can't open old database
Converting from /var/lib/imap/mailboxes.db (berkeley) to
/var/lib/imap/mailboxes.db.flat (flat)
ERROR: unable to convert /var/lib/imap/mailboxes.db from berkeley to flat
fatal error: can't open old database
Converting from /var/lib/imap/annotations.db (berkeley) to
/var/lib/imap/annotations.db.flat (flat)
ERROR: unable to convert /var/lib/imap/annotations.db from berkeley to
flat


Version-Release number of selected component (if applicable):
2.2.10-3.fc3

How reproducible:
Always

Steps to Reproduce:
1. Install FC3
2. Update cyrus-imapd
3. Start cyrus-imapd
    

Actual Results:  service cyrus-imapd start
Starting cyrus-imapd: preparing databases... error!        [FAILED]


Expected Results:  service cyrus-imapd start
Starting cyrus-imapd: preparing databases... done.         [  OK  ]

Additional info:
Comment 1 Mike 2005-02-16 00:59:21 EST
I ran into exactly the same problem today on a freshly installed and
updated FC3 system.  As a shot in the dark I simply renamed the
mailboxes.db file to mailboxes.db.bak and restarted cyrus-imapd.  This
appears to have caused the database files to be rebuilt and everything
now seems to be OK.  Since I'm very new to cyrus-imap, I'm not 100%
sure  this was entirely the best method but it did allow me to
continue to work with the installation and learn more about the
application.

Mike
Comment 2 Elías Halldór Ágústsson 2005-03-16 08:35:13 EST
I just found out that a recent update of file(1) (file-4.12-1.FC3.1) mistakenly
identifies skiplist files as Apple Quicktime files. Fix that (move the skiplist
entry above the multimedia stuff in /usr/share/file/magic and do file -C in
/usr/share/file) and the cyrus startup will work.
Comment 3 Robin Rainton 2005-03-30 00:53:57 EST
I too had this problem. I tried:

- Move the existing /var/lib/imap out of the way and use 'mkimap' to re-
create. This failed. Then I created a blank /var/lib/imap and successfully 
ran 'mkimap' but this didn't create all the necessary files. Gave up.

- Searched the web for ages, couldn't find much.

- Looked in bugzilla and found this report. Did the same as Mike suggests in 
Comment #1 (move the old mailboxes.db file and restart) and this seems to 
work. Well, it starts up at least.
Comment 4 Johnny Ljunggren 2005-04-09 21:58:05 EDT
Ran into the same problem too, but luckily I tried mr. Ágústsson's trick; moving
the skiplist entry to the top of the list.
service cyrus-imapd start now initialized the databases and started.

Now I only need to figure out how to convert the old UW-IMAP mail files to
cyrus-compatible format....
Comment 5 elias 2005-04-10 10:10:35 EDT
I filed a bug in file-4.12-1.FC3.1, the id is #154342
Comment 6 John Dennis 2005-04-23 16:03:39 EDT

*** This bug has been marked as a duplicate of 154342 ***

Note You need to log in before you can comment on or make changes to this bug.