Bugzilla (bugzilla.redhat.com) will be under maintenance for infrastructure upgrades and will not be available on July 31st between 12:30 AM - 05:30 AM UTC. We appreciate your understanding and patience. You can follow status.redhat.com for details.
Bug 1488110 - RHSCL-meta packages don't own %{_scl_root}/usr/lib64
Summary: RHSCL-meta packages don't own %{_scl_root}/usr/lib64
Keywords:
Status: CLOSED DUPLICATE of bug 1475718
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: scl-utils
Version: 7.4
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: rc
: ---
Assignee: Packaging Maintenance Team
QA Contact: BaseOS QE - Apps
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-09-04 11:04 UTC by Luboš Uhliarik
Modified: 2018-08-29 14:22 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-08-29 14:22:13 UTC
Target Upstream Version:


Attachments (Terms of Use)

Description Luboš Uhliarik 2017-09-04 11:04:16 UTC
Description of problem:
e.g. rh-nginx112-runtime package doesn't own /opt/rh/rh-nginx112/root/usr/lib64 directory on aarch42 and ppc64le architectures. 

The situation is the same in httpd24-runtime package.

Version-Release number of selected component (if applicable):
*-runtime

How reproducible:
always

Steps to Reproduce:
1. rpm -qlp rh-nginx112-runtime-1.12-3.el7.aarch64.rpm | grep 'usr/lib64$'
2. rpm -qlp rh-nginx112-runtime-1.12-3.el7.ppc64le.rpm | grep 'usr/lib64$'

Actual results:
nothing, /opt/rh/rh-nginx112/root/usr/lib64 is not included

Expected results:
/opt/rh/rh-nginx112/root/usr/lib64

Additional info:

This is part of the macros.scl:

%ifarch x86_64 ppc ppc64 sparc sparc64 s390 s390x
%{_scl_root}/%{_lib}
%endif

IMO, previous lines should be modified in this way (add aarch64 and ppc64le architecture):

%ifarch x86_64 ppc ppc64 ppc64le aarch64 sparc sparc64 s390 s390x
%{_scl_root}/%{_lib}
%endif

please, see this bug: https://bugzilla.redhat.com/show_bug.cgi?id=1487085

Comment 3 Joe Orton 2018-08-29 14:22:13 UTC

*** This bug has been marked as a duplicate of bug 1475718 ***


Note You need to log in before you can comment on or make changes to this bug.