Due to a recent update on Javascript code a full page refresh on your browser might be needed.
Bug 1488125 - builder0.int.rht.gluster.org and builder1 fail to run rpmbuild tests in mock
Summary: builder0.int.rht.gluster.org and builder1 fail to run rpmbuild tests in mock
Keywords:
Status: CLOSED WORKSFORME
Alias: None
Product: GlusterFS
Classification: Community
Component: project-infrastructure
Version: mainline
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: bugs@gluster.org
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-09-04 11:54 UTC by Niels de Vos
Modified: 2017-11-27 04:53 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-11-27 04:53:07 UTC
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:


Attachments (Terms of Use)

Description Niels de Vos 2017-09-04 11:54:34 UTC
Description of problem:
Building remotely on builder0.int.rht.gluster.org (rpm7) in workspace /home/jenkins/workspace/devrpm-fedora
Wiping out workspace first.
java.nio.file.AccessDeniedException: /home/jenkins/workspace/devrpm-fedora/RPMS/fc25/x86_64/root.log

And the smoke test is marked with a failure.

Examples:
- https://build.gluster.org/job/devrpm-fedora/5789/console
- https://build.gluster.org/job/devrpm-el6/5754/

Both builders have been disabled until this is resolved.

13:03 < ndevos> nigelb, misc: builder0.int.rht.gluster.org seems to have a weird failure - https://build.gluster.org/job/devrpm-fedora/5786/console
13:04 < ndevos> oh, and builder1 has that as well - https://build.gluster.org/job/devrpm-el6/5751/console
13:44 < misc> ndevos: looking
13:44 < misc> mhh
13:44 < misc> ndevos: can you log it as a bugzilla ticket, seems to be a bit more complicated than a quick fix :/

Comment 1 M. Scherer 2017-09-04 12:15:18 UTC
Ok so it seems that mock is using root:
$ ls -ld /home/jenkins/workspace/devrpm-fedora/RPMS/
drwxrwxr-x. 3 root root 4096  4 sept. 08:51 /home/jenkins/workspace/devrpm-fedora/RPMS/

I guess that's related to:

https://github.com/gluster/gluster.org_ansible_configuration/pull/13#discussion_r136525704

I am cherrypicking the fix

Comment 2 M. Scherer 2017-09-04 12:22:54 UTC
So looking at it, it seems that if jenkins can't write to the workspace directory found, it then go to its home. Then it create the workspace and then fail with mock.

I am reenabling the builder on ansible fixed it, please redisable and complete that bug report if it still fail.


Note You need to log in before you can comment on or make changes to this bug.