Bug 1488178 - [Docs][DWH] Incomplete information while creating a read-only user to access the history DB
Summary: [Docs][DWH] Incomplete information while creating a read-only user to access ...
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: Documentation
Version: 4.1.0
Hardware: Unspecified
OS: Unspecified
medium
medium
Target Milestone: ovirt-4.1.8
: ---
Assignee: Avital Pinnick
QA Contact: Byron Gravenorst
URL:
Whiteboard:
: 1488559 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-09-04 14:50 UTC by Javier Coscia
Modified: 2021-03-11 17:17 UTC (History)
8 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-11-22 09:19:36 UTC
oVirt Team: Docs
Target Upstream Version:
lsvaty: testing_plan_complete-


Attachments (Terms of Use)

Description Javier Coscia 2017-09-04 14:50:20 UTC
Description of problem:

Need to add the following information into 2.6 section in DWH Guide

https://access.redhat.com/documentation/en-us/red_hat_virtualization/4.1/html/data_warehouse_guide/allowing_read_only_access_to_the_history_database


Before running the 'psql' command after step 6, customer still needs to configure the authentication method for the read-only user in ph_hba.conf file + reload postgresql service, also, the psql command, to test access to the ovirt_engine_history DB, has to include the host flag (-h localhost)

# /var/lib/pgsql/data/pg_hba.conf
~~~
# TYPE  DATABASE        USER            ADDRESS                 METHOD

# "local" is for Unix domain socket connections only
local   all             all                                     peer
host    ovirt_engine_history ovirt_engine_history 0.0.0.0/0               md5
host    ovirt_engine_history ovirt_engine_history ::0/0                   md5
host    ovirt_engine_history $RO_USER 0.0.0.0/0               md5
host    ovirt_engine_history $RO_USER ::0/0                   md5
host    engine          engine          0.0.0.0/0               md5
host    engine          engine          ::0/0                   md5
# IPv4 local connections:
host    all             all             127.0.0.1/32            ident
# IPv6 local connections:
host    all             all             ::1/128                 ident
~~~

Replace $RO_USER with correct value


# systemctl reload postgresql

Command to test DB access:

# psql -h localhost -U $RO_USER ovirt_engine_history

Comment 1 Andrea Perotti 2017-09-05 17:02:17 UTC
*** Bug 1488559 has been marked as a duplicate of this bug. ***


Note You need to log in before you can comment on or make changes to this bug.