Bug 148819 - X11 Tunneling No Longer Works
Summary: X11 Tunneling No Longer Works
Status: CLOSED DUPLICATE of bug 150262
Alias: None
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: openssh (Show other bugs)
(Show other bugs)
Version: 4.0
Hardware: i386 Linux
medium
medium
Target Milestone: ---
: ---
Assignee: Tomas Mraz
QA Contact: Brian Brock
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-02-15 21:31 UTC by Thornton Prime
Modified: 2007-11-30 22:07 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-06-16 09:20:42 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Thornton Prime 2005-02-15 21:31:19 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.5) Gecko/20041215 Firefox/1.0 Red Hat/1.0-12.EL4

Description of problem:

After upgrading to RHEL4 my OpenSSH will no longer forward X11 connections.

My .ssh/config:

Host *
        ForwardAgent yes
        ForwardX11 yes
        StrictHostKeyChecking no

Logging into a remote host (with -v) says:
debug1: Requesting X11 forwarding with authentication spoofing.
debug1: channel 0: request x11-req

$DISPLAY is set to localhost:10.0

But starting up an xterm gives (-v output):
debug1: client_input_channel_open: ctype x11 rchan 4 win 65536 max 16384
debug1: client_request_x11: request from 127.0.0.1 41748
debug1: fd 7 setting O_NONBLOCK
debug1: channel 1: new [x11]
debug1: confirm x11

No window opens.




Version-Release number of selected component (if applicable):
openssh-3.6.1p2-18

How reproducible:
Always

Steps to Reproduce:
1. ssh to remote host
2. start any X program
3.
  

Actual Results:  Nothing happens

Expected Results:  The X display should be on my local display

Additional info:

Comment 1 Tomas Mraz 2005-02-15 21:55:52 UTC
Which machine have you upgraded? The ssh client or ssh server?
What happens if you run ssh -Y remote and try to run X11 application again?


Comment 2 Thornton Prime 2005-02-15 22:02:24 UTC
I did a clean install on the client. I've tested with a number of different
servers, RHEL3, RHEL2.1, RHEL4, Solaris 9, Solaris 8, SGI.

My home directory is mounted NFS, so my config files haven't changed, and I
haven't changed the /etc/ssh/ssh_config.

-Y does work.

Comment 3 Thornton Prime 2005-02-15 22:13:05 UTC
More information.

I did an install of RHEL4 on another desktop, and it does not exhibit this
problem. The one difference between these is that the one that does not work is
dual-headed running Xinerama.



Comment 4 Tomas Mraz 2005-02-16 08:30:12 UTC
If -Y does work then it's duplicate of bug 138875 and more generally bug 137685.


Comment 5 Tomas Mraz 2005-03-23 12:16:23 UTC
It should get fixed by the next OpenSSH update - this adds the ForwardX11Trusted
yes to the ssh_config file.


Comment 6 Tomas Mraz 2005-06-16 09:20:42 UTC

*** This bug has been marked as a duplicate of 150262 ***


Note You need to log in before you can comment on or make changes to this bug.