Bug 1488333 - ovirt-ha-agent fails connecting ovirt-ha-broker
Summary: ovirt-ha-agent fails connecting ovirt-ha-broker
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: ovirt-hosted-engine-ha
Classification: oVirt
Component: Agent
Version: 2.2.0
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified vote
Target Milestone: ovirt-4.2.0
: 2.2.0
Assignee: Denis Chaplygin
QA Contact: Nikolai Sednev
URL:
Whiteboard:
Depends On:
Blocks: 1487915
TreeView+ depends on / blocked
 
Reported: 2017-09-05 07:52 UTC by Simone Tiraboschi
Modified: 2017-12-20 10:50 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-12-20 10:50:01 UTC
oVirt Team: SLA
rule-engine: ovirt-4.2+


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
oVirt gerrit 81430 0 master POST brokerlink: Broker can not be disconnected anymore 2017-09-05 13:58:53 UTC
oVirt gerrit 81465 0 master POST storage: Storage must be fully initialized by the broker. 2017-09-05 13:59:00 UTC
oVirt gerrit 81466 0 master POST rpc: Added logging of RPC exceptions 2017-09-05 13:59:07 UTC

Description Simone Tiraboschi 2017-09-05 07:52:58 UTC
Description of problem:

ovirt-ha-agent fails connecting ovirt-ha-broker due to the lack of is_connected attribute in BrokerLink object.

MainThread::ERROR::2017-09-04 18:24:23,334::agent::144::ovirt_hosted_engine_ha.agent.agent.Agent::(_run_agent) Traceback (most recent call last):
  File "/usr/lib/python2.7/site-packages/ovirt_hosted_engine_ha/agent/agent.py", line 131, in _run_agent
    return action(he)
  File "/usr/lib/python2.7/site-packages/ovirt_hosted_engine_ha/agent/agent.py", line 55, in action_proper
    return he.start_monitoring()
  File "/usr/lib/python2.7/site-packages/ovirt_hosted_engine_ha/agent/hosted_engine.py", line 434, in start_monitoring
    if self._broker and self._broker.is_connected():
AttributeError: 'BrokerLink' object has no attribute 'is_connected'
MainThread::ERROR::2017-09-04 18:24:23,335::agent::145::ovirt_hosted_engine_ha.agent.agent.Agent::(_run_agent) Trying to restart agent
MainThread::INFO::2017-09-04 18:24:23,335::agent::89::ovirt_hosted_engine_ha.agent.agent.Agent::(run) Agent shutting down
MainThread::INFO::2017-09-04 18:24:33,692::agent::67::ovirt_hosted_engine_ha.agent.agent.Agent::(run) ovirt-hosted-engine-ha agent 2.2.0-0.0.master.20170901100749 started

Version-Release number of selected component (if applicable):


How reproducible:
100%

Steps to Reproduce:
1. deploy hosted-engine
2.
3.

Actual results:
ovirt-ha-agent fails connecting ovirt-ha-broker and restarts itself

Expected results:
ovirt-ha-agent is able to connect ovirt-ha-broker

Additional info:

Comment 1 Nikolai Sednev 2017-09-17 07:52:37 UTC
Successfully deployed ovirt-hosted-engine-setup-2.2.0-0.0.master.20170913082146.git120d800.el7.centos.noarch with pre-installed rhvm-appliance-1:4.1.20170811.0-1.el7.

Moving to verified as initial issue not being reproduced anymore and works fine.

Comment 2 Sandro Bonazzola 2017-12-20 10:50:01 UTC
This bugzilla is included in oVirt 4.2.0 release, published on Dec 20th 2017.

Since the problem described in this bug report should be
resolved in oVirt 4.2.0 release, published on Dec 20th 2017, it has been closed with a resolution of CURRENT RELEASE.

If the solution does not work for you, please open a new bug report.


Note You need to log in before you can comment on or make changes to this bug.