From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.1; SV1; .NET CLR 1.1.4322)
Description of problem:
Latest python should depend on glibc >= 2.3.4, since if not instaled this happens:
symbol __fprintf_chk, version GLIBC_2.3.4 not defined in file libc.so.6 with link time reference.
Version-Release number of selected component (if applicable):
Steps to Reproduce:
1. Install FC1
2. Upgrade python from FC3 Develop
3. exec python
Actual Results: python no longer executable. Other progs as well. Maybe readline is the one which should depend on glibc >= 2.3.4...
Just don't do that or install FC3 glibc as well.
rpm symbol versioning provides/requires only work on a symbol version resolution,
while in the ideal world it would have a per-symbol resolution.
The runtime failure is not ideal, but still you can easily find out what's going
on and upgrade glibc appropriately.
The problem is, that if you do a eg. >yum update python< and don't know that it
was build against newer glibc, yum (and up2date as well), just install python
(and python deps), but not glibc. Sure you can then - MANUALLY - download glibc
(plus deps) and install it, but with up2date or yum it will not work, since
symbols are missing. Why not simply adding a Requires: glibc >= 2.3.4 for
python 2.4!? It would not hurt, or would it!? :-)
Because that would need to be added to almost all newly built packages.
Arg. Yes, you are correct. So it's correct to let it as it is. If someone is
willing to upgrade from fc1/2 to fc3, then it's hopefully an admin who knows
what he is doing and if not he hopefully knows how to fix it, if something goes
Sorry, for buggin'.