Fedora Account System
Red Hat Associate
Red Hat Customer
Description of problem: unable to scan lvm2 partitions that were thin provisioned under rhevm 4.1 Version-Release number of selected component (if applicable): cfme-5.8.1.5 How reproducible: customer environment Steps to Reproduce: 1. provision a vm against a satellite that would have 2 partitions; /dev/sda1 (boot) and /dev/sda2 (volume group). it must use thin provisioning. 2. smartscan the vm with an appliance inside the rhev environment 3. Actual results: ERROR -- : Unable to mount filesystem. Reason:[LVM2Thin cannot find device block: 1 (closest: 0)] for VM [/rhev/data-center/4a7e8c73-ca1b-489d-acb8-7e11cd64eb36/mastersd/master/vms/830b3ebd-b46d-4ea0-a78b-d22520987720/830b3ebd-b46d-4ea0-a78b-d22520987720.ovf] Expected results: able to mount and scan the filesystem Additional info: this issue doesn't happen for non-thin provisioning.
if I can I will try to get access to the .ovf file.
I have verified the issue w/ the provided disk image and sent a PR w/ a tentative fix. Once that is verified and merged, we can begin the process of backporting it to the necessary branches. https://github.com/ManageIQ/manageiq-smartstate/pull/28/commits/9e28a88e376a379909fdc505f0382770cf74c87d
PR: https://github.com/ManageIQ/manageiq-smartstate/pull/28 https://github.com/ManageIQ/manageiq/pull/16028 bumps manageiq-smartstate gem to 0.1.5 which includes this fix.
Verified on CFME-5.9.0.19/RHV-4.1.8: Created a VM with 1 disk with RHEL-7.4 OS, and a 2nd disk, created by the bellow guidance, with RHV storage QE team help. Smart state analysis for this VM ended up successfully. Packages, users, files were collected successfully. Mo's guidance for creating the 2nd image: "create a raw disk image and then partition it and incorporate it into a LVM physical / logical volume structure. https://superuser.com/questions/518554/how-do-you-create-and-partition-a-raw-disk-image https://www.redhat.com/archives/linux-lvm/2008-June/msg00045.html When setting up the volume, make sure it is allocated via 'thin provisioning' https://access.redhat.com/documentation/en-US/Red_Hat_Enterprise_Linux/6/html/Logical_Volume_Manager_Administration/thinly_provisioned_volume_creation.html You can then 'dd' a small amount of data onto the logical volume, but you _shouldn't_ format it with any filesystem as that will more certainly allocate more blocks than the original issue can be replicated with."