Bug 1488496 - OpenJDK 64-Bit Server VM warning: ignoring option MaxPermSize=128M; support was removed in 8.0
Summary: OpenJDK 64-Bit Server VM warning: ignoring option MaxPermSize=128M; support w...
Keywords:
Status: CLOSED WONTFIX
Alias: None
Product: JBoss Operations Network
Classification: JBoss
Component: Launch Scripts
Version: JON 3.3.7,JON 3.3.8,JON 3.3.9
Hardware: Unspecified
OS: Unspecified
unspecified
low
Target Milestone: ---
: ---
Assignee: Michael Burman
QA Contact: Mike Foley
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-09-05 14:13 UTC by Filip Brychta
Modified: 2017-10-12 14:44 UTC (History)
0 users

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-10-12 14:44:40 UTC
Type: Bug


Attachments (Terms of Use)

Description Filip Brychta 2017-09-05 14:13:32 UTC
Description of problem:
The warning in $Summary is visible when starting JON server via rhqctl or when applying a CP.

Version-Release number of selected component (if applicable):
JON 3.3.9.DR01 but previous versions as well

How reproducible:
Always on openJDK 8
openjdk version "1.8.0_131"

Steps to Reproduce:
1. start JON server via rhqctl start or apply CP (jon-server-3.3.0.GA-update-09/apply-updates.sh jon-server-3.3.0.GA)


Actual results:
OpenJDK 64-Bit Server VM warning: ignoring option MaxPermSize=128M; support was removed in 8.0

Expected results:
No warnings.

Additional info:
-XX:MaxPermSize is visible in default RHQ_SERVER_JAVA_OPTS and RHQ_CONTROL_JAVA_OPTS

Comment 1 Filip Brychta 2017-10-12 14:44:40 UTC
Triage: Larry, Simeon, Filip - closing as won't fix since it's just deprecation warning and fix would be risky.


Note You need to log in before you can comment on or make changes to this bug.