Bug 1488524 - dnf needs-restarting fails to operate
Summary: dnf needs-restarting fails to operate
Keywords:
Status: CLOSED EOL
Alias: None
Product: Fedora
Classification: Fedora
Component: dnf-plugins-core
Version: 29
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: rpm-software-management
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks: 1491190
TreeView+ depends on / blocked
 
Reported: 2017-09-05 15:31 UTC by Steven Haigh
Modified: 2019-11-27 23:04 UTC (History)
7 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-11-27 23:04:10 UTC
Type: Bug


Attachments (Terms of Use)

Description Steven Haigh 2017-09-05 15:31:13 UTC
When trying to use 'dnf needs-restarting' to replicate the functionality of the yum-utils based 'needs-restarting', I always get an empty return.

Versions:
dnf-2.6.3-1.fc26.noarch
dnf-plugins-core-2.1.3-1.fc26.noarch

Output:
[root@DELL15 ~]# dnf needs-restarting -u
[root@DELL15 ~]# dnf needs-restarting
[root@DELL15 ~]#

I am currently logged in and the following packages have been updated seconds ago:
2017-09-05T14:44:07Z INFO Upgraded: libsss_certmap-1.15.3-3.fc26.x86_64
2017-09-05T14:44:08Z INFO Upgraded: libreoffice-data-1:5.3.6.1-3.fc26.noarch
2017-09-05T14:44:08Z INFO Upgraded: libsss_idmap-1.15.3-3.fc26.x86_64
2017-09-05T14:44:08Z INFO Upgraded: plasma-workspace-common-5.10.5-3.fc26.x86_64
2017-09-05T14:44:08Z INFO Upgraded: libkworkspace5-5.10.5-3.fc26.x86_64
2017-09-05T14:44:08Z INFO Upgraded: plasma-workspace-libs-5.10.5-3.fc26.x86_64
2017-09-05T14:44:08Z INFO Upgraded: plasma-workspace-geolocation-5.10.5-3.fc26.x86_64
2017-09-05T14:44:09Z INFO Upgraded: plasma-workspace-geolocation-libs-5.10.5-3.fc26.x86_64
2017-09-05T14:44:09Z INFO Upgraded: vim-filesystem-2:8.0.1030-1.fc26.x86_64
2017-09-05T14:44:11Z INFO Upgraded: vim-common-2:8.0.1030-1.fc26.x86_64
2017-09-05T14:44:16Z INFO Upgraded: selinux-policy-3.13.1-260.8.fc26.noarch
2017-09-05T14:44:16Z INFO Upgraded: libsss_nss_idmap-1.15.3-3.fc26.x86_64
2017-09-05T14:44:16Z INFO Upgraded: sssd-client-1.15.3-3.fc26.x86_64
2017-09-05T14:44:16Z INFO Upgraded: sssd-common-1.15.3-3.fc26.x86_64
2017-09-05T14:44:17Z INFO Upgraded: sssd-krb5-common-1.15.3-3.fc26.x86_64
2017-09-05T14:44:17Z INFO Upgraded: sssd-common-pac-1.15.3-3.fc26.x86_64
2017-09-05T14:44:17Z INFO Upgraded: sssd-ad-1.15.3-3.fc26.x86_64
2017-09-05T14:44:17Z INFO Upgraded: sssd-krb5-1.15.3-3.fc26.x86_64
2017-09-05T14:44:17Z INFO Upgraded: sssd-ldap-1.15.3-3.fc26.x86_64
2017-09-05T14:44:17Z INFO Upgraded: libreoffice-ure-common-1:5.3.6.1-3.fc26.noarch
2017-09-05T14:44:17Z INFO Upgraded: libreoffice-opensymbol-fonts-1:5.3.6.1-3.fc26.noarch
2017-09-05T14:44:17Z INFO Upgraded: python3-sssdconfig-1.15.3-3.fc26.noarch
2017-09-05T14:44:18Z INFO Upgraded: libipa_hbac-1.15.3-3.fc26.x86_64
2017-09-05T14:44:18Z INFO Upgraded: sssd-ipa-1.15.3-3.fc26.x86_64
2017-09-05T14:44:18Z INFO Upgraded: kscreenlocker-5.10.5.1-1.fc26.x86_64
2017-09-05T14:44:18Z INFO Upgraded: plasma-lookandfeel-fedora-5.10.5-3.fc26.noarch
2017-09-05T14:44:22Z INFO Upgraded: plasma-workspace-5.10.5-3.fc26.x86_64
2017-09-05T14:44:22Z INFO Upgraded: autocorr-en-1:5.3.6.1-3.fc26.noarch
2017-09-05T14:44:22Z INFO Upgraded: libreoffice-ure-1:5.3.6.1-3.fc26.x86_64
2017-09-05T14:44:22Z INFO Upgraded: libreoffice-gtk3-1:5.3.6.1-3.fc26.x86_64
2017-09-05T14:44:34Z INFO Upgraded: libreoffice-core-1:5.3.6.1-3.fc26.x86_64
2017-09-05T14:44:34Z INFO Upgraded: libreoffice-langpack-en-1:5.3.6.1-3.fc26.x86_64
2017-09-05T14:44:34Z INFO Upgraded: libreoffice-pyuno-1:5.3.6.1-3.fc26.x86_64
2017-09-05T14:44:35Z INFO Upgraded: libreoffice-calc-1:5.3.6.1-3.fc26.x86_64
2017-09-05T14:44:36Z INFO Upgraded: libreoffice-writer-1:5.3.6.1-3.fc26.x86_64
2017-09-05T14:44:36Z INFO Upgraded: libreoffice-emailmerge-1:5.3.6.1-3.fc26.x86_64
2017-09-05T14:44:37Z INFO Upgraded: libreoffice-base-1:5.3.6.1-3.fc26.x86_64
2017-09-05T14:44:37Z INFO Upgraded: libreoffice-impress-1:5.3.6.1-3.fc26.x86_64
2017-09-05T14:44:37Z INFO Upgraded: libreoffice-math-1:5.3.6.1-3.fc26.x86_64
2017-09-05T14:44:37Z INFO Upgraded: libreoffice-graphicfilter-1:5.3.6.1-3.fc26.x86_64
2017-09-05T14:44:38Z INFO Upgraded: libreoffice-draw-1:5.3.6.1-3.fc26.x86_64
2017-09-05T14:44:38Z INFO Upgraded: libreoffice-pdfimport-1:5.3.6.1-3.fc26.x86_64
2017-09-05T14:44:38Z INFO Upgraded: libreoffice-x11-1:5.3.6.1-3.fc26.x86_64
2017-09-05T14:44:38Z INFO Upgraded: libreport-filesystem-2.9.1-3.fc26.x86_64
2017-09-05T14:44:38Z INFO Upgraded: libreport-2.9.1-3.fc26.x86_64
2017-09-05T14:44:38Z INFO Upgraded: abrt-libs-2.10.3-2.fc26.x86_64
2017-09-05T14:44:39Z INFO Upgraded: libreport-web-2.9.1-3.fc26.x86_64
2017-09-05T14:44:39Z INFO Upgraded: libreport-plugin-ureport-2.9.1-3.fc26.x86_64
2017-09-05T14:44:39Z INFO Upgraded: libreport-plugin-bugzilla-2.9.1-3.fc26.x86_64
2017-09-05T14:44:39Z INFO Upgraded: libreport-fedora-2.9.1-3.fc26.x86_64
2017-09-05T14:44:39Z INFO Upgraded: libreport-plugin-logger-2.9.1-3.fc26.x86_64
2017-09-05T14:44:39Z INFO Upgraded: libreport-python3-2.9.1-3.fc26.x86_64
2017-09-05T14:44:39Z INFO Upgraded: libreport-plugin-kerneloops-2.9.1-3.fc26.x86_64
2017-09-05T14:44:39Z INFO Upgraded: libreport-plugin-reportuploader-2.9.1-3.fc26.x86_64
2017-09-05T14:44:39Z INFO Upgraded: libreport-gtk-2.9.1-3.fc26.x86_64
2017-09-05T14:44:40Z INFO Upgraded: abrt-gui-libs-2.10.3-2.fc26.x86_64
2017-09-05T14:44:40Z INFO Upgraded: abrt-addon-coredump-helper-2.10.3-2.fc26.x86_64
2017-09-05T14:44:40Z INFO Upgraded: libreport-cli-2.9.1-3.fc26.x86_64
2017-09-05T14:44:40Z INFO Upgraded: libreport-plugin-systemd-journal-2.9.1-3.fc26.x86_64
2017-09-05T14:44:40Z INFO Upgraded: abrt-python3-2.10.3-2.fc26.x86_64
2017-09-05T14:44:40Z INFO Upgraded: abrt-2.10.3-2.fc26.x86_64
2017-09-05T14:44:41Z INFO Upgraded: abrt-dbus-2.10.3-2.fc26.x86_64
2017-09-05T14:44:41Z INFO Upgraded: abrt-addon-kerneloops-2.10.3-2.fc26.x86_64
2017-09-05T14:44:41Z INFO Upgraded: abrt-retrace-client-2.10.3-2.fc26.x86_64
2017-09-05T14:44:41Z INFO Upgraded: abrt-addon-ccpp-2.10.3-2.fc26.x86_64
2017-09-05T14:44:41Z INFO Upgraded: abrt-addon-vmcore-2.10.3-2.fc26.x86_64
2017-09-05T14:44:41Z INFO Upgraded: abrt-addon-pstoreoops-2.10.3-2.fc26.x86_64
2017-09-05T14:44:41Z INFO Upgraded: abrt-plugin-bodhi-2.10.3-2.fc26.x86_64
2017-09-05T14:44:41Z INFO Upgraded: abrt-addon-xorg-2.10.3-2.fc26.x86_64
2017-09-05T14:44:42Z INFO Upgraded: abrt-addon-python3-2.10.3-2.fc26.x86_64
2017-09-05T14:44:42Z INFO Upgraded: abrt-tui-2.10.3-2.fc26.x86_64
2017-09-05T14:44:42Z INFO Upgraded: abrt-gui-2.10.3-2.fc26.x86_64
2017-09-05T14:44:42Z INFO Upgraded: abrt-desktop-2.10.3-2.fc26.x86_64
2017-09-05T14:44:42Z INFO Upgraded: abrt-cli-2.10.3-2.fc26.x86_64
2017-09-05T14:44:42Z INFO Upgraded: libreoffice-gtk2-1:5.3.6.1-3.fc26.x86_64
2017-09-05T14:44:42Z INFO Upgraded: libreoffice-1:5.3.6.1-3.fc26.x86_64
2017-09-05T14:44:43Z INFO Upgraded: plasma-workspace-drkonqi-5.10.5-3.fc26.x86_64
2017-09-05T14:44:43Z INFO Upgraded: sddm-breeze-5.10.5-3.fc26.noarch
2017-09-05T14:44:43Z INFO Upgraded: sssd-1.15.3-3.fc26.x86_64
2017-09-05T14:44:43Z INFO Upgraded: sssd-proxy-1.15.3-3.fc26.x86_64
2017-09-05T14:44:51Z INFO Upgraded: selinux-policy-targeted-3.13.1-260.8.fc26.noarch
2017-09-05T14:44:52Z INFO Upgraded: vim-enhanced-2:8.0.1030-1.fc26.x86_64
2017-09-05T14:44:52Z INFO Upgraded: vim-minimal-2:8.0.1030-1.fc26.x86_64
2017-09-05T14:44:52Z INFO Upgraded: sssd-nfs-idmap-1.15.3-3.fc26.x86_64
2017-09-05T14:44:52Z INFO Upgraded: setools-python3-4.1.0-4.fc26.x86_64
2017-09-05T14:44:52Z INFO Upgraded: publicsuffix-list-dafsa-20170828-1.fc26.noarch
2017-09-05T14:44:53Z INFO Upgraded: postgresql-libs-9.6.5-1.fc26.x86_64
2017-09-05T14:44:53Z INFO Upgraded: perl-Net-HTTP-6.17-1.fc26.noarch
2017-09-05T14:44:53Z INFO Upgraded: openjpeg2-2.2.0-3.fc26.x86_64
2017-09-05T14:44:53Z INFO Upgraded: libzip-1.3.0-1.fc26.x86_64
2017-09-05T14:44:53Z INFO Upgraded: libsss_sudo-1.15.3-3.fc26.x86_64
2017-09-05T14:44:53Z INFO Upgraded: libsss_autofs-1.15.3-3.fc26.x86_64
2017-09-05T14:44:54Z INFO Upgraded: hwdata-0.304-1.fc26.noarch
2017-09-05T14:44:54Z INFO Upgraded: compat-openssl10-1:1.0.2j-9.fc26.x86_64

Comment 1 Steven Haigh 2017-09-05 15:32:51 UTC
As a side note, I'm not sure if this has ever worked - as I don't recall ever getting any output from this plugin.

I use the yum-utils version of 'needs-restarting' on RHEL servers all the time.

Comment 2 Igor Gnatenko 2017-09-06 14:46:38 UTC
Not sure if it ever worked either... Can you actually try to use tracer plugin from dnf-plugins-extras? That seems to be better.

Comment 3 Steven Haigh 2017-09-06 15:15:58 UTC
I did look at the tracer plugin - but it didn't seem to be quite what I was after.

I'm not sure that it shows 'after the fact' applications that are out of date - say that they were installed via dnfdragora or packagekit.

Sadly, I can't test at the moment due to the fedora site being dead.

Comment 4 Steven Haigh 2017-09-06 15:36:07 UTC
Interestingly enough, I just ran a 'dnf -y update' on my system which pulled down a heap of packages.

I then got:
# dnf needs-restarting
1120 : /usr/bin/sddm
1231 : /usr/libexec/sddm-helper --socket /tmp/sddm-auth8d73ce4b-97bc-4635-b8d4-4ed1f2a14b58 --id 1 --start /usr/bin/startkde
1309 : /usr/libexec/kf5/klauncher --fd=9
1313 : kded5 [kdeinit5]
1325 : /usr/bin/kaccess
1334 : /usr/bin/ksmserver
1346 : /usr/bin/kglobalaccel5
1356 : kwin_x11
1360 : /usr/libexec/kdeconnectd
1361 : /usr/bin/krunner
1363 : /usr/bin/plasmashell
--- snip ---

This is interesting - as:
1) it took a *lot* longer to run than any other time it has run (expected if its actually doing something); and
2) It actually output information.

This is a first - so I'm not sure what the fix was - or how to try and replicate an issue again :\

Comment 5 Fedora End Of Life 2018-05-03 07:59:14 UTC
This message is a reminder that Fedora 26 is nearing its end of life.
Approximately 4 (four) weeks from now Fedora will stop maintaining
and issuing updates for Fedora 26. It is Fedora's policy to close all
bug reports from releases that are no longer maintained. At that time
this bug will be closed as EOL if it remains open with a Fedora  'version'
of '26'.

Package Maintainer: If you wish for this bug to remain open because you
plan to fix it in a currently maintained version, simply change the 'version'
to a later Fedora version.

Thank you for reporting this issue and we are sorry that we were not
able to fix it before Fedora 26 is end of life. If you would still like
to see this bug fixed and are able to reproduce it against a later version
of Fedora, you are encouraged  change the 'version' to a later Fedora
version prior this bug is closed as described in the policy above.

Although we aim to fix as many bugs as possible during every release's
lifetime, sometimes those efforts are overtaken by events. Often a
more recent Fedora release includes newer upstream software that fixes
bugs or makes them obsolete.

Comment 6 Jan Kurik 2018-08-14 10:18:10 UTC
This bug appears to have been reported against 'rawhide' during the Fedora 29 development cycle.
Changing version to '29'.

Comment 8 Ben Cotton 2019-10-31 19:02:13 UTC
This message is a reminder that Fedora 29 is nearing its end of life.
Fedora will stop maintaining and issuing updates for Fedora 29 on 2019-11-26.
It is Fedora's policy to close all bug reports from releases that are no longer
maintained. At that time this bug will be closed as EOL if it remains open with a
Fedora 'version' of '29'.

Package Maintainer: If you wish for this bug to remain open because you
plan to fix it in a currently maintained version, simply change the 'version' 
to a later Fedora version.

Thank you for reporting this issue and we are sorry that we were not 
able to fix it before Fedora 29 is end of life. If you would still like 
to see this bug fixed and are able to reproduce it against a later version 
of Fedora, you are encouraged  change the 'version' to a later Fedora 
version prior this bug is closed as described in the policy above.

Although we aim to fix as many bugs as possible during every release's 
lifetime, sometimes those efforts are overtaken by events. Often a 
more recent Fedora release includes newer upstream software that fixes 
bugs or makes them obsolete.

Comment 9 Ben Cotton 2019-11-27 23:04:10 UTC
Fedora 29 changed to end-of-life (EOL) status on 2019-11-26. Fedora 29 is
no longer maintained, which means that it will not receive any further
security or bug fix updates. As a result we are closing this bug.

If you can reproduce this bug against a currently maintained version of
Fedora please feel free to reopen this bug against that version. If you
are unable to reopen this bug, please file a new report against the
current release. If you experience problems, please add a comment to this
bug.

Thank you for reporting this bug and we are sorry it could not be fixed.


Note You need to log in before you can comment on or make changes to this bug.