Bug 1488542 - "No such drive" error on live merge of one disk causes merge of other disk to fail on engine.
Summary: "No such drive" error on live merge of one disk causes merge of other disk to...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: vdsm
Version: 4.1.4
Hardware: Unspecified
OS: Linux
unspecified
high
Target Milestone: ovirt-4.2.0
: ---
Assignee: Ala Hino
QA Contact: Kevin Alon Goldblatt
URL:
Whiteboard:
Depends On:
Blocks: 1509614
TreeView+ depends on / blocked
 
Reported: 2017-09-05 16:03 UTC by Koutuk Shukla
Modified: 2021-03-11 17:20 UTC (History)
14 users (show)

Fixed In Version: vdsm-4.20.8
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
: 1509614 (view as bug list)
Environment:
Last Closed: 2018-05-15 17:51:57 UTC
oVirt Team: Storage
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Red Hat Product Errata RHEA-2018:1489 0 None None None 2018-05-15 17:53:24 UTC
oVirt gerrit 83490 0 master MERGED live-merge: Handle LookupError when tracking active layer merge job 2017-11-22 10:45:51 UTC
oVirt gerrit 84448 0 master MERGED live-merge: Handle errors raised during updating VM block jobs 2017-11-21 21:13:45 UTC

Description Koutuk Shukla 2017-09-05 16:03:37 UTC
Description of problem:

During live snapshot deletion on vm holding 5 disks. We see that the merge is sucessfull for 4 disks and 1 fails on engine side but completes on host side.
According to vdsm.log it appears that when a Live Merge for one disk was being performed, a No such drive error was reported while checking the block job after the pivot had completed. The volume that caused this was the volume that was just pivoted from, i.e. the original active volume. However this merge completed sucessfully but caused other disk merge operation to fail on engine side but complete on host side.  The images are marged illegal on rhevm database and lv's remain unremoved on Host.

Issue seems similar to the bug https://bugzilla.redhat.com/show_bug.cgi?id=1447437.  Opening this new bug to check further if this new bug or regression. 


Version-Release number of selected component (if applicable):
rhevm-4.1.4.2-0.1.el7.noarch
libvirt-daemon-2.0.0-10.el7_3.9.x86_64
vdsm-4.19.20-1.el7ev.x86_64

How reproducible:
No

Steps to Reproduce:
1.
2.
3.

Actual results:
"No such drive" LookupErrors occurred while checking a block job after the pivot had completed, causing the engine to "fail" merges for two other disk


Expected results:
Merge should complete without any errors.

Comment 16 RHV bug bot 2017-12-06 15:56:28 UTC
according to pathces, fixes are in vdsm not engine, changing component to add to right ET.

Comment 17 RHV bug bot 2017-12-06 16:15:22 UTC
INFO: Bug status wasn't changed from MODIFIED to ON_QA due to the following reason:

[Project 'vdsm'/Component 'ovirt-engine' mismatch]

For more info please contact: rhv-devops@redhat.com

Comment 21 Kevin Alon Goldblatt 2017-12-12 11:55:02 UTC
Tested with the following code:
--------------------------------
ovirt-engine-4.2.0-0.6.el7.noarch
vdsm-4.20.9-1.el7ev.x86_64


Verified with the following scenario:
-----------------------------------------------------
1.Create Vm with 5 disks
2.Create snapshot s1
3.Start VM add data to disks
4.Create snapshot s2
5.Delete snapshot s1 - all snapshot is merged correctly, all disk snapshots are removed, no "No such drive error" reported


Moving to VERIFIED

Comment 26 errata-xmlrpc 2018-05-15 17:51:57 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHEA-2018:1489

Comment 27 Franta Kust 2019-05-16 13:08:56 UTC
BZ<2>Jira Resync


Note You need to log in before you can comment on or make changes to this bug.