Bug 1488613 - Running rhui-installer can fail due to slow or long-running mountpoint operations
Summary: Running rhui-installer can fail due to slow or long-running mountpoint operat...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Update Infrastructure for Cloud Providers
Classification: Red Hat
Component: Tools
Version: 3.0.0
Hardware: Unspecified
OS: Unspecified
unspecified
high
Target Milestone: 3.0.3
: ---
Assignee: RHUI Bug List
QA Contact: Vratislav Hutsky
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-09-05 20:28 UTC by Craig Donnelly
Modified: 2018-05-16 12:49 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-05-16 12:48:53 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2018:1569 None None None 2018-05-16 12:49:23 UTC

Description Craig Donnelly 2017-09-05 20:28:45 UTC
Description of problem:
Currently when attempting to update certs on RHUA your rhui-installer run can fail leaving your RHUI in a bad state.

The reason for failure appears to be due the requirement for certain actions against the shared mount point.

The module at: /usr/share/rhui-installer/modules/rhua/manifests/mounts.pp contains a section:

18   exec { 'set-share-permissions':
19     command => "chown -R apache:apache ${rhua::remote_fs_mountpoint}",
20     path => '/usr/bin/:/bin/',
21     require => [Exec['create-share-dir'], Package['httpd']],
22   }

This chown operation was extremely long running over NFS mount, even though all of the permissions were already set correctly.
This caused an indefinite failure for our installer runs due to a buildup of `chown` operations and slow activity on their part.

To work around the issue, I changed line 19 of the module:

19     command => "echo test", #chown -R apache:apache ${rhua::remote_fs_mountpoint}",

Then killed all of the chown operations in progress:

# pkill chown

I could then successfully run the installer.

Version-Release number of selected component (if applicable):
rhui-installer-3.0.0-1.el7ui.noarch
rhui-installer-base-3.0.0-1.el7ui.noarch

How reproducible:
? (100% in our test env)

Steps to Reproduce:
1. Have a NFS mounted/slow storage environment?
2. Run default rhui-installer

Actual results:
If chown operation does not complete/hangs, installer will fail.

Expected results:
The chown operation against 

Additional info:

Comment 11 errata-xmlrpc 2018-05-16 12:48:53 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2018:1569


Note You need to log in before you can comment on or make changes to this bug.