Bugzilla (bugzilla.redhat.com) will be under maintenance for infrastructure upgrades and will not be available on July 31st between 12:30 AM - 05:30 AM UTC. We appreciate your understanding and patience. You can follow status.redhat.com for details.
Bug 1488618 - failed to apply applicable erratas to a content host
Summary: failed to apply applicable erratas to a content host
Keywords:
Status: CLOSED DUPLICATE of bug 1488167
Alias: None
Product: Red Hat Satellite
Classification: Red Hat
Component: Errata Management
Version: 6.2.12
Hardware: x86_64
OS: Linux
unspecified
medium
Target Milestone: Unspecified
Assignee: satellite6-bugs
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-09-05 20:41 UTC by Reartes Guillermo
Modified: 2018-05-28 11:45 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-02-20 19:46:49 UTC
Target Upstream Version:


Attachments (Terms of Use)
foreman-debug (5.39 MB, application/x-xz)
2017-09-05 20:41 UTC, Reartes Guillermo
no flags Details
screenshot of the failed task (105.99 KB, image/png)
2017-09-05 20:43 UTC, Reartes Guillermo
no flags Details
screenshot of the compoent simple content view (70.74 KB, image/png)
2017-09-05 20:44 UTC, Reartes Guillermo
no flags Details
screenshot of the composite content view tab versions (72.49 KB, image/png)
2017-09-05 20:45 UTC, Reartes Guillermo
no flags Details
screenshot of the composite content view tab content views (64.78 KB, image/png)
2017-09-05 20:47 UTC, Reartes Guillermo
no flags Details
foreman-debug (second sat6.2 instance) (3.29 MB, application/x-xz)
2017-09-08 14:11 UTC, Reartes Guillermo
no flags Details

Description Reartes Guillermo 2017-09-05 20:41:24 UTC
Created attachment 1322401 [details]
foreman-debug

Description of problem: 

I went to CONTENT -> ERRATA -> Selected RHBA-2017:2577 (APPLICABLE)
and then tried to apply to a content host "prueba8.example.com" (provisioned via Sat6 moments ago).

The incremental update task failed with "a sub task failed".

The package (binutils-2.25.1-32.base.el7_4.1.x86_64) is not in the content host's content view, it is not found, so i cannot be installed.

I searched the package in Package Search and it is only on the Default Organization View, for some odd reason, the incremental update did not put it in the new content view version 1.1. 

Also, it is odd, but the simple content view S_RHEL7 v 1.1 is NOT PUBLISHED to Library !!!!

Also odd, the composite content view C_RHEL7 is also NOT PUBLISHED to Library but it is PROMOTED to DESA !!!!

Also for C_RHEL7, in the "content view" tab, al simple content view version are sill on 1.0 !!!!!!!!

It the first time i tested this with composite content views, is the installation of applicable erratas supposed to work for composite content views?


Version-Release number of selected component (if applicable):
6.2.11


How reproducible:
i tried once, i cannot setup the test environment again at them moment.

Steps to Reproduce:
1. Go to CONTENT -> ERRATA
2. Select Errata: RHBA-2017:2577
3. Select Content Hosts: "prueba8.example.com" (the content hosts uses a composite content view)
4. Click on CONFIRM. The INCREMENTAL UPDATE begins... it takes its time...
5. Task INCREMENTAL UPDATE, "sub task failed", a very helpful error. (on the content hosts messages, it is shown that the package was not found)


Actual results: 

Unable to apply applicable erratas to a content host.


Expected results:

Being able to apply applicable erratas.


Additional info:

Comment 1 Reartes Guillermo 2017-09-05 20:43:28 UTC
Created attachment 1322403 [details]
screenshot of the failed task

Comment 2 Reartes Guillermo 2017-09-05 20:44:07 UTC
Created attachment 1322404 [details]
screenshot of the compoent simple content view

Comment 3 Reartes Guillermo 2017-09-05 20:45:41 UTC
Created attachment 1322405 [details]
screenshot of the composite content view tab versions

Comment 4 Reartes Guillermo 2017-09-05 20:47:16 UTC
Created attachment 1322406 [details]
screenshot of the composite content view tab content views

Comment 5 Reartes Guillermo 2017-09-08 14:08:09 UTC
I tested on the same Satellite 6 instance with another system (RHEL7.2 installed from iso) and another errata, but with a regular simple content view instead. It also failed.

Comment 6 Reartes Guillermo 2017-09-08 14:09:36 UTC
On ANOTHER Satellite 6.2.11 instance, i repeated the test with a RHEL7.2 installed from ISO and a COMPOSITE content view (similar to the first test, but with another errata). 

It also failed. 
I am unable to apply applicable erratas for some reason.

Comment 7 Reartes Guillermo 2017-09-08 14:11:04 UTC
Created attachment 1323751 [details]
foreman-debug (second sat6.2 instance)

Comment 9 Reartes Guillermo 2017-10-02 15:22:21 UTC
Tried again with 6.2.12 on my laptop sat6, the issue is still present.

I have yet to update my lab sat6 to 6.2.12 and test.

Comment 10 Brad Buckingham 2017-10-06 13:39:38 UTC
Hi Reartes,

One of my colleagues just reminded me of bug 1488167.  It is very likely that this is the behavior that you are encountering.  The solution for it is available upstream and is planned for the next Satellite 6.2.z (6.2.13).

Comment 13 Brad Buckingham 2018-02-20 19:46:49 UTC
As mentioned in comment 10, this is believed to be related to bug 1488167; therefore, closing as a duplicate.  If you are able to reproduce the issue after updating to the latest 6.2.z (currently 6.2.14), please do re-open and provide the appropriate details.  Thanks!

*** This bug has been marked as a duplicate of bug 1488167 ***


Note You need to log in before you can comment on or make changes to this bug.