Bug 1488784 - [backport][Ocata] Fix the s3tokens endpoint
Summary: [backport][Ocata] Fix the s3tokens endpoint
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat OpenStack
Classification: Red Hat
Component: puppet-barbican
Version: 11.0 (Ocata)
Hardware: Unspecified
OS: Unspecified
high
high
Target Milestone: z5
: 11.0 (Ocata)
Assignee: Christian Schwede (cschwede)
QA Contact: Aharon Canan
URL:
Whiteboard:
: 1484200 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-09-06 08:07 UTC by Robin Cernin
Modified: 2021-09-09 12:34 UTC (History)
7 users (show)

Fixed In Version: puppet-barbican-10.4.0-1.el7ost
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-05-18 17:17:01 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
OpenStack gerrit 501148 0 None None None 2017-09-06 08:08:52 UTC
Red Hat Product Errata RHBA-2018:1623 0 None None None 2018-05-18 17:18:06 UTC

Description Robin Cernin 2017-09-06 08:07:58 UTC
Description of problem:

This was broken when issue_v2_token was removed, and no one noticed because there are no tests. The good news is, Swift3 is content to move toward supporting the v3 format, so just start inheriting from the v3 controller.

Upstream backport proposed https://review.openstack.org/#/c/501148/

Comment 1 Alex Stupnikov 2018-02-05 09:44:43 UTC
Upstream backport was merged at Jan-25, please proceed with the bug.

Comment 4 Christian Schwede (cschwede) 2018-04-10 11:18:49 UTC
*** Bug 1484200 has been marked as a duplicate of this bug. ***

Comment 7 Harry Rybacki 2018-04-18 14:39:50 UTC
Upstream review[1] merged awhile back -- moving bug to POST.

[1] - https://review.openstack.org/#/c/501148/

Comment 16 errata-xmlrpc 2018-05-18 17:17:01 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2018:1623


Note You need to log in before you can comment on or make changes to this bug.