Bug 1488889 - s390x: binutils strip tool segfaults
Summary: s390x: binutils strip tool segfaults
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: binutils
Version: 7.5
Hardware: s390x
OS: Unspecified
unspecified
unspecified
Target Milestone: rc
: ---
Assignee: Nick Clifton
QA Contact: Miloš Prchlík
Vladimír Slávik
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-09-06 12:01 UTC by David Hildenbrand
Modified: 2018-04-10 10:00 UTC (History)
8 users (show)

Fixed In Version: binutils-2.27-16.base.el7
Doc Type: Bug Fix
Doc Text:
The *strip* utility works again Previously, the BFD library missed a NULL pointer check on the IBM z Systems architecture. As a consequence, running the *strip* utility caused a segmentation fault. This bug has been fixed, and *strip* now works as expected.
Clone Of:
Environment:
Last Closed: 2018-04-10 09:59:05 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2018:0686 None None None 2018-04-10 10:00:54 UTC
Red Hat Bugzilla 1485398 None None None Never

Internal Links: 1485398

Description David Hildenbrand 2017-09-06 12:01:40 UTC
Description of problem:
While playing with the patch for bz 1485398, I noticed that the strip command is completely broken on s390x.

Version-Release number of selected component (if applicable):
binutils-2.27-15.base.el7

How reproducible:
100%

Steps to Reproduce:
1. Create a simple C program

test.c:
int main()
{
        return 0;
}


2. Compile it
$ gcc test.c -o test

3. Try to strip it using the strip tool

Actual results:


Expected results:


Additional info:

Comment 2 David Hildenbrand 2017-09-06 12:04:55 UTC
(new try after I pushed the enter key too early ...)

Description of problem:
While playing with the patch for bz 1485398, I noticed that the strip command is completely broken on s390x.

Version-Release number of selected component (if applicable):
binutils-2.27-15.base.el7

How reproducible: 100%

Steps to Reproduce:
1. Create a simple C program

test.c:
int main()
{
        return 0;
}


2. Compile it
$ gcc test.c -o test

3. Try to strip it using the strip tool
$ strip --strip-unneeded test -o test.strip


Actual results: "Segmentation fault"
Expected results: No segmentation fault.

Comment 3 Nick Clifton 2017-09-06 14:51:34 UTC
Fixed in  binutils-2.27-16.base.el7

Comment 7 Miloš Prchlík 2018-01-31 11:37:26 UTC
Verified with binutils-2.27-27.base.el7.s390x.

Comment 10 errata-xmlrpc 2018-04-10 09:59:05 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2018:0686


Note You need to log in before you can comment on or make changes to this bug.