Bug 1488905 - [UPDATES] After undercloud update, overcloud updates fail with The Workflow (tripleo.overcloud.workflowtasks.step2) could not be found.
Summary: [UPDATES] After undercloud update, overcloud updates fail with The Workflow ...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat OpenStack
Classification: Red Hat
Component: instack-undercloud
Version: 12.0 (Pike)
Hardware: Unspecified
OS: Unspecified
urgent
urgent
Target Milestone: beta
: 12.0 (Pike)
Assignee: Dougal Matthews
QA Contact: Yurii Prokulevych
URL:
Whiteboard:
: 1690468 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-09-06 12:35 UTC by Yurii Prokulevych
Modified: 2019-07-02 09:23 UTC (History)
10 users (show)

Fixed In Version: instack-undercloud-7.4.1-1.el7ost openstack-tripleo-common-7.6.3-0.20171022171807.f27b723.el7ost
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-12-13 22:05:43 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Launchpad 1715389 0 None None None 2017-09-06 12:52:35 UTC
OpenStack gerrit 501319 0 None MERGED Add "tripleo-common-managed" to all workflows in tripleo_common 2020-04-17 01:31:18 UTC
OpenStack gerrit 501326 0 None MERGED Only delete workflows with the tripleo-common-managed tag 2020-04-17 01:31:18 UTC
Red Hat Product Errata RHEA-2017:3462 0 normal SHIPPED_LIVE Red Hat OpenStack Platform 12.0 Enhancement Advisory 2018-02-16 01:43:25 UTC

Description Yurii Prokulevych 2017-09-06 12:35:37 UTC
Description of problem:
-----------------------
Attempt to setup-heat-outputs on RHOS-12 failed

openstack overcloud deploy \
--templates /usr/share/openstack-tripleo-heat-templates \
--libvirt-type kvm \
--ntp-server clock.redhat.com \
-e /usr/share/openstack-tripleo-heat-templates/environments/storage-environment.yaml \
-e /home/stack/virt/internal.yaml \
-e /usr/share/openstack-tripleo-heat-templates/environments/network-isolation.yaml \
-e /home/stack/virt/network/network-environment.yaml \
-e /home/stack/virt/inject-trust-anchor.yaml \
-e /home/stack/virt/hostnames.yml \
-e /usr/share/openstack-tripleo-heat-templates/environments/ceph-ansible/ceph-ansible.yaml \
-e /usr/share/openstack-tripleo-heat-templates/environments/docker.yaml \
-e /usr/share/openstack-tripleo-heat-templates/environments/docker-ha.yaml \
-e /home/stack/virt/debug.yaml \
-e /home/stack/virt/nodes_data.yaml \
-e /home/stack/virt/docker-images.yaml \
-e /home/stack/virt/docker-images-ceph.yaml --setup-heat-outputs
...
2017-09-06 10:49:37Z [overcloud-AllNodesDeploySteps-usiltjd4ta5w.BlockStorageDeployment_Step1]: CREATE_IN_PROGRESS  stateHeat Stack update failed.
Heat Stack update failed.
 changed
2017-09-06 10:49:38Z [overcloud-AllNodesDeploySteps-usiltjd4ta5w.CephStorageDeployment_Step1]: CREATE_COMPLETE  state changed
2017-09-06 10:49:38Z [overcloud-AllNodesDeploySteps-usiltjd4ta5w.ControllerDeployment_Step1]: CREATE_COMPLETE  state changed
2017-09-06 10:49:38Z [overcloud-AllNodesDeploySteps-usiltjd4ta5w.ObjectStorageDeployment_Step1]: CREATE_COMPLETE  state changed
2017-09-06 10:49:38Z [overcloud-AllNodesDeploySteps-usiltjd4ta5w.BlockStorageDeployment_Step1]: CREATE_COMPLETE  state changed
2017-09-06 10:49:38Z [overcloud-AllNodesDeploySteps-usiltjd4ta5w.ComputeDeployment_Step1]: CREATE_COMPLETE  state changed
2017-09-06 10:49:38Z [overcloud-AllNodesDeploySteps-usiltjd4ta5w.WorkflowTasks_Step2_Execution]: UPDATE_IN_PROGRESS  state changed
2017-09-06 10:49:39Z [overcloud-AllNodesDeploySteps-usiltjd4ta5w.WorkflowTasks_Step2_Execution]: UPDATE_FAILED  StackValidationFailed: resources.WorkflowTasks_Step2_Execution: Property error: Properties.actions.CREATE.workflow: Error validating value 'tripleo.overcloud.workflowtasks.step2': The Workflow (tripleo.overcloud.workflowtasks.step2) could not be found.
2017-09-06 10:49:40Z [overcloud-AllNodesDeploySteps-usiltjd4ta5w]: UPDATE_FAILED  StackValidationFailed: resources.WorkflowTasks_Step2_Execution: Property error: Properties.actions.CREATE.workflow: Error validating value 'tripleo.overcloud.workflowtasks.step2': The Workflow (tripleo.overcloud.workflowtasks.step2) could not be found.
2017-09-06 10:49:41Z [AllNodesDeploySteps]: UPDATE_FAILED  resources.AllNodesDeploySteps: StackValidationFailed: resources.WorkflowTasks_Step2_Execution: Property error: Properties.actions.CREATE.workflow: Error validating value 'tripleo.overcloud.workflowtasks.step2': The Workflow (tripleo.overcloud.workflowtask
2017-09-06 10:49:42Z [overcloud]: UPDATE_FAILED  resources.AllNodesDeploySteps: StackValidationFailed: resources.WorkflowTasks_Step2_Execution: Property error: Properties.actions.CREATE.workflow: Error validating value 'tripleo.overcloud.workflowtasks.step2': The Workflow (tripleo.overcloud.workflowtask

 Stack overcloud UPDATE_FAILED 

overcloud.AllNodesDeploySteps.WorkflowTasks_Step2_Execution:
  resource_type: OS::Mistral::ExternalResource
  physical_resource_id: ca023c45-d90f-43e9-8dc1-6426551b7469
  status: UPDATE_FAILED
  status_reason: |
    StackValidationFailed: resources.WorkflowTasks_Step2_Execution: Property error: Properties.actions.CREATE.workflow: Error validating value 'tripleo.overcloud.workflowtasks.step2': The Workflow (tripleo.overcloud.workflowtasks.step2) could not be found.


Version-Release number of selected component (if applicable):
-------------------------------------------------------------
openstack-tripleo-heat-templates-7.0.0-0.20170901051303.0rc1.el7ost.noarch
openstack-mistral-executor-5.0.1-0.20170830120805.4bc0950.el7ost.noarch
python-mistral-lib-0.2.0-0.20170821165722.bb1b87b.el7ost.noarch
openstack-mistral-common-5.0.1-0.20170830120805.4bc0950.el7ost.noarch
python-mistralclient-3.1.2-0.20170821154201.e328a05.el7ost.noarch
python-mistral-5.0.1-0.20170830120805.4bc0950.el7ost.noarch
openstack-mistral-api-5.0.1-0.20170830120805.4bc0950.el7ost.noarch
puppet-mistral-11.3.1-0.20170825184651.cf2e493.el7ost.noarch
openstack-mistral-engine-5.0.1-0.20170830120805.4bc0950.el7ost.noarch


Steps to Reproduce:
-------------------
1. Install latest repos(2017-09-05.9) on uc and oc
2. Update uc, reboot
3. Apply next patches from next review: 500346, 495658, 491749, 485732, 486567
4. Push latest images to the registry
5. Run initial deploy command with setup-heat-outputs option

Comment 5 Yurii Prokulevych 2017-11-07 13:19:48 UTC
Verified with:
    instack-undercloud-7.4.2-2.el7ost.noarch
    openstack-tripleo-common-7.6.3-0.20171028055750.el7ost.noarch

openstack overcloud update stack --init-minor-update \
    --container-registry-file /home/stack/virt/docker-images.yaml
...

2017-11-07 13:05:37Z [overcloud-AllNodesDeploySteps-744wfzdaav26]: UPDATE_COMPLETE  Stack UPDATE completed successfully
2017-11-07 13:05:38Z [AllNodesDeploySteps]: UPDATE_COMPLETE  state changed
2017-11-07 13:05:53Z [overcloud]: UPDATE_COMPLETE  Stack UPDATE completed successfully

 Stack overcloud UPDATE_COMPLETE 

Minor update init on stack overcloud complete.

Workflows without common tag:
 - tripleo.overcloud.workflow_tasks.step2
 - std.create_instance
 - std.delete_instance

Comment 9 errata-xmlrpc 2017-12-13 22:05:43 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHEA-2017:3462

Comment 11 Lukas Bezdicka 2019-07-02 09:23:59 UTC
*** Bug 1690468 has been marked as a duplicate of this bug. ***


Note You need to log in before you can comment on or make changes to this bug.