Bugzilla (bugzilla.redhat.com) will be under maintenance for infrastructure upgrades and will not be unavailable on July 31st between 12:30 AM - 05:30 AM UTC. We appreciate your understanding and patience. You can follow status.redhat.com for details.
Bug 1488906 - Fix clagn/gcc warning for umountd
Summary: Fix clagn/gcc warning for umountd
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: GlusterFS
Classification: Community
Component: build
Version: mainline
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: bugs@gluster.org
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-09-06 12:37 UTC by M. Scherer
Modified: 2017-12-08 17:40 UTC (History)
1 user (show)

Fixed In Version: glusterfs-3.13.0
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-12-08 17:40:26 UTC
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:


Attachments (Terms of Use)

Description M. Scherer 2017-09-06 12:37:44 UTC
Description of problem:
The build on FreeBSD (and maybe others) show this:

        umountd.c:59:61: warning: data argument not
        used by format string [-Wformat-extra-args]
        "Cannot access %s\n", path, strerror (errno));

Comment 1 Worker Ant 2017-09-06 12:40:08 UTC
REVIEW: https://review.gluster.org/18219 (Fix clang/gcc warning -Wformat-extra-args) posted (#1) for review on master by Michael Scherer (misc@fedoraproject.org)

Comment 2 Worker Ant 2017-09-07 16:52:42 UTC
COMMIT: https://review.gluster.org/18219 committed in master by Jeff Darcy (jeff@pl.atyp.us) 
------
commit 07c11798ed219c7d8484d4c1f4729cd83cd4a09e
Author: Michael Scherer <misc@redhat.com>
Date:   Wed Sep 6 14:35:39 2017 +0200

    Fix clang/gcc warning -Wformat-extra-args
    
        umountd.c:59:61: warning: data argument not
        used by format string [-Wformat-extra-args]
        "Cannot access %s\n", path, strerror (errno));
    
    Change-Id: If1622d5b806ce6795ad2f84f2f2874227811dd96
    BUG: 1488906
    Signed-off-by: Michael Scherer <misc@redhat.com>
    Reviewed-on: https://review.gluster.org/18219
    Smoke: Gluster Build System <jenkins@build.gluster.org>
    Tested-by: Michael Scherer <misc@fedoraproject.org>
    CentOS-regression: Gluster Build System <jenkins@build.gluster.org>
    Reviewed-by: Jeff Darcy <jeff@pl.atyp.us>

Comment 3 Shyamsundar 2017-12-08 17:40:26 UTC
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.13.0, please open a new bug report.

glusterfs-3.13.0 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] http://lists.gluster.org/pipermail/announce/2017-December/000087.html
[2] https://www.gluster.org/pipermail/gluster-users/


Note You need to log in before you can comment on or make changes to this bug.