Bug 1488938 (CVE-2017-13741) - CVE-2017-13741 liblouis: Use-after-free in the function compileBrailleIndicator()
Summary: CVE-2017-13741 liblouis: Use-after-free in the function compileBrailleIndicat...
Keywords:
Status: CLOSED ERRATA
Alias: CVE-2017-13741
Product: Security Response
Classification: Other
Component: vulnerability
Version: unspecified
Hardware: All
OS: Linux
low
low
Target Milestone: ---
Assignee: Red Hat Product Security
QA Contact:
URL:
Whiteboard: impact=low,public=20170823,reported=2...
Depends On: 1488944 1492713 1492715
Blocks: 1488949
TreeView+ depends on / blocked
 
Reported: 2017-09-06 13:36 UTC by Andrej Nemec
Modified: 2019-06-08 22:18 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-11-03 16:04:57 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHSA-2017:3111 normal SHIPPED_LIVE Moderate: liblouis security update 2017-11-02 19:51:34 UTC

Description Andrej Nemec 2017-09-06 13:36:58 UTC
There is a use-after-free in the function compileBrailleIndicator() in compileTranslationTable.c in Liblouis 3.2.0 that will lead to a denial of service attack.

Product bug:

https://bugzilla.redhat.com/show_bug.cgi?id=1484332

Comment 1 Andrej Nemec 2017-09-06 13:40:20 UTC
Created liblouis tracking bugs for this issue:

Affects: fedora-all [bug 1488944]

Comment 5 errata-xmlrpc 2017-11-02 15:52:33 UTC
This issue has been addressed in the following products:

  Red Hat Enterprise Linux 7

Via RHSA-2017:3111 https://access.redhat.com/errata/RHSA-2017:3111


Note You need to log in before you can comment on or make changes to this bug.