Bug 148895 - internal compiler error: in fold_convert, at fold-const.c:1917
internal compiler error: in fold_convert, at fold-const.c:1917
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: gcc3 (Show other bugs)
4.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Jakub Jelinek
:
Depends On:
Blocks: 137160 145334
  Show dependency treegraph
 
Reported: 2005-02-16 14:07 EST by Mike Marciniszyn
Modified: 2007-11-30 17:07 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-09-29 15:38:00 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
c++ program - compile g++ -c foo.cpp (592.96 KB, text/plain)
2005-02-16 14:09 EST, Mike Marciniszyn
no flags Details

  None (edit)
Description Mike Marciniszyn 2005-02-16 14:07:37 EST
Description of problem:

Dump from compiler

Version-Release number of selected component (if applicable):

3.4.3-9.EL4


How reproducible:
100%


Steps to Reproduce:
Compile the attached program
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Mike Marciniszyn 2005-02-16 14:09:23 EST
Created attachment 111132 [details]
c++ program - compile g++ -c foo.cpp

save as foo.cpp;type g++ -c foo.cpp
Comment 2 Mike Marciniszyn 2005-02-16 14:10:55 EST
Is the fix in 19666 (gcc.gnu.org PR) applicable here?
Comment 3 Mike Marciniszyn 2005-02-17 11:05:03 EST
I've confirmed that the the fix for 19666 corrects the issue by 
introducing the patch into the 3.4.3-9.EL src rpm for gcc.

I guess I need to know when this will be fixed in EL4 for our 
planning purposes.


Comment 4 Jakub Jelinek 2005-02-17 11:07:55 EST
In RHEL4 U1 most probably.
Basically, everything in the current rawhide gcc package (gcc-3.4.3-19)
is intended for RHEL4 U1.
Comment 7 Jakub Jelinek 2005-03-01 06:14:56 EST
Should be fixed in gcc-3.4.3-21.
Comment 8 Jay Turner 2005-04-16 14:17:55 EDT
Fix confirmed with gcc-3.4.3-22.  Moving to PROD_READY.

Note You need to log in before you can comment on or make changes to this bug.