Bug 1489064 - prevent creation (of pools with) too many PGs
Summary: prevent creation (of pools with) too many PGs
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Ceph Storage
Classification: Red Hat
Component: RADOS
Version: 3.0
Hardware: All
OS: All
high
high
Target Milestone: rc
: 3.0
Assignee: Josh Durgin
QA Contact: shylesh
Bara Ancincova
URL:
Whiteboard:
Keywords: Reopened
: 1491007 (view as bug list)
Depends On:
Blocks: 1494421
TreeView+ depends on / blocked
 
Reported: 2017-09-06 15:59 UTC by Sage Weil
Modified: 2017-12-05 23:42 UTC (History)
13 users (show)

(edit)
.The number of PGs per OSD is now limited

Previously, it was possible to create pools that included a large number of placement groups (PGs) which could overload the cluster. This update introduces a new configuration option, `mon_max_pg_per_osd`, that limits the number of PGs per OSD to 200. Creating pools or adjusting the `pg_num` parameter now fails if the change would make the number of PGs per OSD exceed the configured limit. You can adjust this option in the Ceph configuration file. In addition, the `mon_pg_warn_max_per_osd` option has been removed.
Clone Of:
(edit)
Last Closed: 2017-12-05 23:42:05 UTC


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2017:3387 normal SHIPPED_LIVE Red Hat Ceph Storage 3.0 bug fix and enhancement update 2017-12-06 03:03:45 UTC
Github ceph ceph pull 17814 None None None 2017-10-05 16:02 UTC

Description Sage Weil 2017-09-06 15:59:30 UTC
Description of problem:

Users can create pools with lots of pgs and overload the cluster.  Prevent that via a config option that limits the pgs per osd.

See upstream PR https://github.com/ceph/ceph/pull/17427.  This will need to be backported to luminous and (maybe) 2.y.

Comment 2 Ian Colle 2017-10-04 15:31:08 UTC
https://github.com/ceph/ceph/pull/17814 is backport PR

Comment 6 Josh Durgin 2017-10-16 15:20:31 UTC

*** This bug has been marked as a duplicate of bug 1491007 ***

Comment 8 Josh Durgin 2017-10-16 15:30:00 UTC
*** Bug 1491007 has been marked as a duplicate of this bug. ***

Comment 18 shylesh 2017-10-25 09:28:03 UTC
Verified on 12.2.1-29

Comment 22 errata-xmlrpc 2017-12-05 23:42:05 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2017:3387


Note You need to log in before you can comment on or make changes to this bug.