Bug 1489192 - (OSP-12)Ironic introspection loops over ipxe.efi for UEFI boot_mode
Summary: (OSP-12)Ironic introspection loops over ipxe.efi for UEFI boot_mode
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat OpenStack
Classification: Red Hat
Component: puppet-ironic
Version: 12.0 (Pike)
Hardware: Unspecified
OS: Unspecified
high
high
Target Milestone: rc
: 12.0 (Pike)
Assignee: Bob Fournier
QA Contact: mlammon
URL:
Whiteboard:
: 1464523 (view as bug list)
Depends On: 1479386 1489546
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-09-06 23:17 UTC by Bob Fournier
Modified: 2020-09-10 11:20 UTC (History)
12 users (show)

Fixed In Version: puppet-ironic-11.3.1-0.20171006212724.56f526a.el7ost
Doc Type: Bug Fix
Doc Text:
Previously, the DHCP server configuration file for Ironic Inspector did not handle hosts that used UEFI and iPXE, which caused some UEFI and iPXE hosts to fail to boot during Ironic Introspection. This fix updates the DHCP server file `/etc/ironic-inspector/dnsmasq.conf` to handle UEFI and iPXE hosts, and now the hosts can properly boot during Ironic Introspection.
Clone Of: 1479386
Environment:
Last Closed: 2017-12-13 22:05:43 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Launchpad 1714320 None None None 2017-09-06 23:17:51 UTC
OpenStack gerrit 501445 None MERGED Fixes for Ironic-inspector introspection when client using UEFI 2020-10-01 09:26:08 UTC
Red Hat Product Errata RHEA-2017:3462 normal SHIPPED_LIVE Red Hat OpenStack Platform 12.0 Enhancement Advisory 2018-02-16 01:43:25 UTC

Comment 2 Bob Fournier 2017-09-19 18:24:47 UTC
*** Bug 1464523 has been marked as a duplicate of this bug. ***

Comment 5 Bob Fournier 2017-11-16 21:57:07 UTC
Mike - this should be the same UEFI test as was done for this bug fix in OSP-10.

Comment 6 mlammon 2017-11-27 20:57:42 UTC
This was tested manually with BM env (Dell PowerEdge P320 BM servers) with OSP12
This can now be moved to Verified.

Comment 11 errata-xmlrpc 2017-12-13 22:05:43 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHEA-2017:3462


Note You need to log in before you can comment on or make changes to this bug.