Bugzilla (bugzilla.redhat.com) will be under maintenance for infrastructure upgrades and will not be unavailable on July 31st between 12:30 AM - 05:30 AM UTC. We appreciate your understanding and patience. You can follow status.redhat.com for details.
Bug 1489345 - If user tries to reinstall any node once the primary gluster node is replaced contents of /etc/ovirt-hosted-engine/hosted-engine.conf are overwritten
Summary: If user tries to reinstall any node once the primary gluster node is replaced...
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Gluster Storage
Classification: Red Hat
Component: rhhi
Version: rhhi-1.1
Hardware: Unspecified
OS: Unspecified
medium
medium
Target Milestone: ---
: RHHI 1.1
Assignee: Sahina Bose
QA Contact: SATHEESARAN
URL:
Whiteboard:
Depends On: 1439069
Blocks: RHHI-1.1-Approved-Backlog-BZs
TreeView+ depends on / blocked
 
Reported: 2017-09-07 09:05 UTC by Sahina Bose
Modified: 2018-01-03 10:54 UTC (History)
7 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of: 1439069
Environment:
Last Closed: 2018-01-03 10:54:04 UTC
Target Upstream Version:


Attachments (Terms of Use)

Description Sahina Bose 2017-09-07 09:05:41 UTC
+++ This bug was initially created as a clone of Bug #1439069 +++

Description of problem:
Once user replaces the primary gluster node and if he tries to reinstall any nodes in the cluster /etc/ovirt-hosted-engine/hosted-engine.conf contents are overwritten. I see that value for "storage" is overwritten and host fails to mount the storage and goes to nonoperational.

Version-Release number of selected component (if applicable):
Red Hat Virtualization Manager Version: 4.1.1.2-0.1.el7

How reproducible:
Always

Steps to Reproduce:
1. Replace primary gluster server in HC cluster
2. Now try reinstalling any node in the cluster
3.

Actual results:
I see that /etc/ovirt-hosted-engine/hosted-engine.conf file gets overridden. value of storage points to the old host which is removed and due to this host is not able to mount storage and goes to non operational state.

Expected results:
/etc/ovirt-hosted-engine/hosted-engine.conf file should not be overwritten when a host is re-installed.

--- Additional comment from Sahina Bose on 2017-04-05 09:13:20 EDT ---

Is there a workaround?

--- Additional comment from RamaKasturi on 2017-04-06 06:47:48 EDT ---

sahina, i moved the node to maintenance changed the contents of /etc/ovirt-hosted-engine.conf file to point to correct storage path, rebooted the node and activated it which brought the node online and mounted all the volumes back.

--- Additional comment from RamaKasturi on 2017-04-13 09:45:34 EDT ---

If user retries Hosted Engine deployment for any reason, /etc/ovirt-hosted-engine/hosted-engine.conf file will not contain the mnt_options. user can later on edit this file to set the mnt_options. But if user tries to reinstall any of the node from UI, mnt_options from the conf file will be lost.

--- Additional comment from Sahina Bose on 2017-05-30 03:27:15 EDT ---

Simone, are we adding UI enhancements to edit the conf file? Should this bug be retargeted?

--- Additional comment from Simone Tiraboschi on 2017-05-31 10:54:06 EDT ---

The engine fetches that value from the initial answerfile stored on a configuration volume on the hosted-engine storage domain. We have an helper utility ('hosted-engine --set-shared-config') to let the user edit values there but currently he can just modify notifications related values.

--- Additional comment from Yaniv Kaul on 2017-08-04 12:06:52 EDT ---

Is this on track to get into 4.1.5?

--- Additional comment from Simone Tiraboschi on 2017-08-07 05:37:58 EDT ---

(In reply to Yaniv Kaul from comment #6)
> Is this on track to get into 4.1.5?

No code changes are required here: once 1457357 got it (and we are going to have it in 4.1.5) it's just a matter of documenting how to use it.

Comment 1 RamaKasturi 2017-12-04 10:34:26 UTC
Moving the bug back to assigned due to the bug since the dependent bug 1439069 failed_qa . 

Reason for failure have been specified at https://bugzilla.redhat.com/show_bug.cgi?id=1439069#c11

Comment 2 Sahina Bose 2017-12-04 13:28:12 UTC
Back to ON_QA, as there's now an option to edit the HE storage domain options from engine

Comment 3 RamaKasturi 2017-12-04 17:04:20 UTC
Moving the bug to verified state as the dependent bug is already in verified state. 

Refer https://bugzilla.redhat.com/show_bug.cgi?id=1439069#c14


Note You need to log in before you can comment on or make changes to this bug.