Bug 1489374 - [RFE] Support deploying app with private repo image on Deploy Image page
Summary: [RFE] Support deploying app with private repo image on Deploy Image page
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: RFE
Version: 3.7.0
Hardware: Unspecified
OS: Unspecified
medium
medium
Target Milestone: ---
: 3.10.0
Assignee: Samuel Padgett
QA Contact: Yadan Pei
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-09-07 09:56 UTC by Xingxing Xia
Modified: 2018-12-20 21:41 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-12-20 21:41:03 UTC


Attachments (Terms of Use)
private_image_repo.png (17.64 KB, image/png)
2017-09-07 09:56 UTC, Xingxing Xia
no flags Details

Description Xingxing Xia 2017-09-07 09:56:14 UTC
Created attachment 1323018 [details]
private_image_repo.png

Description of problem:
On Deploy Image page, search private image, it shows message: Could not load image metadata
Web console should support deploying app with private repo image on Deploy Image page

Version-Release number of selected component (if applicable):
v3.7.0-0.125.0

How reproducible:
Always

Steps to Reproduce:
1. Login to web console, go to Deploy Image page
2. Select option "Image Name", input starxia/ruby-20-centos7 which is private repo indicated from the screenshot, press Enter 

Actual results:
2. It will show messages:
Could not load image metadata.
You may not have access to the Docker image "starxia/ruby-20-centos7"

Expected results:
2. Should implement an interface to support deploying app with private repo image on Deploy Image page

Additional info:
This RFE bug is inspired by the fact: v3.6 Deploy Image page has the "Pull Secret" section after searching a public image, e.g. openshift/hello-openshift.
But in v3.7, it does not have!
So need Dev to confirm if this is intended or a bug? If it is bug, need QE open separate bug for it?
BTW, IMO it is intended and acceptable because: now that user can search the image, the image is from public repo, then it makes no sense have "Pull Secret" because the added secret will not play effect for pulling the image

Comment 1 Xingxing Xia 2017-09-08 07:32:44 UTC
> Additional info:
> This RFE bug is inspired by the fact: v3.6 Deploy Image page has the "Pull
> Secret" section after searching a public image, e.g.
> openshift/hello-openshift.
> But in v3.7, it does not have!
> So need Dev to confirm if this is intended or a bug? If it is bug, need QE
> open separate bug for it?
Could you help confirm this? Thanks!
> BTW, IMO it is intended and acceptable because: now that user can search the
> image, the image is from public repo, then it makes no sense have "Pull
> Secret" because the added secret will not play effect for pulling the image

Comment 2 Samuel Padgett 2017-09-12 16:39:11 UTC
This already works, but you have to define a secret ahead of time.

1. Define a pull secret for your private repo, Resources -> Secrets -> Create Secret
2. Search for your image in the Deploy Image page. It should appear.

We could add a link to create a secret directly in the Deploy Image page, however. It would need to be visible before searching for a repository.

It was intended that we remove the secret selection from the page after you search because it is not useful there.

Comment 3 Steve Goodwin 2018-03-22 13:59:11 UTC
PR merged
https://github.com/openshift/origin-web-console/pull/2904

Comment 4 Xingxing Xia 2018-05-29 02:52:38 UTC
US card has finished, and it is tested the feature works well now in OCP v3.10.0-0.53.0. Moving to VERIFIED


Note You need to log in before you can comment on or make changes to this bug.