Bug 148938 - Patch to allow conditional X11 support
Patch to allow conditional X11 support
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: chkfontpath (Show other bugs)
3
All Linux
medium Severity medium
: ---
: ---
Assigned To: Mike A. Harris
Ben Levenson
: FutureFeature
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-02-16 20:40 EST by Philip Gwyn
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-03-14 23:35:43 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Philip Gwyn 2005-02-16 20:40:39 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.3)
Gecko/20040914

Description of problem:
This patch adds %define use_X to the spec file.  This define is then
used to conditionnaly turn functionnaly that needs X11 on or off.

Deactivating X11 is useful for servers.

This patch simply removes Requires: xfs, which isn't really required,
is it?

Version-Release number of selected component (if applicable):
chkfontpath-1.10.0-2

How reproducible:
Always

Steps to Reproduce:
1. Install FC3 default
2. rpm -e xorg-x11-libs

    

Actual Results:  Step 2 barfs because chkfontpath want xorg-x11-xfs,
which wants xorg-x11-libs.

Expected Results:  Being able to install a server w/o X11 installed.

Additional info:

diff -ub SPECS/chkfontpath.spec SPECS.noX/chkfontpath.spec
--- SPECS/chkfontpath.spec  2004-06-15 13:27:43.000000000 -0400
+++ SPECS.noX/chkfontpath.spec  2005-02-16 19:31:23.581167647 -0500
@@ -1,7 +1,15 @@
 Summary: Simple interface for editing the font path for the X font
server.
 Name: chkfontpath
+
+# set to 0 to disable X11 bits
+%define use_X 0
+
 Version: 1.10.0
+%if %{use_X}
 Release: 2
+%else
+Release: 2.noX
+%endif
 License: GPL
 Group: System Environment/Base
 BuildRoot: %{_tmppath}/%{name}-%{version}-root
@@ -12,7 +20,9 @@
 # implementation.  Instead, use a virtual Requires, or depend on a
file or
 # directory which will be present in one of the X11 implementation's file
 # lists, thus avoiding the problem.  See bugzilla #118469 for details.
+%if %{use_X} 
 Requires: xfs
+%endif
 Requires: /sbin/pidof
 
 %description
Comment 1 Mike A. Harris 2005-03-14 23:35:43 EST
chkfontpath's entire purpose is to add/remove font paths to/from
the xfs config file.  The xfs config file is owned by the xfs
package.  If xfs is not installed, the config file is also not
installed, and chkfontpath can not function properly.

Forcibly ignoring this dependancy in the rpm spec file does not
stop chkfontpath from requiring xfs's config file be present.

All of the font packages in the OS, have a dependancy on
chkfontpath, to ensure that any fonts that get installed, are
properly configured for X11 core fonts.

Setting status to "NOTABUG" as the current dependancies are
correct and required for proper system operation when using "xfs"
which is our default and supported configuration.

Note You need to log in before you can comment on or make changes to this bug.