Bug 1489403 - After upgrade package install page remains in loading state and getting execption w/ error: NoMethodError: undefined method `order' for #<Array:0x007fbf964b8748>
Summary: After upgrade package install page remains in loading state and getting execp...
Status: CLOSED DUPLICATE of bug 1419139
Alias: None
Product: Red Hat Satellite 6
Classification: Red Hat
Component: Hosts - Content
Version: 6.2.12
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified vote
Target Milestone: Unspecified
Assignee: satellite6-bugs
QA Contact: Katello QA List
URL:
Whiteboard:
Keywords: Regression, Triaged
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-09-07 11:40 UTC by Sachin Ghai
Modified: 2017-09-25 11:25 UTC (History)
3 users (show)

(edit)
Clone Of:
(edit)
Last Closed: 2017-09-25 11:25:19 UTC


Attachments (Terms of Use)
loading package install page from UI (123.27 KB, image/png)
2017-09-07 11:40 UTC, Sachin Ghai
no flags Details
complete exception from production.log (18.44 KB, text/plain)
2017-09-07 11:41 UTC, Sachin Ghai
no flags Details

Description Sachin Ghai 2017-09-07 11:40:19 UTC
Created attachment 1323063 [details]
loading package install page from UI

Description of problem:
Upgraded satellite 6.2.11 -> 6.2.12 and I see following error while installing packages on content hosts:


2017-09-07 07:28:25 60e323d5 [app] [I] Started GET "/api/v2/hosts/48/packages?page=1&search=" for 10.65.223.131 at 2017-09-07 07:28:25 -0400
2017-09-07 07:28:25 60e323d5 [app] [I] Processing by Katello::Api::V2::HostPackagesController#index as JSON
2017-09-07 07:28:25 60e323d5 [app] [I]   Parameters: {"page"=>"1", "search"=>"", "api_version"=>"v2", "host_id"=>"48"}
2017-09-07 07:28:25 60e323d5 [app] [E] NoMethodError: undefined method `order' for #<Array:0x007fbf964b8748>
 | /opt/theforeman/tfm/root/usr/share/gems/gems/katello-3.0.0.152/app/controllers/katello/api/v2/api_controller.rb:76:in `scoped_search'
 | /opt/theforeman/tfm/root/usr/share/gems/gems/katello-3.0.0.152/app/controllers/katello/api/v2/host_packages_controller.rb:23:in `index'
 | /opt/rh/rh-ror41/root/usr/share/gems/gems/actionpack-4.1.5/lib/action_controller/metal/implicit_render.rb:4:in `send_action'
 | /opt/rh/rh-ror41/root/usr/share/gems/gems/actionpack-4.1.5/lib/abstract_controller/base.rb:189:in `process_action'
 | /opt/rh/rh-ror41/root/usr/share/gems/gems/actionpack-4.1.5/lib/action_controller/metal/rendering.rb:10:in `process_action'
 | /opt/rh/rh-ror41/root/usr/share/gems/gems/actionpack-4.1.5/lib/abstract_controller/callbacks.rb:20:in `block in process_action'
 | /opt/rh/rh-ror41/root/usr/share/gems/gems/activesupport-4.1.5/lib/active_support/callbacks.rb:113:in `call'
 | /opt/rh/rh-ror41/root/usr/share/gems/gems/activesupport-4.1.5/lib/active_support/callbacks.rb:113:in `call'
 | /opt/rh/rh-ror41/root/usr/share/gems/gems/activesupport-4.1.5/lib/active_support/callbacks.rb:149:in `block in halting_and_conditional'
 | /opt/rh/rh-ror41/root/usr/share/gems/gems/activesupport-4.1.5/lib/active_support/callbacks.rb:149:in `call'
 | /opt/rh/rh-ror41/root/usr/share/gems/gems/activesupport-4.1.5/lib/active_support/callbacks.rb:149:in `block in halting_and_conditional'
 | /opt/rh/rh-ror41/root/usr/share/gems/gems/activesupport-4.1.5/lib/active_support/callbacks.rb:149:in `call'
 | /opt/rh/rh-ror41/root/usr/share/gems/gems/activesupport-4.1.5/lib/active_support/callbacks.rb:149:in `block in halting_and_conditional'
 | /opt/rh/rh-ror41/root/usr/share/gems/gems/activesupport-4.1.5/lib/active_support/callbacks.rb:149:in `call'
 | /opt/rh/rh-ror41/root/usr/share/gems/gems/activesupport-4.1.5/lib/active_support/callbacks.rb:149:in `block in halting_and_conditional'
 | /opt/rh/rh-ror41/root/usr/share/gems/gems/activesupport-4.1.5/lib/active_support/callbacks.rb:166:in `call'
 | /opt/rh/rh-ror41/root/usr/share/gems/gems/activesupport-4.1.5/lib/active_support/callbacks.rb:166:in `block in halting'


Version-Release number of selected component (if applicable):
upgrade 6.2.11 -> 6.2.12

How reproducible:


Steps to Reproduce:
1. upgrade satellite
2. try to install package on content-host registered before upgrade
3.

Actual results:
package install page remains in loading state and see following error in production.log:

2017-09-07 07:28:25 60e323d5 [app] [E] NoMethodError: undefined method `order' for #<Array:0x007fbf964b8748>
 


Expected results:
no error should raise and user should be install packages.

Additional info:

Comment 1 Sachin Ghai 2017-09-07 11:41 UTC
Created attachment 1323064 [details]
complete exception from production.log

Comment 3 Sachin Ghai 2017-09-07 12:51:38 UTC
I think its side effect of changes appears w/ bz1419139. I'll keep this open until next snap and will re-check if its fixed w/ new snap.

Comment 4 Brad Buckingham 2017-09-12 14:53:30 UTC
Hi Sachin,  adding a needinfo to ensure we cover comment 3.  The fix for bug 1419139 is in the latest snap, so let us know if the issue persists or if we may close this one out.  Thanks!

Comment 6 Sachin Ghai 2017-09-25 11:24:42 UTC
Yeah, issue has been fixed. closing this out.

Comment 7 Sachin Ghai 2017-09-25 11:25:19 UTC

*** This bug has been marked as a duplicate of bug 1419139 ***


Note You need to log in before you can comment on or make changes to this bug.