Bug 148941 - Patch that conditionnaly deactivates X11 support
Patch that conditionnaly deactivates X11 support
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: redhat-lsb (Show other bugs)
3
All Linux
medium Severity medium
: ---
: ---
Assigned To: Leon Ho
: FutureFeature
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-02-16 20:56 EST by Philip Gwyn
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-03-20 23:46:26 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
patch to spec file (907 bytes, patch)
2005-02-16 20:57 EST, Philip Gwyn
no flags Details | Diff

  None (edit)
Description Philip Gwyn 2005-02-16 20:56:39 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.3)
Gecko/20040914

Description of problem:
This patch adds %define use_X to the spec file.  This define is then
used to conditionnaly turn functionnaly that needs X11 on or off.

Deactivating X11 is useful for servers.

redhat-lsb Requires a bunch of X11 libraries that server will never need.

Version-Release number of selected component (if applicable):
redhat-lsb-1.3-4

How reproducible:
Always

Steps to Reproduce:
1. Install default fc3
2. rpm -e xorg-x11-libs

    

Actual Results:  Step 2 will fail because redhat-lsb Requires
librairies that are in xorg-x11-libs.

Expected Results:  Be able to install a server w/o X11 libs.

Additional info:
Comment 1 Philip Gwyn 2005-02-16 20:57:09 EST
Created attachment 111148 [details]
patch to spec file
Comment 2 Leon Ho 2005-02-22 20:34:11 EST
LSB 2.0 test suites need X. Any reason why you are installed redhat-lsb?
Comment 3 Philip Gwyn 2005-03-03 15:53:09 EST
FC3 installs it by default.  Aren't /lib/lsb/init-functions and the
scripts in /etc/redhat-lsb necessary?
Comment 4 Leon Ho 2005-03-04 02:14:32 EST
Do you mean on FC3 default installation path, or in full-installation?
If it is in full-installation, user will pull down X packages anyway.
If it is on default installation path, it is definitely a bug. 

redhat-lsb should just pull in if users install every packages on the
distro.
Comment 5 Leon Ho 2005-03-20 23:46:26 EST
Thanks for the report. Closing out based of the rationale.

Note You need to log in before you can comment on or make changes to this bug.