Bug 1489411 - Context menu should appear by pointer when invoked via mouse
Summary: Context menu should appear by pointer when invoked via mouse
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: DevTools
Classification: Red Hat
Component: rh-eclipse47
Version: rh-eclipse47
Hardware: x86_64
OS: Linux
unspecified
high
Target Milestone: rc
: 2018.2
Assignee: Mat Booth
QA Contact: Václav Kadlčík
Robert Krátký
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-09-07 12:04 UTC by ptoshniw
Modified: 2021-06-10 12:58 UTC (History)
12 users (show)

Fixed In Version: rh-eclipse47-eclipse-4.7.3a-3.4.el7
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-04-23 15:41:25 UTC
Target Upstream Version:


Attachments (Terms of Use)
screenshot-2 (87.30 KB, image/png)
2018-04-10 10:49 UTC, Martin Coufal
no flags Details
taken in 4.7.3a-3.4.el7 (110.61 KB, image/jpeg)
2018-04-13 02:41 UTC, Václav Kadlčík
no flags Details


Links
System ID Private Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2018:1198 0 None None None 2018-04-23 15:41:58 UTC

Description ptoshniw 2017-09-07 12:04:05 UTC
Description of problem:
Context menu in Eclipse does not appear at mouse pointer when opened with mouse click.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:

1. open Git repo view in Java perspective (bottom left corner)
2. expand one repository node
3. right click this repository node (popup appears at right position)
4. right click the "Branches" node (popup appears way too high)

Actual results:
The context menu is appearing way high but not near to the branches.

Expected results:
It should appear at the mouse pointer

Additional info:
https://bugs.eclipse.org/bugs/show_bug.cgi?id=431423

Comment 2 Andrey Loskutov 2017-10-16 14:00:31 UTC
Please check if https://bugs.eclipse.org/bugs/show_bug.cgi?id=526083 is related - it provides an example and gives a hint to the possible root cause.

Comment 8 Andrey Loskutov 2018-02-15 12:10:34 UTC
Can anyone from CC comment on the target release for this issue?

Comment 9 Andrey Loskutov 2018-02-15 12:21:56 UTC
The bug is still reproducible with 4.7.2, 4.8.0 M5 / RHEL 7.2 (gtk3-3.14.13-16.el7.x86_64), 7.4 (gtk3-3.22.10-4.el7.x86_64).

Comment 10 Eric Williams 2018-02-15 15:56:22 UTC
(In reply to Andrey Loskutov from comment #8)
> Can anyone from CC comment on the target release for this issue?

We plan to target the Photon release.

Comment 16 Martin Coufal 2018-04-10 10:45:44 UTC
Still present in: rh-eclipse47-eclipse-4.7.3a-3.2

See screenshot-2 for details.

Comment 17 Martin Coufal 2018-04-10 10:48:24 UTC
Still present in: rh-eclipse47-eclipse-4.7.3a-3.2 (gtk3-3.22.26-3)

See screenshot-2 for details.

Comment 18 Martin Coufal 2018-04-10 10:49:37 UTC
Created attachment 1419836 [details]
screenshot-2

Comment 28 Václav Kadlčík 2018-04-13 02:41:07 UTC
Created attachment 1421155 [details]
taken in 4.7.3a-3.4.el7

Comment 33 errata-xmlrpc 2018-04-23 15:41:25 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2018:1198


Note You need to log in before you can comment on or make changes to this bug.