Bug 148946 - 'fdisk -l <device>' should show all partitions on device
'fdisk -l <device>' should show all partitions on device
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: util-linux (Show other bugs)
3
All Linux
medium Severity medium
: ---
: ---
Assigned To: Karel Zak
Ben Levenson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-02-17 00:42 EST by Felix Miata
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-10-06 05:30:50 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
SuSE 9.3 'fdisk -l' output (5.57 KB, text/plain)
2005-10-06 12:10 EDT, Felix Miata
no flags Details

  None (edit)
Description Felix Miata 2005-02-17 00:42:49 EST
To reproduce:
1-install some ATA or USB disk with more than 16 partitions
2-run 'fdisk -l <device>' (e.g. 'fdisk -l /dev/hda' or 'fdisk -l
/dev/sda')

Actual results:
1-partitions above 16 are not listed

Expected results:
1-All partitions are listed

Additional information:
SuSE gets it right: http://qa.mandrakesoft.com/attachment.cgi?id=2507
Fedora Core 3 is like Mandrake:
http://qa.mandrakesoft.com/attachment.cgi?id=2508
Comment 1 Felix Miata 2005-09-29 18:05:45 EDT
SuSE link superceded to http://qa.mandriva.com/attachment.cgi?id=2507 and
Mandriva link http://qa.mandriva.com/attachment.cgi?id=2508
Comment 2 Karel Zak 2005-10-06 05:30:50 EDT
That's wilful limitation of Red Hat fdisk. 

All types of disks (SCSI, ACSI, Parallel port IDE, ...) support usually 15
partitions only -- with exception for classic IDE where kernel supports 63
partitions. 

The actual design of fdisk doesn't implement any good way how support diffrent
number of partitions for diffrent types of block devices. It's reason why we
prefer usual limit (15 part.) rather than problems with non IDE disks.

It's very unusual that someone needs more than 15 partitions. You can use LVM
and create logical volumes rather than physical partitions.
Comment 3 Karel Zak 2005-10-06 05:34:58 EDT
Note: you can try use the parted(8) util.
Comment 4 Felix Miata 2005-10-06 07:58:13 EDT
A 'wilful limitation" makes it most certainly a bug, since SuSE fdisk does not
have this limitation, proving the limit is both arbitrary and unnecessary.

Neither windoze XP disk management nor OS/2 fdisk/lvm have this artificial
limitation, creating a cross-platform incompatibility problem for multibooters
expecting the traditional linux partitioning tool installed by default on all
linux systems to be compatible. If it cannot be compatible, it should be removed
from standard installation, and sfdisk or some other fully compatible tool
recommended/supplied as the default replacement.

http://www.kernel.org/pub/linux/docs/device-list/devices.txt explicitly shows
/dev/hda63 to be a valid devicename.

I usually only use 'fdisk -l' to quickly refresh my mind which partitions are
which before taking some action with one that could be disastrous if taken upon
the wrong one. When I ask for a list, I need a list of all partitions, not some
arbitrary number. parted has no counterpart to 'fdisk -l' that I can determine.

Most ATA HDs I own and regularly use have more than 15 partitions, commonly
considerably more. I do my backups partition to partition, typically keeping
more than one per devicename on some disk mounted in a USB 2.0 enclosure, but
also on permanently installed disks.

Compare http://qa.mandriva.com/show_bug.cgi?id=14696 and 
http://qa.mandriva.com/show_bug.cgi?id=13715

There is no reason here expressed to leave this unfixed.
Comment 5 Karel Zak 2005-10-06 08:55:14 EDT
What happen if you try create 63 partitions (by fdisk) on SCSI disk on SuSE? Is
it correct that fdisk offers to users create 63 partitions on device that
supports only 15 partitions?

To be honest, FC5 is probably last distribution with fdisk -- in future there
will be parted(8) only.
Comment 6 Felix Miata 2005-10-06 12:10:22 EDT
Created attachment 119675 [details]
SuSE 9.3 'fdisk -l' output

I have no idea how many SCSI partitions SuSE fdisk can create, only that it
shows all table entries when started with the -l switch:

     1st item /dev/sda is real SCSI on sym53c8xx (last=sda9)
     2nd item is PATA /dev/hda (last=hda26)
     3rd item is PATA disk attached via USB 2.0 /dev/sdb (last=sdb39)

I don't routinely create partitions with fdisk. I usually use the multiplatform
compatible tool DFSee, which runs natively under DOS, doze, OS/2 & Linux, and
is capable of managing in excess of 999 partitions per system and more than 63
partitions per disk.

Pretending SATA is SCSI is a serious artificial limitation when it comes to
partitioning. Back in days when disk size was measured in MB, large numbers of
partitions didn't make sense largely because of the overall physical limitation
on size imposed by small disks. That physical limitation is long gone with
currently common disk sizes approaching a terrabyte, but the logistical
management of data on very large partitions has replaced it, making larger
numbers of partitions per physical device more relevant, useful, and
attractive, particularly in backup strategies.

Note You need to log in before you can comment on or make changes to this bug.