Bug 1489460 - gdm leaking some info on locked screen
Summary: gdm leaking some info on locked screen
Keywords:
Status: CLOSED WONTFIX
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: gnome-shell
Version: 7.5
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: rc
: ---
Assignee: Florian Müllner
QA Contact: Desktop QE
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-09-07 13:42 UTC by Tomas Pelka
Modified: 2021-01-15 07:41 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2021-01-15 07:41:52 UTC
Target Upstream Version:


Attachments (Terms of Use)
screenshot (1.56 MB, image/jpeg)
2017-09-07 13:42 UTC, Tomas Pelka
no flags Details

Description Tomas Pelka 2017-09-07 13:42:31 UTC
Created attachment 1323123 [details]
screenshot

Description of problem:
Gdm leaking topicons and bottom panel on locked screen.

Version-Release number of selected component (if applicable):
gdm-3.22.3-12.el7.x86_64
gnome-shell-3.22.3-17.el7.x86_64
gnome-classic-session-3.22.2-10.el7.noarch
topicons plus from https://extensions.gnome.org/extension/1031/topicons/

How reproducible:
100%

Steps to Reproduce:
1.
2.
3.

Actual results:
see attached photo 

Expected results:


Additional info:

Comment 1 Ray Strode [halfline] 2017-09-07 13:49:10 UTC
does the problem happen if you get rid of topicons ?

do you have any tracebacks in your journal?

Comment 2 Tomas Pelka 2017-09-07 13:56:42 UTC
With topicons enabled I can see in journal:

Sep 07 15:54:04 placka-t470s dbus[1533]: [system] Activating via systemd: service name='net.reactivated.Fprint' unit='fprintd.service'
Sep 07 15:54:04 placka-t470s systemd[1]: Starting Fingerprint Authentication Daemon...
Sep 07 15:54:04 placka-t470s dbus-daemon[1533]: dbus[1533]: [system] Successfully activated service 'net.reactivated.Fprint'
Sep 07 15:54:04 placka-t470s dbus[1533]: [system] Successfully activated service 'net.reactivated.Fprint'
Sep 07 15:54:04 placka-t470s fprintd[15821]: Launching FprintObject
Sep 07 15:54:04 placka-t470s fprintd[15821]: D-Bus service launched with name: net.reactivated.Fprint
Sep 07 15:54:04 placka-t470s fprintd[15821]: entering main loop
Sep 07 15:54:04 placka-t470s systemd[1]: Started Fingerprint Authentication Daemon.
Sep 07 15:54:06 placka-t470s su[15820]: (to root) tpelka on pts/0
Sep 07 15:54:06 placka-t470s su[15820]: pam_unix(su:session): session opened for user root by tpelka(uid=1000)
^LSep 07 15:54:29 placka-t470s gdm-password][15881]: gkr-pam: unlocked login keyring
Sep 07 15:54:29 placka-t470s gnome-shell[19738]: JS ERROR: Exception in callback for signal: updated: Error: Type name Gjs_GPasteAboutItem is already registered
                                                 GObjectMeta<._construct@resource:///org/gnome/gjs/modules/overrides/GObject.js:145
                                                 wrapper@resource:///org/gnome/gjs/modules/lang.js:178
                                                 Class.prototype._construct/newClass@resource:///org/gnome/gjs/modules/lang.js:213
                                                 Class@resource:///org/gnome/gjs/modules/lang.js:161
                                                 @/usr/share/gnome-shell/extensions/GPaste@gnome-shell-extensions.gnome.org/aboutItem.js:29
                                                 @/usr/share/gnome-shell/extensions/GPaste@gnome-shell-extensions.gnome.org/indicator.js:36
                                                 @/usr/share/gnome-shell/extensions/GPaste@gnome-shell-extensions.gnome.org/extension.js:28
                                                 initExtension@resource:///org/gnome/shell/ui/extensionSystem.js:221
                                                 enableExtension@resource:///org/gnome/shell/ui/extensionSystem.js:110
                                                 enableAllExtensions/<@resource:///org/gnome/shell/ui/extensionSystem.js:345
                                                 enableAllExtensions@resource:///org/gnome/shell/ui/extensionSystem.js:344
                                                 _sessionUpdated@resource:///org/gnome/shell/ui/extensionSystem.js:372
                                                 _emit@resource:///org/gnome/gjs/modules/signals.js:124
                                                 SessionMode<._sync@resource:///org/gnome/shell/ui/sessionMode.js:205
                                                 wrapper@resource:///org/gnome/gjs/modules/lang.js:178
                                                 SessionMode<.popMode@resource:///org/gnome/shell/ui/sessionMode.js:174
                                                 wrapper@resource:///org/gnome/gjs/modules/lang.js:178
                                                 ScreenShield<._continueDeactivate@resource:///org/gnome/shell/ui/screenShield.js:1210
                                                 wrapper@resource:///org/gnome/gjs/modules/lang.js:178
                                                 ScreenShield<.deactivate/<@resource:///org/gnome/shell/ui/screenShield.js:1195
                                                 AuthPrompt<.finish@resource:///org/gnome/shell/gdm/authPrompt.js:585
                                                 wrapper@resource:///org/gnome/gjs/modules/lang.js:178
                                                 UnlockDialog<.finish@resource:///org/gnome/shell/ui/unlockDialog.js:147
                                                 wrapper@resource:///org/gnome/gjs/modules/lang.js:178
                                                 ScreenShield<.deactivate@resource:///org/gnome/shell/ui/screenShield.js:1194
                                                 wrapper@resource:///org/gnome/gjs/modules/lang.js:178
                                                 ScreenShield<._init/</<@resource:///org/gnome/shell/ui/screenShield.js:541
                                                 _emit@resource:///org/gnome/gjs/modules/signals.js:124
                                                 _convertToNativeSignal@resource:///org/gnome/gjs/modules/overrides/Gio.js:129
Sep 07 15:54:35 placka-t470s fprintd[15821]: No devices in use, exit

Comment 3 Tomas Pelka 2017-09-07 14:01:05 UTC
Ok it seems it is caused by topicons plus, works wine without mentioned extension installed.

So feel free to close as topicons plus is not officially supported by RH.

Comment 5 RHEL Program Management 2021-01-15 07:41:52 UTC
After evaluating this issue, there are no plans to address it further or fix it in an upcoming release.  Therefore, it is being closed.  If plans change such that this issue will be fixed in an upcoming release, then the bug can be reopened.


Note You need to log in before you can comment on or make changes to this bug.