Bug 1489515 - API hosts/X/facts inconsistent and superfluous hostname hash in results response
Summary: API hosts/X/facts inconsistent and superfluous hostname hash in results response
Keywords:
Status: CLOSED WONTFIX
Alias: None
Product: Red Hat Satellite
Classification: Red Hat
Component: Fact
Version: 6.2.11
Hardware: Unspecified
OS: Unspecified
unspecified
medium
Target Milestone: Unspecified
Assignee: Shira Maximov
QA Contact: Katello QA List
URL:
Whiteboard:
Depends On:
Blocks: 1122832
TreeView+ depends on / blocked
 
Reported: 2017-09-07 15:16 UTC by Peter Vreman
Modified: 2019-08-12 14:08 UTC (History)
6 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-11-02 11:41:40 UTC
Target Upstream Version:
Embargoed:


Attachments (Terms of Use)

Description Peter Vreman 2017-09-07 15:16:30 UTC
Description of problem:
When querying the facts of a host the returned results are encapsulated in an additional hash of the hostname. This is inconsistent with all other API responses on a per host level, e.g. the interfaces

[crash/LI] root@li-lc-1578:~# curl -K /opt/hoici/etc/sat6/curl-hoici.conf "-HContent-Type: application/json" "-d{\"per_page\":9999999}" -XGET https://localhost:443/api/v2/hosts/23/facts
{
  "total": 217,
  "subtotal": 1,
  "page": 1,
  "per_page": 9999999,
  "search": " host = 23",
  "sort": {
    "by": null,
    "order": null
  },
  "results": {"li-lc-1441.hag.hilti.com":{"hardwaremodel":"x86_64","architecture":"x86_64",...."rubyplatform":"x86_64-linux","package_provider":"yum"}}
}
[crash/LI] root@li-lc-1578:~# curl -K /opt/hoici/etc/sat6/curl-hoici.conf "-HContent-Type: application/json" "-d{\"per_page\":9999999}" -XGET https://localhost:443/api/v2/hosts/23/interfaces
{
  "total": 3,
  "subtotal": 3,
  "page": 1,
  "per_page": 9999999,
  "search": null,
  "sort": {
    "by": null,
    "order": null
  },
  "results": [{"subnet_id":null,"subnet_name":null,"domain_id":1,...virtual":false}]
}


Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1. Query hosts/X/facts
2. Query hosts/X/interfaces
3.

Actual results:
Inconsistent return of results, the facst are inside results{"hostname":{}}
The interfaces are in the expected results:[]

Expected results:
Facts per hosts are directly underneath results returned like all other API calls.


Additional info:

Comment 1 Daniel Lobato Garcia 2017-09-11 15:31:26 UTC
Created redmine issue http://projects.theforeman.org/issues/20891 from this bug

Comment 3 Satellite Program 2018-01-11 17:09:29 UTC
Upstream bug assigned to mshira

Comment 4 Satellite Program 2018-01-11 17:09:39 UTC
Upstream bug assigned to mshira

Comment 5 Satellite Program 2018-06-14 18:08:27 UTC
Moving this bug to POST for triage into Satellite 6 since the upstream issue http://projects.theforeman.org/issues/20891 has been resolved.

Comment 7 Patrick Creech 2018-10-31 15:32:08 UTC
Kicking this back to new, as the commit appears to have been reverted

Comment 9 Satellite Program 2018-10-31 16:06:46 UTC
Moving this bug to POST for triage into Satellite 6 since the upstream issue https://projects.theforeman.org/issues/20891 has been resolved.

Comment 11 Bryan Kearney 2018-11-01 14:45:03 UTC
The Satellite Team is attempting to provide an accurate backlog of bugzilla requests which we feel will be resolved in the next few releases. We do not believe this bugzilla will meet that criteria, and have plans to close it out in 1 month. This is  not a reflection on the validity of the request, but a reflection of the many priorities for the product. If you have any concerns about this, feel free to contact Rich Jerrido or Bryan Kearney or your account team. If we do not hear from you, we will close this bug out. Thank you.

Comment 12 Peter Vreman 2018-11-02 10:36:08 UTC
Thanks for trying ot make it work at least.
I can understand the backwards compatibility issue.

BZ can be closed.

Comment 13 Tomer Brisker 2018-11-02 11:41:40 UTC
Closing per comment #12, thanks for the understanding Peter!

Comment 14 Bryan Kearney 2018-11-30 14:51:12 UTC
Thank you for your interest in Satellite 6. We have evaluated this request, and while we recognize that it is a valid request, we do not expect this to be implemented in the product in the foreseeable future. This is due to other priorities for the product, and not a reflection on the request itself. We are therefore closing this out as WONTFIX. If you have any concerns about this, please do not reopen. Instead, feel free to contact Rich Jerrido or Bryan Kearney. Thank you.


Note You need to log in before you can comment on or make changes to this bug.