Bug 148952 - up2date incorrectly identifies "Extras" packages (RealPlayer and ksh) as updates of standard packages (HelixPlayer and pdksh)
up2date incorrectly identifies "Extras" packages (RealPlayer and ksh) as upda...
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: up2date (Show other bugs)
4.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Jason Connor
Beth Nackashi
:
Depends On:
Blocks: 155573 156323
  Show dependency treegraph
 
Reported: 2005-02-17 02:48 EST by Chris Melaro
Modified: 2014-03-30 21:37 EDT (History)
11 users (show)

See Also:
Fixed In Version: RHBA-2005-711
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-10-05 13:13:30 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
patch for up2date in batch mode (459 bytes, patch)
2005-05-04 10:58 EDT, Jack Neely
no flags Details | Diff
Patch to fix obsoletes in the GUI (637 bytes, patch)
2005-05-04 13:29 EDT, Jack Neely
no flags Details | Diff
patch for depSolver.py (3.41 KB, patch)
2005-07-07 14:55 EDT, Jason Connor
no flags Details | Diff

  None (edit)
Description Chris Melaro 2005-02-17 02:48:29 EST
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.1; SV1; .NET CLR 1.1.4322)

Description of problem:
up2date incorrectly identifies "Extras" packages (RealPlayer and ksh) as updates of standard packages (HelixPlayer and pdksh)

up2date should consider these different packages and not updates


Version-Release number of selected component (if applicable):
up2date-4.4.5-1

How reproducible:
Always

Steps to Reproduce:
1.RHEL4 system w/ HelixPlayer-1.0.1.gold-8EL and pdksh-5.2.14-20 installed
2.run up2date
3.
  

Actual Results:  HelixPlayer and pdksh RPMs were removed from system.
RealPlayer and ksh RPMs were installed.

Expected Results:  up2date should not have considered these updates as they are different packages and should have performed no action

Additional info:
Comment 1 Adrian Likins 2005-02-17 12:32:47 EST
The ksh and RealPlayer obsolete pdksh and HelixPlayer, respectively. So
up2date is doing the right thing. 

If those packages should be obsoleting stuff is another question,
and thats up to debate. Reassigning this bug to ksh, since
I can't reassign to both packages.
Comment 2 Jack Neely 2005-03-21 15:25:09 EST
I'm seeing something very similar here, but up2date tries to install the two
conflicting packages anyway.  This results in a traceback and completely breaks
the ability to receive updates.  We are testing RHEL 4 for deployment later this
year and this is definately a show stopper.

[root@lnx00test nscd]# /usr/sbin/up2date -u --dry-run
 
Fetching Obsoletes list for channel: rhel-i386-ws-4...
########################################
 
Fetching Obsoletes list for channel: rhel-i386-ws-4-extras...
 
Fetching Obsoletes list for channel: realmlinux-ws4...
########################################
 
Fetching Obsoletes list for channel: Physics_WS3...
 
Fetching Obsoletes list for channel: CLS_Subversion...
 
Fetching rpm headers...
########################################
 
Name                                    Version        Rel
----------------------------------------------------------
HelixPlayer                             1.0.3          1                 i386
ImageMagick                             6.0.7.1        6                 i386
RealPlayer                              10.0.3         1                 i386
alsa-lib                                1.0.6          5.RHEL4           i386
cpio                                    2.5            7.EL4.1           i386
cups                                    1.1.22         0.rc1.9.6         i386
cups-libs                               1.1.22         0.rc1.9.6         i386
emacs                                   21.3           19.EL.1           i386
emacs-common                            21.3           19.EL.1           i386
emacs-leim                              21.3           19.EL.1           i386
enscript                                1.6.1          28.3              i386
firefox                                 1.0.1          1.4.3             i386
firstboot                               1.3.30         1.ncsu.1          noarch
gaim                                    1.1.4          1.EL4             i386
gpdf                                    2.8.2          4.3               i386
htdig                                   3.2.0b6        3.40.1            i386
kdegraphics                             3.3.1          3.3               i386
kdelibs                                 3.3.1          3.3               i386
krb5-devel                              1.3.4          10                i386
krb5-libs                               1.3.4          10                i386
krb5-workstation                        1.3.4          10                i386
ksh                                     20040229       12                i386
libexif                                 0.5.12         5.1               i386
libtiff                                 3.6.1          8                 i386
mozilla-nspr                            1.7.3          19.EL4            i386
mozilla-nss                             1.7.3          19.EL4            i386
perl                                    5.8.5          12.1              i386
python                                  2.3.4          14.1              i386
python-devel                            2.3.4          14.1              i386
realmconfig                             4.2.2          1.use.rhnproxy    noarch
rhn-org-trusted-ssl-cert                1.0            4.use.rhnproxy    noarch
tetex                                   2.0.2          22.EL4.4          i386
tetex-afm                               2.0.2          22.EL4.4          i386
tetex-dvips                             2.0.2          22.EL4.4          i386
tetex-fonts                             2.0.2          22.EL4.4          i386
tetex-latex                             2.0.2          22.EL4.4          i386
tetex-xdvi                              2.0.2          22.EL4.4          i386
vim-common                              6.3.046        0.40E.4           i386
vim-enhanced                            6.3.046        0.40E.4           i386
vim-minimal                             6.3.046        0.40E.4           i386
xpdf                                    3.00           11.5              i386
xpdf                                    3.00           11.5              i386
 
 
Testing package set / solving RPM inter-dependencies...
########################################
 
Name                                    Version        Rel
----------------------------------------------------------
HelixPlayer                             1.0.3          1                 i386
ImageMagick                             6.0.7.1        6                 i386
RealPlayer                              10.0.3         1                 i386
alsa-lib                                1.0.6          5.RHEL4           i386
cpio                                    2.5            7.EL4.1           i386
cups                                    1.1.22         0.rc1.9.6         i386
cups-libs                               1.1.22         0.rc1.9.6         i386
emacs                                   21.3           19.EL.1           i386
emacs-common                            21.3           19.EL.1           i386
emacs-leim                              21.3           19.EL.1           i386
enscript                                1.6.1          28.3              i386
firefox                                 1.0.1          1.4.3             i386
firstboot                               1.3.30         1.ncsu.1          noarch
gaim                                    1.1.4          1.EL4             i386
gpdf                                    2.8.2          4.3               i386
htdig                                   3.2.0b6        3.40.1            i386
kdegraphics                             3.3.1          3.3               i386
kdelibs                                 3.3.1          3.3               i386
krb5-devel                              1.3.4          10                i386
krb5-libs                               1.3.4          10                i386
krb5-workstation                        1.3.4          10                i386
ksh                                     20040229       12                i386
libexif                                 0.5.12         5.1               i386
libtiff                                 3.6.1          8                 i386
mozilla-nspr                            1.7.3          19.EL4            i386
mozilla-nss                             1.7.3          19.EL4            i386
perl                                    5.8.5          12.1              i386
python                                  2.3.4          14.1              i386
python-devel                            2.3.4          14.1              i386
realmconfig                             4.2.2          1.use.rhnproxy    noarch
rhn-org-trusted-ssl-cert                1.0            4.use.rhnproxy    noarch
tetex                                   2.0.2          22.EL4.4          i386
tetex-afm                               2.0.2          22.EL4.4          i386
tetex-dvips                             2.0.2          22.EL4.4          i386
tetex-fonts                             2.0.2          22.EL4.4          i386
tetex-latex                             2.0.2          22.EL4.4          i386
tetex-xdvi                              2.0.2          22.EL4.4          i386
vim-common                              6.3.046        0.40E.4           i386
vim-enhanced                            6.3.046        0.40E.4           i386
vim-minimal                             6.3.046        0.40E.4           i386
xpdf                                    3.00           11.5              i386
 
The following Packages are obsoleted by newer packages:
 
Name-Version-Release        obsoleted by      Name-Version-Release
-------------------------------------------------------------------------------
HelixPlayer-1.0.1.gold-8EL              RealPlayer-10.0.3-1
pdksh-5.2.14-30                         ksh-20040229-12
[root@lnx00test nscd]# pwd
/var/db/nscd
[root@lnx00test nscd]# ls
group  hosts  passwd
[root@lnx00test nscd]# /usr/sbin/up2date -u
 
Fetching Obsoletes list for channel: rhel-i386-ws-4...
 
Fetching Obsoletes list for channel: rhel-i386-ws-4-extras...
 
Fetching Obsoletes list for channel: realmlinux-ws4...
 
Fetching Obsoletes list for channel: Physics_WS3...
 
Fetching Obsoletes list for channel: CLS_Subversion...
 
Fetching rpm headers...
########################################
 
Name                                    Version        Rel
----------------------------------------------------------
HelixPlayer                             1.0.3          1                 i386
ImageMagick                             6.0.7.1        6                 i386
RealPlayer                              10.0.3         1                 i386
alsa-lib                                1.0.6          5.RHEL4           i386
cpio                                    2.5            7.EL4.1           i386
cups                                    1.1.22         0.rc1.9.6         i386
cups-libs                               1.1.22         0.rc1.9.6         i386
emacs                                   21.3           19.EL.1           i386
emacs-common                            21.3           19.EL.1           i386
emacs-leim                              21.3           19.EL.1           i386
enscript                                1.6.1          28.3              i386
firefox                                 1.0.1          1.4.3             i386
firstboot                               1.3.30         1.ncsu.1          noarch
gaim                                    1.1.4          1.EL4             i386
gpdf                                    2.8.2          4.3               i386
htdig                                   3.2.0b6        3.40.1            i386
kdegraphics                             3.3.1          3.3               i386
kdelibs                                 3.3.1          3.3               i386
krb5-devel                              1.3.4          10                i386
krb5-libs                               1.3.4          10                i386
krb5-workstation                        1.3.4          10                i386
ksh                                     20040229       12                i386
libexif                                 0.5.12         5.1               i386
libtiff                                 3.6.1          8                 i386
mozilla-nspr                            1.7.3          19.EL4            i386
mozilla-nss                             1.7.3          19.EL4            i386
perl                                    5.8.5          12.1              i386
python                                  2.3.4          14.1              i386
python-devel                            2.3.4          14.1              i386
realmconfig                             4.2.2          1.use.rhnproxy    noarch
rhn-org-trusted-ssl-cert                1.0            4.use.rhnproxy    noarch
tetex                                   2.0.2          22.EL4.4          i386
tetex-afm                               2.0.2          22.EL4.4          i386
tetex-dvips                             2.0.2          22.EL4.4          i386
tetex-fonts                             2.0.2          22.EL4.4          i386
tetex-latex                             2.0.2          22.EL4.4          i386
tetex-xdvi                              2.0.2          22.EL4.4          i386
vim-common                              6.3.046        0.40E.4           i386
vim-enhanced                            6.3.046        0.40E.4           i386
vim-minimal                             6.3.046        0.40E.4           i386
xpdf                                    3.00           11.5              i386
 
 
Testing package set / solving RPM inter-dependencies...
########################################
HelixPlayer-1.0.3-1.i386.rp ########################## Done.
ImageMagick-6.0.7.1-6.i386. ########################## Done.
RealPlayer-10.0.3-1.i386.rp ########################## Done.
alsa-lib-1.0.6-5.RHEL4.i386 ########################## Done.
cpio-2.5-7.EL4.1.i386.rpm:  ########################## Done.
cups-1.1.22-0.rc1.9.6.i386. ########################## Done.
cups-libs-1.1.22-0.rc1.9.6. ########################## Done.
emacs-21.3-19.EL.1.i386.rpm ########################## Done.
emacs-common-21.3-19.EL.1.i ########################## Done.
emacs-leim-21.3-19.EL.1.i38 ########################## Done.
enscript-1.6.1-28.3.i386.rp ########################## Done.
firefox-1.0.1-1.4.3.i386.rp ########################## Done.
firstboot-1.3.30-1.ncsu.1.n ########################## Done.
gaim-1.1.4-1.EL4.i386.rpm:  ########################## Done.
gpdf-2.8.2-4.3.i386.rpm:    ########################## Done.
htdig-3.2.0b6-3.40.1.i386.r ########################## Done.
kdegraphics-3.3.1-3.3.i386. ########################## Done.
kdelibs-3.3.1-3.3.i386.rpm: ########################## Done.
krb5-devel-1.3.4-10.i386.rp ########################## Done.
krb5-libs-1.3.4-10.i386.rpm ########################## Done.
krb5-workstation-1.3.4-10.i ########################## Done.
ksh-20040229-12.i386.rpm:   ########################## Done.
libexif-0.5.12-5.1.i386.rpm ########################## Done.
libtiff-3.6.1-8.i386.rpm:   ########################## Done.
mozilla-nspr-1.7.3-19.EL4.i ########################## Done.
mozilla-nss-1.7.3-19.EL4.i3 ########################## Done.
perl-5.8.5-12.1.i386.rpm:   ########################## Done.
python-2.3.4-14.1.i386.rpm: ########################## Done.
python-devel-2.3.4-14.1.i38 ########################## Done.
realmconfig-4.2.2-1.use.rhn ########################## Done.
rhn-org-trusted-ssl-cert-1. ########################## Done.
tetex-2.0.2-22.EL4.4.i386.r ########################## Done.
tetex-afm-2.0.2-22.EL4.4.i3 ########################## Done.
tetex-dvips-2.0.2-22.EL4.4. ########################## Done.
tetex-fonts-2.0.2-22.EL4.4. ########################## Done.
tetex-latex-2.0.2-22.EL4.4. ########################## Done.
tetex-xdvi-2.0.2-22.EL4.4.i ########################## Done.
vim-common-6.3.046-0.40E.4. ########################## Done.
vim-enhanced-6.3.046-0.40E. ########################## Done.
vim-minimal-6.3.046-0.40E.4 ########################## Done.
xpdf-3.00-11.5.i386.rpm:    ########################## Done.
Preparing              ########################################### [100%]
Traceback (most recent call last):
  File "/usr/sbin/up2date", line 1245, in ?
    sys.exit(main() or 0)
  File "/usr/sbin/up2date", line 800, in main
    fullUpdate, dryRun=options.dry_run))
  File "/usr/sbin/up2date", line 1119, in batchRun
    batch.run()
  File "/usr/share/rhn/up2date_client/up2dateBatch.py", line 86, in run
    self.__installPackages()
  File "/usr/share/rhn/up2date_client/up2dateBatch.py", line 170, in
__installPackages
    self.kernelsToInstall = up2date.installPackages(self.packagesToInstall,
self.rpmCallback)
  File "/usr/share/rhn/up2date_client/up2date.py", line 752, in installPackages
    runTransaction(ts, added, removed,rpmCallback, rollbacktrans = rollbacktrans)
  File "/usr/share/rhn/up2date_client/up2date.py", line 632, in runTransaction
    rpmUtils.runTransaction(ts,rpmCallback, transdir)
  File "/usr/share/rhn/up2date_client/rpmUtils.py", line 511, in runTransaction
    "Failed running transaction of  packages: %s") % errors, deps=rc)
up2date_client.up2dateErrors.TransactionError: RPM  error. The message was:
Failed running transaction of  packages:
('file /usr/lib/helix/LICENSE conflicts between attempted installs of
RealPlayer-10.0.3-1 and HelixPlayer-1.0.3-1', (6, '/usr/lib/helix/LICENSE', 0L))
('file /usr/lib/helix/README conflicts between attempted installs of
RealPlayer-10.0.3-1 and HelixPlayer-1.0.3-1', (6, '/usr/lib/helix/README', 0L))
('file /usr/lib/helix/codecs/colorcvt.so conflicts between attempted installs of
RealPlayer-10.0.3-1 and HelixPlayer-1.0.3-1', (6,
'/usr/lib/helix/codecs/colorcvt.so', 0L))
('file /usr/lib/helix/codecs/cvt1.so conflicts between attempted installs of
RealPlayer-10.0.3-1 and HelixPlayer-1.0.3-1', (6,
'/usr/lib/helix/codecs/cvt1.so', 0L))
('file /usr/lib/helix/common/clntcore.so conflicts between attempted installs of
RealPlayer-10.0.3-1 and HelixPlayer-1.0.3-1', (6,
'/usr/lib/helix/common/clntcore.so', 0L))
('file /usr/lib/helix/common/clntxres.so conflicts between attempted installs of
RealPlayer-10.0.3-1 and HelixPlayer-1.0.3-1', (6,
'/usr/lib/helix/common/clntxres.so', 0L))
('file /usr/lib/helix/plugins/audplin.so conflicts between attempted installs of
RealPlayer-10.0.3-1 and HelixPlayer-1.0.3-1', (6,
'/usr/lib/helix/plugins/audplin.so', 0L))
('file /usr/lib/helix/plugins/aufformat.so conflicts between attempted installs
of RealPlayer-10.0.3-1 and HelixPlayer-1.0.3-1', (6,
'/usr/lib/helix/plugins/aufformat.so', 0L))
('file /usr/lib/helix/plugins/authmgr.so conflicts between attempted installs of
RealPlayer-10.0.3-1 and HelixPlayer-1.0.3-1', (6,
'/usr/lib/helix/plugins/authmgr.so', 0L))
('file /usr/lib/helix/plugins/clbascauth.so conflicts between attempted installs
of RealPlayer-10.0.3-1 and HelixPlayer-1.0.3-1', (6,
'/usr/lib/helix/plugins/clbascauth.so', 0L))
('file /usr/lib/helix/plugins/giffformat.so conflicts between attempted installs
of RealPlayer-10.0.3-1 and HelixPlayer-1.0.3-1', (6,
'/usr/lib/helix/plugins/giffformat.so', 0L))
('file /usr/lib/helix/plugins/gifrender.so conflicts between attempted installs
of RealPlayer-10.0.3-1 and HelixPlayer-1.0.3-1', (6,
'/usr/lib/helix/plugins/gifrender.so', 0L))
('file /usr/lib/helix/plugins/h263render.so conflicts between attempted installs
of RealPlayer-10.0.3-1 and HelixPlayer-1.0.3-1', (6,
'/usr/lib/helix/plugins/h263render.so', 0L))
('file /usr/lib/helix/plugins/httpfsys.so conflicts between attempted installs
of RealPlayer-10.0.3-1 and HelixPlayer-1.0.3-1', (6,
'/usr/lib/helix/plugins/httpfsys.so', 0L))
('file /usr/lib/helix/plugins/hxsdp.so conflicts between attempted installs of
RealPlayer-10.0.3-1 and HelixPlayer-1.0.3-1', (6,
'/usr/lib/helix/plugins/hxsdp.so', 0L))
('file /usr/lib/helix/plugins/hxxml.so conflicts between attempted installs of
RealPlayer-10.0.3-1 and HelixPlayer-1.0.3-1', (6,
'/usr/lib/helix/plugins/hxxml.so', 0L))
('file /usr/lib/helix/plugins/jpgfformat.so conflicts between attempted installs
of RealPlayer-10.0.3-1 and HelixPlayer-1.0.3-1', (6,
'/usr/lib/helix/plugins/jpgfformat.so', 0L))
('file /usr/lib/helix/plugins/jpgrender.so conflicts between attempted installs
of RealPlayer-10.0.3-1 and HelixPlayer-1.0.3-1', (6,
'/usr/lib/helix/plugins/jpgrender.so', 0L))
('file /usr/lib/helix/plugins/memfsys.so conflicts between attempted installs of
RealPlayer-10.0.3-1 and HelixPlayer-1.0.3-1', (6,
'/usr/lib/helix/plugins/memfsys.so', 0L))
('file /usr/lib/helix/plugins/oggfformat.so conflicts between attempted installs
of RealPlayer-10.0.3-1 and HelixPlayer-1.0.3-1', (6,
'/usr/lib/helix/plugins/oggfformat.so', 0L))
('file /usr/lib/helix/plugins/pcmrend.so conflicts between attempted installs of
RealPlayer-10.0.3-1 and HelixPlayer-1.0.3-1', (6,
'/usr/lib/helix/plugins/pcmrend.so', 0L))
('file /usr/lib/helix/plugins/pngfformat.so conflicts between attempted installs
of RealPlayer-10.0.3-1 and HelixPlayer-1.0.3-1', (6,
'/usr/lib/helix/plugins/pngfformat.so', 0L))
('file /usr/lib/helix/plugins/pngrender.so conflicts between attempted installs
of RealPlayer-10.0.3-1 and HelixPlayer-1.0.3-1', (6,
'/usr/lib/helix/plugins/pngrender.so', 0L))
('file /usr/lib/helix/plugins/ramfformat.so conflicts between attempted installs
of RealPlayer-10.0.3-1 and HelixPlayer-1.0.3-1', (6,
'/usr/lib/helix/plugins/ramfformat.so', 0L))
('file /usr/lib/helix/plugins/ramrender.so conflicts between attempted installs
of RealPlayer-10.0.3-1 and HelixPlayer-1.0.3-1', (6,
'/usr/lib/helix/plugins/ramrender.so', 0L))
('file /usr/lib/helix/plugins/rn5auth.so conflicts between attempted installs of
RealPlayer-10.0.3-1 and HelixPlayer-1.0.3-1', (6,
'/usr/lib/helix/plugins/rn5auth.so', 0L))
('file /usr/lib/helix/plugins/rpfformat.so conflicts between attempted installs
of RealPlayer-10.0.3-1 and HelixPlayer-1.0.3-1', (6,
'/usr/lib/helix/plugins/rpfformat.so', 0L))
('file /usr/lib/helix/plugins/rpgifplin.so conflicts between attempted installs
of RealPlayer-10.0.3-1 and HelixPlayer-1.0.3-1', (6,
'/usr/lib/helix/plugins/rpgifplin.so', 0L))
('file /usr/lib/helix/plugins/rpjpgplin.so conflicts between attempted installs
of RealPlayer-10.0.3-1 and HelixPlayer-1.0.3-1', (6,
'/usr/lib/helix/plugins/rpjpgplin.so', 0L))
('file /usr/lib/helix/plugins/rppngplin.so conflicts between attempted installs
of RealPlayer-10.0.3-1 and HelixPlayer-1.0.3-1', (6,
'/usr/lib/helix/plugins/rppngplin.so', 0L))
('file /usr/lib/helix/plugins/rprender.so conflicts between attempted installs
of RealPlayer-10.0.3-1 and HelixPlayer-1.0.3-1', (6,
'/usr/lib/helix/plugins/rprender.so', 0L))
('file /usr/lib/helix/plugins/rtfformat.so conflicts between attempted installs
of RealPlayer-10.0.3-1 and HelixPlayer-1.0.3-1', (6,
'/usr/lib/helix/plugins/rtfformat.so', 0L))
('file /usr/lib/helix/plugins/rtrender.so conflicts between attempted installs
of RealPlayer-10.0.3-1 and HelixPlayer-1.0.3-1', (6,
'/usr/lib/helix/plugins/rtrender.so', 0L))
('file /usr/lib/helix/plugins/sdpplin.so conflicts between attempted installs of
RealPlayer-10.0.3-1 and HelixPlayer-1.0.3-1', (6,
'/usr/lib/helix/plugins/sdpplin.so', 0L))
('file /usr/lib/helix/plugins/smlfformat.so conflicts between attempted installs
of RealPlayer-10.0.3-1 and HelixPlayer-1.0.3-1', (6,
'/usr/lib/helix/plugins/smlfformat.so', 0L))
('file /usr/lib/helix/plugins/smlrender.so conflicts between attempted installs
of RealPlayer-10.0.3-1 and HelixPlayer-1.0.3-1', (6,
'/usr/lib/helix/plugins/smlrender.so', 0L))
('file /usr/lib/helix/plugins/smplfsys.so conflicts between attempted installs
of RealPlayer-10.0.3-1 and HelixPlayer-1.0.3-1', (6,
'/usr/lib/helix/plugins/smplfsys.so', 0L))
('file /usr/lib/helix/plugins/theorarend.so conflicts between attempted installs
of RealPlayer-10.0.3-1 and HelixPlayer-1.0.3-1', (6,
'/usr/lib/helix/plugins/theorarend.so', 0L))
('file /usr/lib/helix/plugins/vidsite.so conflicts between attempted installs of
RealPlayer-10.0.3-1 and HelixPlayer-1.0.3-1', (6,
'/usr/lib/helix/plugins/vidsite.so', 0L))
('file /usr/lib/helix/plugins/vorbisrend.so conflicts between attempted installs
of RealPlayer-10.0.3-1 and HelixPlayer-1.0.3-1', (6,
'/usr/lib/helix/plugins/vorbisrend.so', 0L))
('file /usr/lib/helix/plugins/wbmpfformat.so conflicts between attempted
installs of RealPlayer-10.0.3-1 and HelixPlayer-1.0.3-1', (6,
'/usr/lib/helix/plugins/wbmpfformat.so', 0L))
('file /usr/lib/helix/plugins/wbmprend.so conflicts between attempted installs
of RealPlayer-10.0.3-1 and HelixPlayer-1.0.3-1', (6,
'/usr/lib/helix/plugins/wbmprend.so', 0L))
('file /usr/lib/mozilla/plugins/nphelix.so conflicts between attempted installs
of RealPlayer-10.0.3-1 and HelixPlayer-1.0.3-1', (6,
'/usr/lib/mozilla/plugins/nphelix.so', 0L))
('file /usr/share/applications/realplay.desktop conflicts between attempted
installs of RealPlayer-10.0.3-1 and HelixPlayer-1.0.3-1', (6,
'/usr/share/applications/realplay.desktop', 0L))
 
Comment 3 Bill Nottingham 2005-03-22 22:49:13 EST
Assigning back to up2date.

Note that I feel the upgrade issue is not a bug; as they conflict and are
different implementations, one will obsolete the other.
Comment 4 Jack Neely 2005-03-29 15:42:01 EST
Bill,

Indeed RealPlayer does obsolete HelixPlayer.  Up2date seems to know this but it
attempts to install both packages anyway, resulting in the above traceback.

I RHEL 4 is in the very early deployment stages at NCSU and NONE of them can
retrieve updates via up2date.

I have also been able to duplicate with stock RHEL 4 WS for x86_64.  As soon as
I subscribed the machine to the Extras sub channel and up2date sees RealPlayer,
it attempts to install/upgrade them both even with the obsoletes.  I get the
identical traceback as above.
Comment 5 Kelly Setzer 2005-03-31 10:19:38 EST
We are testing RHEL4 WS for deployment.  We get the same traceback and resulting
failure.
Comment 6 Chris Melaro 2005-03-31 18:11:26 EST
Not sure why this is such a big deal, basically all that really needs to happen
is modifying the RPM SPEC files to change "Obsoletes" to "Conflicts" statements.

This gives the user the option of choosing which implementation they want and
not having rpm/up2date replace it with the other implementation.

Context diffs of spec files to resolve the problem follow...  

[root@rhel4es SPECS]# pwd
/usr/src/redhat/SPECS
[root@rhel4es SPECS]# diff -c pdksh.spec pdksh.spec.original
*** pdksh.spec  2005-03-31 17:50:13.338236983 -0500
--- pdksh.spec.original 2005-03-31 17:30:51.932565377 -0500
***************
*** 1,7 ****
  Summary: A public domain clone of the Korn shell (ksh).
  Name: pdksh
  Version: 5.2.14
! Release: 31
  License: Public Domain
  Group: System Environment/Shells
  Patch0: pdksh-5.2.14-manloc.patch
--- 1,7 ----
  Summary: A public domain clone of the Korn shell (ksh).
  Name: pdksh
  Version: 5.2.14
! Release: 30
  License: Public Domain
  Group: System Environment/Shells
  Patch0: pdksh-5.2.14-manloc.patch
***************
*** 12,18 ****
  URL: http://www.cs.mun.ca/~michael/pdksh/
  BuildRoot: %{_tmppath}/%{name}-%{version}-root
  PreReq: grep, fileutils
- Conflicts: ksh

  %description
  The pdksh package contains PD-ksh, a clone of the Korn shell (ksh).
--- 12,17 ----
[root@rhel4es SPECS]# diff -c ksh.spec ksh.spec.original
*** ksh.spec    2005-03-31 17:50:01.669016718 -0500
--- ksh.spec.original   2005-03-31 17:16:14.352118528 -0500
***************
*** 6,12 ****
  Group:        Applications/Shells
  License:      AT&T Open Source
  Version:      20040229
! Release:      13
  Source0:     
http://www.research.att.com/~gsf/download/tgz/ast-ksh.%{releasedate}.tgz
  Source1:     
http://www.research.att.com/~gsf/download/tgz/INIT.%{releasedate}.tgz
  Source2:     
http://www.research.att.com/~gsf/download/tgz/ast-base-locale.%{releasedate}.tgz
--- 6,12 ----
  Group:        Applications/Shells
  License:      AT&T Open Source
  Version:      20040229
! Release:      12
  Source0:     
http://www.research.att.com/~gsf/download/tgz/ast-ksh.%{releasedate}.tgz
  Source1:     
http://www.research.att.com/~gsf/download/tgz/INIT.%{releasedate}.tgz
  Source2:     
http://www.research.att.com/~gsf/download/tgz/ast-base-locale.%{releasedate}.tgz
***************
*** 19,25 ****
  Provides:     ksh93
  Obsoletes:    ksh93
  Provides:     pdksh
! Conflicts:    pdksh

  %description
  KSH-93 is the most recent version of the KornShell by David Korn of
--- 19,25 ----
  Provides:     ksh93
  Obsoletes:    ksh93
  Provides:     pdksh
! Obsoletes:    pdksh

  %description
  KSH-93 is the most recent version of the KornShell by David Korn of
[root@rhel4es SPECS]#
Comment 7 Jack Neely 2005-04-06 17:45:27 EDT
I have duplicated this bug on RHEL AS4.  Also tested with the recently released
up2date-4.4.5.6-2 package on both WS and AS.  No joy.  I cannot use the Extras
channel.
Comment 8 Jack Neely 2005-05-03 18:03:16 EDT
After further testing and debuging this looks like it may be an RPM issue rather
than up2date.  The __add() method in depSolver.py does the right thing.  When it
sees that RealPlayer obsoletes HelixPlayer it does the right thing by not adding
it to the transaction set and it does add RealPlayer as expected.

However, as soon as RealPlayer is added to the ts the ts reports that it
contains HelixPlayer.  HelixPlayer is never removed from the transaction and
ends up with RPM attempting to install it.
Comment 9 Jack Neely 2005-05-04 10:55:57 EDT
I lied.  That is actually the TE element for removing the old HelixPlayer
package currently on disk.  I've found the real problem this time and I have a
patch for you.

Suppose you have package foo-1-1 installed.  Running up2date it sees that there
is a updated package foo-2-1 and it sees that package bar obsoletes foo.  The
dependancy solver does the right thing and creates a set that installs bar and
removes foo.  However, the up2date.dryrun() method sees that there's an updated
foo package available and blindly assumes that foo must be updated.  So when
up2date.installPackages() is run it is handed a set that includes installs of
both foo-2-1 and bar.  This blows up.
Comment 10 Jack Neely 2005-05-04 10:58:21 EDT
Created attachment 114015 [details]
patch for up2date in batch mode

This patch fixes the above issues for batch mode.  The GUI mode still exibits
the bug.

Can some one look at getting this patched up soon?  This is a serious show
stopper.
Comment 11 Jack Neely 2005-05-04 13:29:35 EDT
Created attachment 114029 [details]
Patch to fix obsoletes in the GUI

This patch fixes the up2date GUI.

Really, in both cases up2date gets a perfect set of packages to install/update
from them dep resolver.  That's what up2date should follow.  But up2date just
throws that on the floor and uses what it thinks is right rather than what the
dep resolver *knows* is right.	This patch fixes this in the GUI code.
Comment 14 Adrian Likins 2005-05-17 19:43:10 EDT
up2date-4.4.19 should have the patches applied
Comment 15 Debbie McGrath 2005-06-08 14:01:13 EDT
This bug is considered MustFix for RHEL 4 U2 by RHN Engineering.
Comment 32 Beth Nackashi 2005-08-05 15:53:42 EDT
up2date-4.4.36-4 fails to install HelixPlayer on RHEL 4 AS U1, x86_64 ... This
needs to work before I can verify the rest of this bug:

[root@mspevack64 rhn]# rhn_check -vvv
D: check_action {'action': "<?xml
version='1.0'?>\n<methodCall>\n<methodName>packages.update</methodName>\n<params>\n<param>\n<value><array><data>\n<value><array><data>\n<value><string>HelixPlayer</string></value>\n<value><string>1.0.5</string></value>\n<value><string>0.EL4.1</string></value>\n<value><string>1</string></value>\n</data></array></value>\n</data></array></value>\n</param>\n</params>\n</methodCall>\n",
'version': 2, 'id': 24349382}
D: logininfo: {'X-RHN-Server-Id': 1005477120, 'X-RHN-Auth-Server-Time':
'1123271342.05', 'X-RHN-Auth': 's4y86NdAjkju0YfNm1S/rA==',
'X-RHN-Auth-Channels': [['rhel-x86_64-as-4', '20050805124442', '1', '1'],
['rhel-x86_64-as-4-extras', '20050727152413', '0', '1'],
['rhn-tools-rhel-4-as-x86_64', '20050804143047', '0', '1']],
'X-RHN-Auth-User-Id': '', 'X-RHN-Auth-Expire-Offset': '3600.0'}
D: handle_action {'action': "<?xml
version='1.0'?>\n<methodCall>\n<methodName>packages.update</methodName>\n<params>\n<param>\n<value><array><data>\n<value><array><data>\n<value><string>HelixPlayer</string></value>\n<value><string>1.0.5</string></value>\n<value><string>0.EL4.1</string></value>\n<value><string>1</string></value>\n</data></array></value>\n</data></array></value>\n</param>\n</params>\n</methodCall>\n",
'version': 2, 'id': 24349382}
D: handle_action actionid = 24349382, version = 2
D: do_call packages.update ([['HelixPlayer', '1.0.5', '0.EL4.1', '1']],)
D: Called update_packages [['HelixPlayer', '1.0.5', '0.EL4.1', '1']]
D: availablePackageList::channels: <up2date_client.rhnChannel.rhnChannelList
instance at 0x2a9a8f7518>
D: listPackages Fetched via: diskcache
D: listPackages Fetched via: diskcache
D: listPackages Fetched via: diskcache
D: obsoletesList::channels: <up2date_client.rhnChannel.rhnChannelList instance
at 0x2a9a8f7518>
D: getObsoletes Fetched via: diskcache
D: getObsoletes Fetched via: diskcache
D: getObsoletes Fetched via: diskcache
D: archscore 7
D: archscore 1

Name                                    Version        Rel
----------------------------------------------------------
HelixPlayer                             1.0.5          0.EL4.1           i386
No advisory information available


D: Called dryRun [['HelixPlayer', '1.0.5', '0.EL4.1', '1', 'i386', '3997060',
'rhel-x86_64-as-4']]
D: obsoletesList::channels: <up2date_client.rhnChannel.rhnChannelList instance
at 0x2a9a8f7518>
D: getObsoletes Fetched via: diskcache
D: getObsoletes Fetched via: diskcache
D: getObsoletes Fetched via: diskcache
D: add instance class name up2date
D: Removing package (['kernel', '2.6.9', '11.EL', '', 'x86_64', '10607496',
'rhel-x86_64-as-4'], 'Pkg name/pattern')
D: Removing package (['kernel-devel', '2.6.9', '11.EL', '', 'x86_64', '3674100',
'rhel-x86_64-as-4'], 'Pkg name/pattern')
D: Removing package (['kernel-doc', '2.6.9', '11.EL', '', 'noarch', '2096141',
'rhel-x86_64-as-4'], 'Pkg name/pattern')
D: Removing package (['kernel-hugemem-devel', '2.6.9', '5.EL', '', 'i686',
'3751363', 'rhel-x86_64-as-4'], 'Pkg name/pattern')
D: Removing package (['kernel-smp', '2.6.9', '11.EL', '', 'x86_64', '9941203',
'rhel-x86_64-as-4'], 'Pkg name/pattern')
D: Removing package (['kernel-smp-devel', '2.6.9', '11.EL', '', 'x86_64',
'3686888', 'rhel-x86_64-as-4'], 'Pkg name/pattern')
D: Removing package (['kernel-utils', '2.4', '13.1.66', '1', 'x86_64', '539037',
'rhel-x86_64-as-4'], 'Pkg name/pattern')
D: Candidates for the selected list: [['HelixPlayer', '1.0.5', '0.EL4.1', '1',
'i386', '3997060', 'rhel-x86_64-as-4']]
D: Checking for dependencies
D: Running transaction (final step)...

The following packages you requested are already updated:
HelixPlayer
D: Sending back response (0, 'Packages were installed successfully', {})
D: do_call packages.checkNeedUpdate ('rhnsd=1',)
D: local action status:  (0, 'rpm database not modified since last update (or
package list recently updated)', {})
[root@mspevack64 rhn]# rpm -q HelixPlayer
package HelixPlayer is not installed
Comment 33 Jason Connor 2005-08-24 12:43:40 EDT
Beth,

The above error message seems consitent with having RealPlayer installed and
up-to-date. Because RealPlayer obsoletes HelixPlayer, rpm will tell you that the
package, HelixPalyer, is up-to-date because RealPlayer is up-to-date.

Kinda convoluted, I know. But the behavior is correct, even if the error message
obfuscates the real meaning.

I did my testing on fmoquete-64.rdu, rhel4 u1, with up2date-4.4.42-4

The box is still setup (though currenly registered to my production account).
It's still got RealPlayer installed, but I'm done with it for the time being, so
feel free to use it to verify the changes that were made to up2date.
Comment 34 Beth Nackashi 2005-08-25 16:59:00 EDT
verified fix on RHEL 4 U1 AS i386 with up2date-4.4.42-4
Comment 35 Todd Warner 2005-09-23 16:31:57 EDT
PROD_READY-->RELEASE_PENDING
Comment 37 Red Hat Bugzilla 2005-10-05 13:13:31 EDT
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on the solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2005-711.html

Note You need to log in before you can comment on or make changes to this bug.