Bug 1489521 - subscription-manager-cockpit - no feedback when deregistering a system and a server is down
Summary: subscription-manager-cockpit - no feedback when deregistering a system and a ...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: subscription-manager
Version: 7.5
Hardware: Unspecified
OS: Unspecified
medium
medium
Target Milestone: rc
: ---
Assignee: Jiri Hnidek
QA Contact: Jan Stavel
URL:
Whiteboard:
Depends On: 1516439
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-09-07 15:39 UTC by Jan Stavel
Modified: 2018-04-10 09:51 UTC (History)
5 users (show)

Fixed In Version: subscription-manager-1.20.10-1
Doc Type: No Doc Update
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-04-10 09:51:13 UTC
Target Upstream Version:


Attachments (Terms of Use)
an error message when candlepin is down and proxy is used (36.53 KB, image/png)
2018-02-01 10:03 UTC, Jan Stavel
no flags Details


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2018:0681 None None None 2018-04-10 09:51:43 UTC
Github candlepin subscription-manager pull 1733 None None None 2017-11-24 11:37:33 UTC

Description Jan Stavel 2017-09-07 15:39:32 UTC
Description of problem:

subscription-manager-cockpit does not give any feedback when candlepin server is not reachable and I want to unregister  system

Version-Release number of selected component (if applicable):


How reproducible:

Each time.

Steps to Reproduce:
Given a system is registered 
   and I openned cockpit subscription page

When I click on 'Unregister' button
then I see a rotating icon
   and the icon disappears after a short while
   and I see 'Unregister' button again.


Actual results:

Nothing displayed about a problem with reaching the server.

Expected results:

a sort of 'The server is unreachable now. Please check the network connection.'


Additional info:

I was out of VPN so a name resolution for the server name failed.

an info about network problem appears in /etc/rhsm/rhsm.log

3412341235', '100000000000020', '32060', '99010', '88888', '900', '908', '98121', '806', '917571', '37080', '801', '6051', '6050', '37070']
2017-09-07 17:30:09,607 [DEBUG] subscription-manager:20019:MainThread @connection.py:516 - Making request: GET /subscription/consumers/04e479cd-9a1b-4d83-bda9-c
9878fd4aff3/compliance
2017-09-07 17:30:09,610 [ERROR] subscription-manager:20019:MainThread @cache.py:229 - [Errno -2] Name or service not known
2017-09-07 17:30:09,610 [WARNING] subscription-manager:20019:MainThread @cache.py:235 - Unable to reach server, using cached status.

Comment 2 Jiri Hnidek 2017-11-22 15:34:57 UTC
I can reproduce this bug report. I'm taking this bug.

Comment 6 Jan Stavel 2018-02-01 10:03:37 UTC
Created attachment 1389439 [details]
an error message when candlepin is down and proxy is used

Comment 7 Jan Stavel 2018-02-01 10:04:01 UTC
It just works!

Comment 10 errata-xmlrpc 2018-04-10 09:51:13 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2018:0681


Note You need to log in before you can comment on or make changes to this bug.