Bug 1489529 - perl-XML-LibXML-2.0129-7.fc28 FTBFS: tests fail with libxml2-2.9.5
Summary: perl-XML-LibXML-2.0129-7.fc28 FTBFS: tests fail with libxml2-2.9.5
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: perl-XML-LibXML
Version: 27
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Petr Pisar
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On: 1493613
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-09-07 15:56 UTC by Petr Pisar
Modified: 2018-04-13 13:57 UTC (History)
9 users (show)

Fixed In Version: perl-XML-LibXML-2.0129-8.fc28
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-04-13 13:57:46 UTC
Type: Bug


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
CPAN 122958 None None None 2017-09-07 15:56:24 UTC

Description Petr Pisar 2017-09-07 15:56:24 UTC
perl-XML-LibXML-2.0129-7.fc28 fails to build in F28 because tests fail:

t/31xpc_functions.t ................................ ok

#   Failed test ' TODO : Add test name'
#   at t/32xpc_variables.t line 114.
# Looks like you failed 1 test of 35.
t/32xpc_variables.t ................................
Dubious, test returned 1 (wstat 256, 0x100)
Failed 1/35 subtests
[...]
t/48_memleak_rt_83744.t ............................ ok

#   Failed test 'xml_reader is undef'
#   at t/48_reader_undef_warning_on_empty_str_rt106830.t line 33.
# Looks like you failed 1 test of 2.
t/48_reader_undef_warning_on_empty_str_rt106830.t ..
Dubious, test returned 1 (wstat 256, 0x100)
Failed 1/2 subtests

This is caused by upgrading libxml2-devel from 2.9.4-5.fc28 to
2.9.5-1.fc28.

The 2.9.5 was pushed to Fedora ≥ 27.

Comment 1 Petr Pisar 2017-09-20 15:29:02 UTC
I pushed the fix for t/48_reader_undef_warning_on_empty_str_rt106830.t into perl-XML-LibXML. I will rebuild this package once libxml2 fixes the second bug causing failing t/32xpc_variables.t.

Comment 2 Fedora Update System 2017-09-25 07:33:45 UTC
perl-XML-LibXML-2.0129-8.fc27 has been submitted as an update to Fedora 27. https://bodhi.fedoraproject.org/updates/FEDORA-2017-eb3fae70d6

Comment 3 Fedora Update System 2017-09-25 16:23:05 UTC
perl-XML-LibXML-2.0129-8.fc27 has been pushed to the Fedora 27 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2017-eb3fae70d6

Comment 4 Fedora Update System 2017-09-30 06:54:14 UTC
perl-XML-LibXML-2.0129-8.fc27 has been pushed to the Fedora 27 stable repository. If problems still persist, please make note of it in this bug report.

Comment 5 Fedora Update System 2018-02-27 13:01:43 UTC
perl-XML-LibXML-2.0129-3.fc26 has been submitted as an update to Fedora 26. https://bodhi.fedoraproject.org/updates/FEDORA-2018-7efc906066

Comment 6 Fedora Update System 2018-02-27 18:01:26 UTC
perl-XML-LibXML-2.0129-3.fc26 has been pushed to the Fedora 26 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2018-7efc906066

Comment 7 Fedora Update System 2018-03-13 17:15:49 UTC
perl-XML-LibXML-2.0129-3.fc26 has been pushed to the Fedora 26 stable repository. If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.