Bug 148958 - Upgrade to Version 1.2.0
Upgrade to Version 1.2.0
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: pgadmin3 (Show other bugs)
3
All Linux
medium Severity medium
: ---
: ---
Assigned To: Gavin Henry
Fedora Extras Quality Assurance
: FutureFeature
Depends On: 154618
Blocks:
  Show dependency treegraph
 
Reported: 2005-02-17 07:30 EST by Gavin Henry
Modified: 2007-11-30 17:11 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-11-14 22:59:43 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Gavin Henry 2005-02-17 07:30:23 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.5)
Gecko/20041111 Firefox/1.0

Description of problem:


Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
N/A
    

Additional info:
Comment 1 Michael Schwendt 2005-02-24 03:21:24 EST
[package owner's e-mail address gives 550 user unknown - reassigning to
extras-orphan]
Comment 2 Gavin Henry 2005-02-24 03:37:07 EST
I could claim this if you like, as it's in the Fedora Extras Orphan
list now?
Comment 3 Nils O. Selåsdal 2005-02-24 06:24:39 EST
>I could claim this if you like, as it's in the Fedora Extras Orphan
list now?

Please go ahead, I have my hands full at the time ;)
Comment 4 Gavin Henry 2005-02-24 07:49:08 EST
OK, I'll get the SRPM and get to work.

If you want it back anytime, just say the word.

Gavin.
Comment 5 Michael Schwendt 2005-02-24 09:14:54 EST
Component owner change requested. Also requested assignment of
cpan2rpm and john to Gavin.
Comment 6 Gavin Henry 2005-02-24 11:04:36 EST
I have updated the specfile and tried rebuilt the SRPM.

apparantly pgadmin3 needs wxWidgets 2.5.3

Does our latest version include any of this?

Because configure fails on:

configure: error: you need to install the stc package from
wxWindows/contrib/src/stc

but wxGTKs-stc is installed.
Comment 7 Michael Schwendt 2005-02-24 16:22:30 EST
2.5.x is the development tree of wxWidgets and not available in Fedora
Extras. Once it was in fedora.us, but was pulled due to lack of API
users and lack of stability.
Comment 8 Terry Wilson 2005-07-16 10:25:43 EDT
This package still needs to be upgraded, especially now that postgresql 8 is
distributed with fc4 as pgadmin 1.0 does not support postgresql 8.
Comment 9 Gavin Henry 2005-07-16 10:52:07 EDT
There is already a FC4 S/RPM here:

ftp://ftp.postgresql.org/pub/pgadmin3/release/v1.2.2/fedora-core-4/

Current maintainer for that is:

* Devrim Gunduz <devrim@gunduz.org>
* PGP Key: http://www.gunduz.org/devrimgunduz.pgp.pub

Should I review his specfile and ask if he would like to maintain it, or keep
ownership?

Thanks.
Comment 10 Michael Schwendt 2005-07-16 18:53:43 EDT
wxWidgets/GTK >= 2.6 needed, right?
Comment 11 Gavin Henry 2005-07-17 03:26:42 EDT
Don't think so. I have installed his RPM with wxGTK2-2.4.2-12 installed. 
  
Then again, I have just checked his SPEC file and noticed that he lists no build requirements,  
which is very strange.  
  
Gavin.  
Comment 12 Toshio Kuratomi 2005-09-02 12:10:28 EDT
$ rpm -qp --requires pgadmin3-1.2.2-2.i686.rpm |grep -i wx
$
[From the spec]
%configure --enable-static --with-wx-config=%{withwxconfig} --with-wx=/usr/local
--disable-debug

So he's compiling with wxGTK static.  A valid choice for him since he's
distributing to several rpm based distro's where he can't depend on having
wxGTK-2.6.

For our use, we'll need wxGTK-2.6 in order to use this.
Comment 13 Matthew Miller 2005-11-30 16:19:20 EST
Okay, so we now have wxGTK-2.6 in the devel branch.
Comment 14 Gavin Henry 2005-12-07 03:18:54 EST
Rebulding and releasing today, to version 1.4.0

Sorry for the massive delay.
Comment 15 Gavin Henry 2005-12-08 17:19:42 EST
Updated specfiles. Imported new sources and requested builds in FC4 extras and
Devel.

Gavin.
Comment 16 Andy Burns 2005-12-18 09:31:46 EST
Did this get tangled up in the jump to GCC 4.1?

I thought I saw it on the build system queue a few days ago, 
but no sign of it now ...
Comment 17 Gavin Henry 2005-12-18 13:48:04 EST
It was on the build system, but failed on x86_64 like a few of my other
packages, due to bad libs.
Comment 18 Andy Burns 2006-02-26 17:39:44 EST
Working nicely in 1.4.1-2 (on x86_64)
Comment 19 Christian Iseli 2007-01-19 18:47:13 EST
FC3 and FC4 have now been EOL'd.

Please check the ticket against a current Fedora release, and either adjust the
release number, or close it if appropriate.

Thanks.

Your friendly BZ janitor :-)
Comment 20 Joshua Daniel Franklin 2007-11-14 13:11:57 EST
This bug is showing up in my pgadmin3 bugzilla searches.

It's old and should probably be closed. 
Comment 21 Devrim GUNDUZ 2007-11-14 22:59:43 EST
Closing this bug, it is too old.

Note You need to log in before you can comment on or make changes to this bug.