Bug 148960 - RFE: build with --enable-sqlite
Summary: RFE: build with --enable-sqlite
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: php (Show other bugs)
(Show other bugs)
Version: rawhide
Hardware: All Linux
medium
medium
Target Milestone: ---
Assignee: Joe Orton
QA Contact: David Lawrence
URL:
Whiteboard:
Keywords: FutureFeature, Reopened
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-02-17 12:58 UTC by Adriaan Peeters
Modified: 2007-11-30 22:11 UTC (History)
1 user (show)

Fixed In Version: 5.1.1-2
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-08-24 18:52:33 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Adriaan Peeters 2005-02-17 12:58:37 UTC
please build php5 package with sqlite support

Comment 1 Joe Orton 2005-02-17 17:11:47 UTC
I'm not encouraged about doing this:

1) after seeing the number of compiler warnings in the bundled copy of
the sqlite2 source code (64-bit unsafe?)

2) the distro now already includes a sqlite3 package, yet the PHP
extension only works with sqlite 2 - I would much prefer to ship an
sqlite extension which works with sqlite3


Comment 2 Joe Orton 2005-04-06 08:34:59 UTC
Marking as DEFERRED for the moment, until PHP supports sqlite3.

Comment 3 Matthew Miller 2006-08-24 18:32:18 UTC
Looks like there is a "PDO-SQLITE" which supports sqlite3:

http://www.php.net/manual/en/ref.pdo-sqlite.php

Comment 4 Matthew Miller 2006-08-24 18:52:33 UTC
Err, and further, it looks like this is enabled and built as part of the php-pdo
subpackage. So, moving to resolved -- I'm pretty sure, from the changelog, in
php-5.1.1-2.

Comment 5 Matthew Miller 2006-08-24 18:54:05 UTC
Although. it seems like a good idea to mention SQlite in the description (and
summary?) of the php-pdo subpackage, yeah?

Comment 6 Joe Orton 2006-08-29 07:29:04 UTC
Good idea Matt - done for future builds, thanks.


Note You need to log in before you can comment on or make changes to this bug.