Bug 1489677 - [downstream clone - 4.1.7] If VM is down and 'run_on_vds' is still set, errors are reported in engine and server logs
Summary: [downstream clone - 4.1.7] If VM is down and 'run_on_vds' is still set, error...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-engine
Version: 4.1.2
Hardware: Unspecified
OS: Linux
medium
high
Target Milestone: ovirt-4.1.7
: ---
Assignee: Arik
QA Contact: Nisim Simsolo
URL:
Whiteboard:
Depends On: 1487728
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-09-08 06:20 UTC by rhev-integ
Modified: 2021-05-01 16:51 UTC (History)
12 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of: 1487728
Environment:
Last Closed: 2017-11-07 17:27:54 UTC
oVirt Team: Virt
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Red Hat Product Errata RHEA-2017:3138 0 normal SHIPPED_LIVE Red Hat Virtualization Manager (ovirt-engine) 4.1.7 2017-11-07 22:22:33 UTC
oVirt gerrit 81412 0 master MERGED core: update the required fields when vm disappears 2020-12-14 12:53:33 UTC
oVirt gerrit 81517 0 ovirt-engine-4.1 MERGED core: update the required fields when vm disappears 2020-12-14 12:53:35 UTC
oVirt gerrit 81518 0 ovirt-engine-4.1 MERGED core: prevent NPE when vm disappears from the host 2020-12-14 12:53:33 UTC
oVirt gerrit 82518 0 ovirt-engine-4.1 MERGED core: clear migrating_to_vds when migration ends unexpectedly 2020-12-14 12:53:33 UTC

Description rhev-integ 2017-09-08 06:20:19 UTC
+++ This bug is a downstream clone. The original bug is: +++
+++   bug 1487728 +++
======================================================================

Description of problem:

If 'run_on_vds' in the vm_dynamic table in the RHV database contains a host id, but the VM is actually down, the engine will report the following;

- engine.log;

2017-08-31 07:43:23,615+05 INFO  [org.ovirt.engine.core.vdsbroker.monitoring.VmAnalyzer] (DefaultQuartzScheduler1) [] VM '6be6956f-b8b8-4a33-bb37-30334702b8b9'(cdvpgweb03) is running in db and not running on VDS 'e31634bf-d4a0-47e8-ba81-d49c280acaa3'(dch12bl13.cbec.gov.in)

2017-08-31 07:43:23,623+05 ERROR [org.ovirt.engine.core.utils.timer.SchedulerUtilQuartzImpl] (DefaultQuartzScheduler1) [] Failed to invoke scheduled method poll: null


- server.log;

2017-08-31 07:43:23,623+05 INFO  [org.quartz.core.JobRunShell] (DefaultQuartzScheduler1) Job DEFAULT.org.ovirt.engine.core.vdsbroker.monitoring.PollVmStatsRefresher.poll#-9223372036854775759 threw a JobExecutionException: : org.quartz.JobExecutionException: failed to execute job



Version-Release number of selected component (if applicable):

RHV 4.1.2
RHVH 7.3 hosts


How reproducible:

100% if you force it to happen.


Steps to Reproduce:
1. Check VM is not running.
2. Set 'run_on_vds' in vm_dynamic to a valid host uuid.
3. Check engine and server logs.


Actual results:


Expected results:


Additional info:

(Originally by Gordon Watson)

Comment 5 rhev-integ 2017-09-08 06:20:41 UTC
They are not normal either way, but the host was responding, actually.
We should deal with the exception more gracefully, no matter how it happened (it may be restore from a backup)

(Originally by michal.skrivanek)

Comment 6 rhev-integ 2017-09-08 06:20:46 UTC
do we want also a 4.1 backport of https://gerrit.ovirt.org/#/c/81560/ ?

(Originally by michal.skrivanek)

Comment 10 errata-xmlrpc 2017-11-07 17:27:54 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHEA-2017:3138


Note You need to log in before you can comment on or make changes to this bug.