Bug 14897 - sawfish conflicts between librep and librep_helix packages
Summary: sawfish conflicts between librep and librep_helix packages
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: sawfish   
(Show other bugs)
Version: 7.0
Hardware: i386 Linux
medium
medium
Target Milestone: ---
Assignee: Jonathan Blandford
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2000-07-31 17:41 UTC by Tammy Fox
Modified: 2013-04-02 04:14 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-10-04 19:27:12 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Tammy Fox 2000-07-31 17:41:02 UTC
When upgrading from a stock 6.2 system with helix-gnome added, sawfish
consistently fails to run with the following error:

[tfox@falcon tfox]$ rpm -q librep
librep-0.12.3-0_helix_1
[tfox@falcon tfox]$ sawfish --display=:0.0
Xlib:  extension "XINERAMA" missing on display ":0.0".
sawfish: error while loading shared libraries: /usr/lib/librep.so.9:
undefined symbol: mpz_init_set_ui
[tfox@falcon tfox]$

basically, the librep helix package has problems with the pinstripe sawfish
... this problem did not occur when using enlightenment as the window
manager ...

Comment 1 Tammy Fox 2000-07-31 19:36:57 UTC
the problem was that the helix librep version is higher than the pinstripe
librep version ... downgrading librep (and librep-devel) to the versions shipped
in pinstripe fixed the sawfish problem ...

Comment 2 David Mason 2000-08-01 15:11:31 UTC
jrb - we need to figure out the upgrade path for those already running sawfish -
especially the helix ones as they seem to be breaking all over the place (at
least according to the sawfish mail list)

Comment 3 Alan Cox 2000-08-05 21:24:33 UTC
The upgrade path I gave out is simple

rpm --erase `rpm -qa |grep helix-`
Upgrade
Then optionally add the Helix packages.


Comment 4 Dax Kelson 2000-09-14 19:50:22 UTC
Surely you mean "helix_" not "helix-".

[guru@dhcp1 guru]$ rpm -qa |grep helix_ | wc -l
    109
[guru@dhcp1 guru]$ rpm -qa |grep helix- | wc -l
      2



Comment 5 Tammy Fox 2000-10-04 19:27:09 UTC
Was this fixed?  Can it be closed?

Comment 6 Havoc Pennington 2000-12-05 16:01:20 UTC
It's as fixed as it's going to get. Hopefully jrb won't mind if I close it. ;-)


Note You need to log in before you can comment on or make changes to this bug.