Bug 1489777 - [EC2] IPv6 address isn't assigned inside guest automatically.
Summary: [EC2] IPv6 address isn't assigned inside guest automatically.
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: ec2-images
Version: 7.4
Hardware: Unspecified
OS: Unspecified
high
high
Target Milestone: rc
: ---
Assignee: Jon Disnard
QA Contact: Vratislav Hutsky
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-09-08 11:19 UTC by Chen Shi
Modified: 2019-12-06 02:44 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-01-17 01:27:47 UTC
Target Upstream Version:


Attachments (Terms of Use)

Description Chen Shi 2017-09-08 11:19:27 UTC
Description of problem:
When we test EC2 IPv6 features, found that the IPv6 address is not recognized on the instance automatically. Additional steps still need to be applied for RHEL7.4 to use the assigned IPv6 address.

Version-Release number of selected component (if applicable):
Red Hat Enterprise Linux 7.4 (HVM), SSD Volume Type - ami-30ef0556

How reproducible:
100%

Steps to Reproduce:
1. Lunch instance over t2.micro
2. In lunch wizard, "Configure Instance" page, enable "Auto-assign IPv6 IP".
3. You can get IPv6 address from "Description" of this instance.
4. ping6 <ipv6 address> can't be reached from the Internet or peer guest, but ping6 <fe80:......%eth0> works well from peer guest (which means security group allows ICMP-IPV6).
5. Assigned IPv6 can't be seen from "ifconfig".
6. Follow instruction http://docs.aws.amazon.com/AmazonVPC/latest/UserGuide/vpc-migrate-ipv6.html#ipv6-dhcpv6-rhel to configure IPv6 in RHEL guest.
7. After that IPv6 can be seen and ping6 works with assigned ipv6 address.

Actual results:
1. IPv6 address can't be recognized on the instance automatically.
2. IPv6 address can't be seen from "ifconfig" without manually doing additional steps.
3. IPv6 address can't be reached by ping6 from other hosts without manually doing additional steps.

Expected results:
Assigned IPv6 address can be recognized on the instance automatically. And this address should able to be reached.

Additional info:
1. Cold-add and Warm-add IPv6 can be automatically recognized by AMZN Linux.
2. Hot-add IPv6 address in AMZN Linux:
    a) if it is the first IPv6 address, can be automatically recognized.
    b) if it is not the first IPv6, need to restart the network service.

Comment 4 Vitaly Kuznetsov 2018-07-12 14:47:54 UTC
I generally agree we need to enable this by default and Lin's comment#3 how to do this seems to be correct. But before implementing the change there's one thing I wanted to confirm: what's the current situation with Amazon Linux 1 and 2 AMIs? Do they have this enabled by default?

Comment 5 Chen Shi 2018-07-13 09:18:55 UTC
(In reply to Vitaly Kuznetsov from comment #4)
> I generally agree we need to enable this by default and Lin's comment#3 how
> to do this seems to be correct. But before implementing the change there's
> one thing I wanted to confirm: what's the current situation with Amazon
> Linux 1 and 2 AMIs? Do they have this enabled by default?

Create VM with AMZN AMI [1] in the VPC which Auto-assign IPv6 IP, we can see the IPv6 address has been assigned by default after creating VM.

[ec2-user@ip-10-22-2-12 ~]$ ifconfig eth0 | grep inet6
          inet6 addr: fe80::c:42ff:fe04:a6c8/64 Scope:Link
          inet6 addr: 2600:1f14:bb0:d002:6630:3369:23b1:faac/64 Scope:Global
[ec2-user@ip-10-22-2-12 ~]$ cd /etc/cloud
[ec2-user@ip-10-22-2-12 cloud]$ grep -i dhcp -R *
[ec2-user@ip-10-22-2-12 cloud]$ 


Create VM with AMZN2 AMI [2] in the VPC which Auto-assign IPv6 IP, we can see the IPv6 address has been assigned by default after creating VM.

[ec2-user@ip-10-22-2-158 ~]$ ifconfig eth0 | grep inet6
        inet6 2600:1f14:bb0:d002:3648:f0e0:2786:ab69  prefixlen 64  scopeid 0x0<global>
        inet6 fe80::9c:34ff:feaa:3918  prefixlen 64  scopeid 0x20<link>
[ec2-user@ip-10-22-2-158 ~]$ cd /etc/cloud
[ec2-user@ip-10-22-2-158 cloud]$ grep -i dhcp -R *
[ec2-user@ip-10-22-2-158 cloud]$ 


[1] amzn-ami-hvm-2018.03.0.20180622-x86_64-gp2 (ami-0ad99772)
[2] amzn2-ami-hvm-2.0.20180622.1-x86_64-gp2 (ami-a9d09ed1)


Note You need to log in before you can comment on or make changes to this bug.