Bug 148985 - Sound works on laptop with no speakers plugged in, no sound when speakers are in
Sound works on laptop with no speakers plugged in, no sound when speakers are in
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
3
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Dave Jones
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-02-17 14:06 EST by Gabriel Matthews
Modified: 2015-01-04 17:17 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-02-17 16:49:39 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Gabriel Matthews 2005-02-17 14:06:17 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.5) Gecko/20041111 Firefox/1.0

Description of problem:
I apologize, as always, as I'm not a master of linux stuff.. so if you need more info, or if I've incorrectly categorized this as 'kernel' related, please forgive me.

I have a dell latitude D600, running BIOS A15 (latest).  I have installed Fedora Core 3, and this problem has existed from the vanilla install all the way up to now, and I am fully up to date.

My soundcard is being detected as an Intel Corp. 82801DB/DBL/DBM (ICH4/ICH4-L/ICH4-M) AC'97 Audio Controller.

When I do the soundcard test, it plays the sound just fine. I can hear music and GAIM sounds and gnome-sounds and all sorts of stuff through the onboard speakers.. when I plug in my speakers to the soundcard, there is no sound produced.  My theory is because the soundcard seems to have some level of intelligence that decides when something is plugged into the jack, it disables the onboard speakers.. logical, but it seems that something in my fc3 install, kernel or module or something, isn't picking up that change.  I've rebooted the machine with the speakers plugged in, thinking that maybe it needs to detect it in that plugged-in state, but no help.  I have even compiled my own kernel from kernel.org, the 2.6.10 variety with no other patches or anything, and it still has that problem..  I've used different speakers, headphones, etc, to rule out if it's externally related, and it doesn't seem to be.

I can provide any further information, output of /proc/pci or whatever, just let me know what you need.. This is a minor but annoying thing that makes me want to go back to windows just to listen to some music.. (My office is in a server room, and the little speakers don't put out enough low-mid to hear anything over all the noise, so I am music-less. :(

Thanks for your help with this!

Version-Release number of selected component (if applicable):
kernel-2.6.10-1.766_FC3

How reproducible:
Always

Steps to Reproduce:
1.Plug in speakers, headphones, etc
2.No sound comes out, no matter how high I increase the levels
3.Unplug speakers from jack, and music comes out from internal speakers on laptop

Additional info:
Comment 1 Joel Rittvo 2005-02-17 14:33:01 EST
On my Dell Inspiron, the KDE mixer applet shows a slider for
"headphones" that controls the jack.  I'm suspect you have the same
(in Gnome or KDE) and it is either disabled or turned all the way
down.  This is different from in Windows, where I have never seen
settings specifically for the headphone jack.
Comment 2 Gabriel Matthews 2005-02-17 16:49:39 EST
Dude.. You have got to be joking me.  That was it.  I didn't even
think to check that.. I didn't realize there would be those kinds of
settings.. HA!  So, rather than there not being enough support for the
soundcard, it's actually supported quite well.. interesting.. :)  The
odd part though is that that's muted by default..  but oh well, at
least I know now.. thanks for your help.. :)

Note You need to log in before you can comment on or make changes to this bug.