Bugzilla (bugzilla.redhat.com) will be under maintenance for infrastructure upgrades and will not be unavailable on July 31st between 12:30 AM - 05:30 AM UTC. We appreciate your understanding and patience. You can follow status.redhat.com for details.
Bug 1489884 - [RFE] rebase llvm/clang to 5.0
Summary: [RFE] rebase llvm/clang to 5.0
Keywords:
Status: CLOSED WONTFIX
Alias: None
Product: Fedora EPEL
Classification: Fedora
Component: llvm
Version: epel7
Hardware: All
OS: Linux
unspecified
unspecified
Target Milestone: ---
Assignee: Dave Johansen
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-09-08 14:50 UTC by Pat Riehecky
Modified: 2017-12-21 04:59 UTC (History)
11 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-12-21 04:59:20 UTC
Type: Bug


Attachments (Terms of Use)

Description Pat Riehecky 2017-09-08 14:50:12 UTC
Description of problem:
Can llvm/clang be rebased to the recently published 5.0 version?

Additional info:
http://releases.llvm.org/download.html#5.0.0
http://releases.llvm.org/5.0.0/docs/ReleaseNotes.html

Comment 1 Josh Stone 2017-09-08 16:22:35 UTC
I expect the more likely path is to create a new llvm5 package, like the current llvm3.9.  (nobody bothered with llvm4 though...)

Comment 2 Tom Stellard 2017-09-08 18:06:02 UTC
I've started working on this, and I'm waiting for a side-tag to be created for rawhide: https://pagure.io/releng/issue/6927

Comment 3 Josh Stone 2017-09-08 20:23:46 UTC
Tom, note this RFE is for epel7.

Comment 4 Tom Stellard 2017-09-08 22:01:16 UTC
(In reply to Josh Stone from comment #3)
> Tom, note this RFE is for epel7.

Ah thanks, I missed that.

Comment 5 Tom Stellard 2017-09-08 22:01:52 UTC
Review request for llvm4.0 package: https://bugzilla.redhat.com/show_bug.cgi?id=1489983

Comment 6 Jens Petersen 2017-12-21 04:59:20 UTC
(In reply to Josh Stone from comment #1)
> I expect the more likely path is to create a new llvm5 package, like the
> current llvm3.9.  (nobody bothered with llvm4 though...)

Right, rebase is not really acceptable for EPEL for this important component.

llvmXY packages from Fedora should be built for EPEL 7.


Note You need to log in before you can comment on or make changes to this bug.